Note: Version v201808 will be sunset soon. All users of those versions must migrate to a newer one.

type LineItemOperationError (v201905)

Lists all errors for executing operations on line items


Namespace
https://www.google.com/apis/ads/publisher/v201905

Field

ApiError (inherited)

fieldPath

xsd:string

The OGNL field path to identify cause of error.

fieldPathElements

FieldPathElement[]

A parsed copy of the field path. For example, the field path "operations[1].operand" corresponds to this list: {FieldPathElement(field = "operations", index = 1), FieldPathElement(field = "operand", index = null)}.

trigger

xsd:string

The data that caused the error.

errorString

xsd:string

A simple string representation of the error and reason.

LineItemOperationError

reason

LineItemOperationError.Reason

The error reason represented by an enum.


Enumerations
NOT_ALLOWED
The operation is not allowed due to lack of permissions.
NOT_APPLICABLE
The operation is not applicable for the current state of the LineItem.
HAS_COMPLETED
The LineItem is completed. A LineItemAction cannot be applied to a line item that is completed.
HAS_NO_ACTIVE_CREATIVES
The LineItem has no active creatives. A line item cannot be activated with no active creatives.
CANNOT_ACTIVATE_LEGACY_DFP_LINE_ITEM
A LineItem of type LineItemType.LEGACY_DFP cannot be Activated.
CANNOT_ACTIVATE_UNCONFIGURED_LINE_ITEM
A LineItem with publisher creative source cannot be activated if the corresponding deal is not yet configured by the buyer.
CANNOT_DELETE_DELIVERED_LINE_ITEM
Deleting an LineItem that has delivered is not allowed
CANNOT_RESERVE_COMPANY_CREDIT_STATUS_NOT_ACTIVE
Reservation cannot be made for line item because the LineItem.advertiserId it is associated with has Company.creditStatus that is not ACTIVE or ON_HOLD.
CANNOT_ACTIVATE_INVALID_COMPANY_CREDIT_STATUS
Cannot activate line item because the LineItem.advertiserId it is associated with has Company.creditStatus that is not ACTIVE, INACTIVE, or ON_HOLD.
UNKNOWN
The value returned if the actual value is not exposed by the requested API version.