Google is committed to advancing racial equity for Black communities. See how.

ARCore Cloud Anchor service deprecation policy

Note: The following deprecation policy applies only to apps built using ARCore SDK 1.12.0 or later and their use of the Cloud Anchors API. Apps built with ARCore SDK 1.11.0 and earlier will not be able to host or resolve Cloud Anchors beginning December 2020, due to the SDK’s use of an older deprecated ARCore Cloud Anchor service.

Should Google decide to discontinue support for the services and functionality provided by Cloud Anchors and the ARCore Cloud Anchor service introduced in ARCore 1.12.0, Google will announce this decision in the ARCore release notes and in What’s New in ARCore, and make commercially reasonable efforts to continue to operate these services for one year after that announcement.

However, Google may discontinue support earlier if it decides, in its reasonable good-faith judgment, that it is required to do so by law, third-party relationship, security risk, or substantial economic or material technical burden. Google makes no such commitment with respect to Cloud Anchors and the AR Cloud Anchor Service as supported prior to ARCore 1.12.0, in which the device uploads the 3D feature map to the Cloud Anchor Service.