SDK Maps pour iOS

Restez organisé à l'aide des collections Enregistrez et classez les contenus selon vos préférences.
Sélectionnez une plate-forme : Android iOS JavaScript

L'équipe Google Maps Platform met régulièrement à jour les SDK en ajoutant des fonctionnalités, en corrigeant les bugs et en améliorant les performances. Cette page explique comment gérer vos dépendances sur les SDK pour mobile.

  • Pour les applications critiques, associez la dernière version ponctuelle de la version majeure que vous utilisez (X.*) et passez chaque année à la nouvelle version majeure.

    À mesure que vous publiez de nouvelles versions de votre application au cours de l'année, vous pouvez commencer à utiliser des versions ponctuelles plus récentes du SDK Maps pour iOS. Vous n'aurez pas besoin de mettre à jour votre application, car les nouvelles versions ponctuelles sont rétrocompatibles.

    Avantages :

    • Si vous détectez des problèmes dans le SDK Maps pour iOS, les correctifs seront fournis de manière rétrocompatible pendant 12 mois après la publication initiale de la version majeure, conformément aux Règles relatives à la compatibilité mobile. Vous n'aurez pas besoin de passer en urgence à une version du SDK incompatible pour profiter des correctifs.
    • Les dernières améliorations et fonctionnalités sont faciles à adopter si votre application est déjà basée sur la dernière version.
    • Les mises à jour incrémentielles annuelles vers la dernière version majeure du SDK peuvent nécessiter moins de travail pour adapter, réécrire et tester votre application, plutôt que de gérer les modifications antérieures incompatibles introduites dans plusieurs versions majeures.

  • Pour les applications non critiques, associez une version corrigée. Lorsque vous recevez un avis d'abandon concernant cette version corrigée, vous disposez de 12 mois pour mettre à disposition des utilisateurs le code de votre application mis à jour.

    Avantages :

    • Les tâches de maintenance sont moins fréquentes.
    • Les nouvelles versions de votre application restent compatibles plus longtemps avec les appareils des utilisateurs équipés de systèmes d'exploitation mobiles plus anciens (jusqu'à ce que vous deviez passer à une nouvelle version du SDK).

Les propriétaires de projets disposant d'adresses e-mail régulièrement consultées reçoivent des notifications proactives sur les modifications affectant chacun de leurs projets. Informez-vous sur les mises à jour importantes, les abandons et les autres modifications.

Installation

Spécifiez toujours un numéro de version dans vos dépendances au lieu d'utiliser un opérateur optimiste (~>), car cela peut entraîner des builds imprévisibles et impossibles à reproduire. Le SDK Maps pour iOS respecte la gestion sémantique des versions, et les nouvelles versions majeures incluent les modifications destructives.

Utiliser CocoaPods

Exemple de dépendance de fichier Podfile utilisant la syntaxe Podfile:

source 'https://github.com/CocoaPods/Specs.git'

platform :ios, '13.0'

target 'YOUR_APPLICATION_TARGET_NAME_HERE' do
  pod 'GoogleMaps', '7.3.0'
end

Utiliser Carthage

Exemple de dépendance Cartfile utilisant la syntaxe Cartfile:

binary "https://dl.google.com/geosdk/GoogleMaps.json" == 6.2.1

Maintenance et mise à niveau

Pour bénéficier des dernières améliorations, recherchez régulièrement des versions plus récentes et mettez à jour vos spécifications de version. Si vous effectuez une mise à jour vers une nouvelle version majeure, consultez les notes de version pour découvrir les modifications incompatibles avec les versions antérieures et comment mettre à jour votre code.

Utiliser CocoaPods

  1. Ouvrez un terminal et accédez au répertoire contenant Podfile:

    cd <path-to-project>
  2. Exécutez pod outdated pour vérifier si une version plus récente du SDK Maps pour iOS est disponible.
  3. Si une version plus récente du SDK est trouvée, mettez à jour votre Podfile avec cette nouvelle version. Consultez la section Spécifier des versions de pod pour savoir comment définir une version spécifique dans votre Podfile.
  4. Exécutez pod update.
  5. Apportez toutes les modifications nécessaires à la mise à niveau. Consultez les notes de version pour obtenir la liste des modifications apportées à chaque version.
  6. Nettoyez et recréez votre projet en sélectionnant Produit > Nettoyer, puis Produit > Créer.

Utiliser Carthage

  1. Ouvrez un terminal et accédez au répertoire contenant Podfile :

    cd <path-to-project>
  2. Exécutez carthage outdated pour vérifier si une version plus récente du SDK Maps pour iOS est disponible.
  3. Si une version plus récente du SDK est trouvée, mettez à jour votre Cartfile avec cette nouvelle version. Consultez la section Configuration requise pour savoir comment définir une version spécifique dans votre Cartfile.
  4. Exécutez carthage update.
  5. Apportez toutes les modifications nécessaires à la mise à niveau. Consultez les notes de version pour obtenir la liste des modifications apportées à chaque version.
  6. Nettoyez et recréez votre projet en sélectionnant Produit > Nettoyer, puis Produit > Créer.

Manuel

Obtenir le lien vers les fichiers sources les plus récents sur la page Installer le SDK.

En plus d'interroger les versions plus récentes, les propriétaires de projets Google Cloud reçoivent des e-mails sur les modifications incompatibles avec les versions antérieures qui peuvent affecter leurs projets. Pour recevoir des notifications proactives sur ces modifications, attribuez le rôle de propriétaire en indiquant une adresse e-mail surveillée pour chacun de vos projets.