版本控制

Google Maps Platform 团队会定期更新 SDK,以加入新功能、修复问题并提升性能。本页面介绍如何管理移动 SDK 的依赖项。

安装

在应用级 build.gradle 文件中,请务必指定版本,而不是前缀范围 (+) 或 latest,否则可能会导致不可预测且不可重复的 build。Maps SDK for Android 遵循语义化版本控制,并且新的主要版本可能包含破坏性更改。支持的最低 API 级别为 14。

使用 Gradle 语法在 Google Play 服务中指定地图依赖项。

dependencies {
    implementation 'com.google.android.gms:play-services-maps:18.0.0'
    // ...
}

请参阅有关管理 Google Play 服务版本控制的其他指南。

维护

Android Studio 会自动检查是否有更新的版本,并在有更新版本的依赖项时发出警告。为了尽可能减少技术债务,请尽快更新到最新版本。如果您要更新到新的主要版本,请查看版本说明,了解向后不兼容性更改以及代码更新方法。

除了可以轮询更新的版本之外,Google Cloud 项目所有者还会收到电子邮件,通过邮件得知可能会影响其项目的向后不兼容性更改。如需获取有关向后不兼容性更改的主动通知,请为您的每个项目分配所有者角色,并提供受监控的电子邮件地址。