Google Ads API is returning to beta status. Please read our blog post for more details.

Overview

The Ruby client library is hosted on GitHub, and the gem is available via RubyGems.

The library supports Ruby version 2.5 or greater. To use this library, you will need the information listed in Prerequisites.

Refer to the library's README for getting started instructions.

To get OAuth2 refresh tokens, visit the following guides:

Visit these pages for more details on features and utilities:

Supported Ruby Versions

The Ruby client library supports Ruby 2.5, 2.6, and 2.7. Going forward we plan to support the 3 most recent Ruby versions. Ruby is released on the 25th of December each year, so we expect to drop support for 2.5 at the end of 2020.