将 AppLovin 与中介集成

本指南面向希望使用 Google 移动广告 SDK 通过出价和广告瀑布流中介功能加载和展示来自 AppLovin Ads 的广告的发布商。其中介绍了如何将 AppLovin 添加到广告单元的中介配置以及如何将 AppLovin SDK 和适配器集成到iOS 应用中。

支持的广告格式和功能

AdMob 适用于 AppLovin 的中介适配器具有以下功能:

格式
横幅
插页式广告
激励广告
原生
功能
自适应横幅广告
广告联盟优化 (ANO)
自动收集数据
出价

要求

  • iOS 部署目标为 10.0 或更高版本
  • [对于出价]:AppLovin 适配器 6.3.0.0 或更高版本(建议使用最新版本)
  • 最新版 Google 移动广告 SDK

第 1 步:设置 AppLovin

注册登录您的 AppLovin 帐号。

要设置 AdMob 广告单元,您需要使用 AppLovin SDK 密钥报告密钥。要查找这些 ID,请转到 AppLovin 信息中心并点击帐号标签页。在帐号下的下拉列表中,选择以查看这两个值。

[仅限广告瀑布流] 选择中介应用

在 AppLovin 信息中心内,选择获利部分下的应用,以转到您已注册的应用。从可用应用列表中选择要用于中介的应用。

[仅限广告瀑布流] 创建区域

在 AppLovin 信息中心,选择获利部分下的区域,以转到已注册的区域 ID。如果您已为应用创建所需的区域,请直接跳到第 2 步。如需创建新的区域 ID,请点击创建区域

输入区域 ID 的名称,选择 iOS 作为平台,然后选择所需的广告类型

价格部分,从下拉菜单中选择 Flat CPM,为 CPM 区域选择特定的国家/地区,或为非 CPM 区域选择 By by AppLovin。然后,点击保存

创建区域后,可在区域 ID 列下找到区域 ID。

第 2 步:为广告单元 AdMob 配置中介设置

您需要将 AppLovin 添加到广告单元的中介配置中。

首先,登录您的 AdMob 帐号。 接下来,转到中介标签页。如果您已有要修改的中介组,请点击该中介组的名称进行修改,然后直接将 AppLovin 添加为广告来源

要创建新的中介组,请选择创建中介组

输入广告格式和平台,然后点击继续

为中介组命名,然后选择要定位到的地理位置。接下来,将中介组状态设置为已启用,然后点击添加广告单元

将此中介组与您的一个或多个现有AdMob 广告单元相关联。接着,点击完成

现在,您应该会看到“广告单元”卡片中填充了您选择的广告单元:

将 AppLovin 添加为广告来源

出价

广告来源部分的出价卡片下,选择添加广告来源。然后选择 AppLovin

接下来,输入在上一部分中获取的 SDK Key,然后点击 Done

最后,点击保存

瀑布

广告来源卡片中,选择添加广告联盟

选择 AppLovin 并启用优化开关。输入在上一部分中获取的报告密钥,以便为 AppLovin 设置 ANO。然后,为 AppLovin 输入一个 eCPM 值,并点击 Continue(继续)。

输入应用的 Bundle ID 以及上一部分中获取的区域 IDSDK 密钥

使用激励广告

在激励广告单元的设置中,提供奖励金额和奖励类型的值。然后,为确保无论投放哪个广告联盟,您都能向用户提供相同的奖励,请选中 应用于中介组中的所有广告联盟复选框。

如果您不应用此设置,AppLovin 适配器会在创建展示位置时传回 AppLovin 信息中心中指定的奖励。

如需详细了解如何为 AdMob 广告单元设置奖励值,请参阅创建广告单元

第 3 步:导入 AppLovin SDK 和适配器

  • 将以下行添加到项目的 Podfile 中:

    pod 'GoogleMobileAdsMediationAppLovin'
    
  • 从命令行中运行以下命令:

    pod install --repo-update

手动集成

  • 下载最新版 AppLovin iOS SDK,并在项目中关联 ApplovinSDK.framework

  • 变更日志的下载链接下载最新版 AppLovin 适配器,并关联项目中的 ApplovinAdapter.framework

  • 将以下框架添加到您的项目中:

    • AdSupport
    • AVFoundation
    • CoreGraphics
    • CoreMedia
    • CoreTelephony
    • StoreKit
    • SystemConfiguration
    • UIKit
    • WebKit (NEW)
    • libz.tbd (NEW)

第 4 步:需要其他代码

AppLovin 集成不需要其他代码。

第 5 步:测试您的实现效果

如果您无法获取实时广告,AppLovin 建议在开发过程中使用测试广告

要启用测试广告,请点击 AppLovin 信息中心内的应用名称,转到 Manage Apps(管理应用)页面,然后转到 Test Mode 部分。将 Test Mode 开关切换为 ON

测试模式最多可能需要 30 分钟才能生效。并在两小时后自动重置为 OFF

可选步骤

根据 Google《欧盟地区用户意见征求政策》,您必须确保向欧洲经济区 (EEA) 内的用户披露与使用设备标识符和个人数据有关的信息,以及征得这些用户的同意。此政策反映了欧盟《电子隐私指令》和《一般数据保护条例》(GDPR) 的要求。在征求用户意见时,您必须指明中介链中可能会收集、接收或使用个人数据的广告联盟,并提供各个广告联盟的使用情况信息。Google 目前无法自动将用户的意见传递给此类网络。

以下部分介绍了如何为 AppLovin 启用或停用个性化广告。

在 SDK 版本 5.0.1中,AppLovin 添加了 setHasUserContentsetIsAgeRestrictedUser 方法。以下示例代码展示了如何将用户意见征求信息传递给 AppLovin SDK。我们建议您在通过 Google 移动广告 SDK 请求广告之前调用这些方法。

Swift

import AppLovinSDK
// ...

ALPrivacySettings.setHasUserConsent(true)

Objective-C

#import <AppLovinSDK/AppLovinSDK.h>
// ...

[ALPrivacySettings setHasUserConsent:YES];

此外,如果已知用户属于有年龄限制的类别,您可以将以下标志设置为 YES

Swift

import AppLovinSDK
// ...

ALPrivacySettings.setIsAgeRestrictedUser(true)

Objective-C

#import <AppLovinSDK/AppLovinSDK.h>
// ...

[ALPrivacySettings setIsAgeRestrictedUser:YES];

如需了解详情,请参阅 AppLovin' 隐私设置

广告联盟专用参数

AppLovin 适配器支持 muteAudio,这是一个用于为视频广告停用音频的可选 extra。该参数可以使用 GADMAdapterAppLovinExtras 类传递给适配器,并且必须针对每个广告请求进行设置。设置方法如下:

Swift

let request = GADRequest()
let extras = GADMAdapterAppLovinExtras()
extras.muteAudio = false
request.register(extras)

Objective-C

GADRequest *request = [GADRequest request];
GADMAdapterAppLovinExtras * extras = [[GADMAdapterAppLovinExtras alloc] init];
extras.muteAudio = NO;
[request registerAdNetworkExtras:extras];

优化

在应用启动后立即初始化 AppLovin SDK 使 AppLovin 能够在应用启动后立即跟踪事件。

Swift

let sdk = ALSdk.shared(withKey: "sdkKey")
sdk?.initializeSdk()

Objective-C

ALSdk *sdk = [ALSdk sharedWithKey:@"sdkKey"];
[sdk initializeSdk];

错误代码

如果适配器未能收到来自 AppLovin 的广告,则发布商可以使用以下类下的 GADResponseInfo.adNetworkInfoArray,位于以下类下:

GADMAdapterAppLovin
GADMAdapterAppLovinRewardBasedVideoAd
GADMediationAdapterAppLovin

广告加载失败时,AppLovin 适配器抛出的代码和附带的消息如下:

错误代码 原因
-102 至 -900,204 AppLovin SDK 返回了错误。如需了解详情,请参阅这份文档
101 请求的广告尺寸与 AppLovin 支持的横幅广告尺寸不符。
103 上下文为 null。
104 AppLovin 出价令牌为空。
105 针对同一区域请求了多个广告。AppLovin 在每个区域每次只能加载 1 个广告。
106 广告尚未准备好展示。
108 AppLovin Adapter 不支持请求的广告格式。
-1009 至 -1,204 AppLovin SDK 返回了错误。如需了解详情,请参阅 Unity 的代码
101 请求的广告尺寸与 AppLovin 支持的横幅广告尺寸不符。
102 AdMob 界面中配置的 AppLovin 服务器参数缺失/无效。
103 未能展示 AppLovin 广告。
104 针对同一区域请求了多个广告。AppLovin 在每个区域每次只能加载 1 个广告。
105 找不到 AppLovin SDK 密钥。
107 出价令牌为空。
108 AppLovin Adapter 不支持请求的广告格式。
110 AppLovin 发送了一个成功的加载回调,但加载了零个广告。

AppLovin iOS 中介适配器变更日志

版本 11.3.3.0

  • 经验证与 AppLovin SDK 11.3.3 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.3.0 版。
  • AppLovin SDK 版本 11.3.3。

版本 11.3.2.0

  • 经验证与 AppLovin SDK 11.3.2 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.2.0 版。
  • AppLovin SDK 版本 11.3.2。

版本 11.3.1.0

  • 验证了与 AppLovin SDK 11.3.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.1.0 版。
  • AppLovin SDK 版本 11.3.1。

版本 11.3.0.0

  • 经验证与 AppLovin SDK 11.3.0 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.1.0 版。
  • AppLovin SDK 版本 11.3.0。

版本 11.2.1.0

  • 验证了与 AppLovin SDK 11.2.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.1.0 版。
  • AppLovin SDK 11.2.1 版。

版本 11.2.0.0

  • 验证了与 AppLovin SDK 11.2.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.1.0 版。
  • AppLovin SDK 11.2.0 版。

版本 11.1.2.0

  • 验证了与 AppLovin SDK 11.1.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • AppLovin SDK 11.1.2 版。

版本 11.1.1.0

  • 验证了与 AppLovin SDK 11.1.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • AppLovin SDK 11.1.1。

版本 11.1.0.0

  • 验证了与 AppLovin SDK 11.1.0 的兼容性。
  • 经验证与 Google 移动广告 SDK 9.0.0 版本兼容。
  • 现在需要使用 Google 移动广告 SDK 9.0.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • AppLovin SDK 11.1.0。

版本 11.0.0.0

  • 验证了与 AppLovin SDK 11.0.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.13.0。
  • AppLovin SDK 11.0.0。

版本 10.3.7.0

  • 验证了与 AppLovin SDK 10.3.7 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.12.0。
  • AppLovin SDK 版本 10.3.7。

版本 10.3.6.0

  • 验证了与 AppLovin SDK 10.3.6 的兼容性。
  • 现在要求的最低操作系统版本为 10.0。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.11.0。
  • AppLovin SDK 版本 10.3.6。

版本 10.3.5.0

  • 验证了与 AppLovin SDK 10.3.5 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.9.0。
  • AppLovin SDK 版本 10.3.5。

版本 10.3.4.0

  • 经验证与 AppLovin SDK 10.3.4 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.8.0。
  • AppLovin SDK 版本 10.3.4。

版本 10.3.3.0

  • 经验证与 AppLovin SDK 10.3.3 兼容。
  • 现在,适配器会在请求广告之前尝试初始化 AppLovin SDK。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.7.0。
  • AppLovin SDK 版本 10.3.3。

版本 10.3.2.0

  • 验证了与 AppLovin SDK 10.3.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.6.0。
  • AppLovin SDK 版本 10.3.2。

版本 10.3.0.0

  • 验证了与 AppLovin SDK 10.3.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • AppLovin SDK 版本 10.3.0。

版本 10.2.1.0

  • 验证了与 AppLovin SDK 10.2.1 的兼容性。
  • 已放宽对 Google 移动广告 SDK 8.0.0 或更高版本的依赖。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.4.0。
  • AppLovin SDK 版本 10.2.1。

版本 10.2.0.0

  • 验证了与 AppLovin SDK 10.2.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 8.4.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.4.0。
  • AppLovin SDK 版本 10.2.0。

版本 10.1.1.0

  • 验证了与 AppLovin SDK 10.1.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.3.0 版。
  • AppLovin SDK 版本 10.1.1。

版本 10.1.0.0

  • 验证了与 AppLovin SDK 10.1.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 8.3.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.3.0 版。
  • AppLovin SDK 版本 10.1.0。

版本 10.0.1.0

  • 验证了与 AppLovin SDK 10.0.1 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 8.2.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.2.0 版。
  • AppLovin SDK 版本 10.0.1。

版本 10.0.0.0

  • 验证了与 AppLovin SDK 10.0.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 8.1.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.1.0。
  • AppLovin SDK 版本 10.0.0。

版本 6.15.2.0

  • 经验证与 AppLovin SDK 6.15.2 兼容。
  • 现在需要使用 Google 移动广告 SDK 8.0.0 或更高版本。
  • 更新了适配器以使用 .xcframework 格式。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.0.0。
  • AppLovin SDK 6.15.2 版。

版本 6.15.1.0

  • 验证了与 AppLovin SDK 6.15.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.69.0 版。
  • AppLovin SDK 6.15.1 版。

版本 6.15.0.0

  • 经验证与 AppLovin SDK 6.15.0 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.69.0 版。
  • AppLovin SDK 6.15.0。

版本 6.14.11.0

  • 验证了与 AppLovin SDK 6.14.11 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.69.0 版。
  • AppLovin SDK 6.14.11。

版本 6.14.10.0

  • 验证了与 AppLovin SDK 6.14.10 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.69.0 或更高版本。
  • 添加了 GADMediationAdapterAppLovin.SDKSettings 属性。发布商现在可以通过此 API 配置 AppLovin SDK 设置。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.69.0 版。
  • AppLovin SDK 6.14.10 版。

版本 6.14.9.0

  • 经验证与 AppLovin SDK 6.14.9 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.68.0 版。
  • AppLovin SDK 6.14.9 版。

版本 6.14.8.0

  • 经验证与 AppLovin SDK 6.14.8 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.68.0 版。
  • AppLovin SDK 6.14.8 版。

版本 6.14.7.0

  • 经验证与 AppLovin SDK 6.14.7 兼容。
  • 现在需要使用 Google 移动广告 SDK 7.68.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.68.0 版。
  • AppLovin SDK 6.14.7 版。

版本 6.14.6.0

  • 经验证与 AppLovin SDK 6.14.6 兼容。
  • 现在需要使用 Google 移动广告 SDK 7.67.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.67.0 版。
  • AppLovin SDK 6.14.6 版。

版本 6.14.5.0

  • 经验证与 AppLovin SDK 6.14.5 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.66.0 版。
  • AppLovin SDK 6.14.5 版。

版本 6.14.4.0

  • 经验证与 AppLovin SDK 6.14.4 兼容。
  • 现在需要使用 Google 移动广告 SDK 7.66.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.66.0 版。
  • AppLovin SDK 6.14.4。

版本 6.14.3.0

  • 经验证与 AppLovin SDK 6.14.3 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.65.0 版。
  • AppLovin SDK 6.14.3 版。

版本 6.14.2.0

  • 经验证与 AppLovin SDK 6.14.2 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.65.0 版。
  • AppLovin SDK 6.14.2 版。

版本 6.13.4.1

  • 现在需要使用 Google 移动广告 SDK 7.65.0 或更高版本。
  • 取消了对 300x250 中矩形广告和原生广告的支持。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.65.0 版。
  • AppLovin SDK 6.13.4 版。

版本 6.13.4.0

  • 经验证与 AppLovin SDK 6.13.4 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.64.0 版。
  • AppLovin SDK 6.13.4 版。

版本 6.13.1.0

  • 经验证与 AppLovin SDK 6.13.1 兼容。
  • 现在需要使用 Google 移动广告 SDK 7.64.0 或更高版本。
  • 移除了 iPhone 设备支持的 728x90 格式。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.64.0 版。
  • AppLovin SDK 6.13.1 版。

版本 6.13.0.0

  • 验证了与 AppLovin SDK 6.13.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.61.0 或更高版本。
  • 移除了 iPhone 设备支持的 728x90 格式。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.61.0 版。
  • AppLovin SDK 6.13.0。

版本 6.12.8.0

  • 验证了与 AppLovin SDK 6.12.8 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.60.0 版。
  • AppLovin SDK 6.12.8 版。

版本 6.12.7.0

  • 经验证与 AppLovin SDK 6.12.7 兼容。
  • 现在需要使用 Google 移动广告 SDK 7.60.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.60.0 版。
  • AppLovin SDK 6.12.7 版。

版本 6.12.6.0

  • 经验证与 AppLovin SDK 6.12.6 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.59.0 版。
  • AppLovin SDK 6.12.6 版。

版本 6.12.5.0

  • 经验证与 AppLovin SDK 6.12.5 兼容。
  • 将 Google 移动广告 SDK 所需的最低版本更新为 7.59.0。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.59.0 版。
  • AppLovin SDK 6.12.5。

6.12.4.0 版

  • 经验证与 AppLovin SDK 6.12.4 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • AppLovin SDK 6.12.4 版。

6.12.3.0 版

  • 经验证与 AppLovin SDK 6.12.3 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • AppLovin SDK 6.12.3 版。

6.12.2.0 版

  • 经验证与 AppLovin SDK 6.12.2 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • AppLovin SDK 6.12.2 版。

6.12.1.0 版

  • 验证了与 AppLovin SDK 6.12.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • AppLovin SDK 6.12.1 版。

6.12.0.0 版

  • 经验证与 AppLovin SDK 6.12.0 兼容。
  • 添加了标准化的适配器错误代码和消息。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • AppLovin SDK 6.12.0。

6.11.5.0 版

  • 经验证与 AppLovin SDK 6.11.5 兼容。
  • 取消了对 i386 架构的支持。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.56.0 版。
  • AppLovin SDK 6.11.5 版。

6.11.4.0 版

  • 经验证与 AppLovin SDK 6.11.4 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.55.1 版。
  • AppLovin SDK 6.11.4。

6.11.3.0 版

  • 经验证与 AppLovin SDK 6.11.3 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.55.0 版。
  • AppLovin SDK 6.11.3 版。

6.11.1.0 版

  • 验证了与 AppLovin SDK 6.11.1 的兼容性。
  • 修复了导致原生广告无法加载的问题。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.53.1 版。
  • AppLovin SDK 6.11.1 版。

6.10.1.0 版

  • 验证了与 AppLovin SDK 6.10.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.52.0 版。
  • AppLovin SDK 6.10.1 版。

6.9.5.0 版

  • 经验证与 AppLovin SDK 6.9.5 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.50.0 版。
  • AppLovin SDK 6.9.5 版。

6.9.4.0 版

  • 经验证与 AppLovin SDK 6.9.4 兼容。
  • 修复了实时出价激励视频广告在加载后仍无法展示的问题。
  • 修复了适配器,不允许 AdMob 超时或发布商未显示之前加载的区域的后续广告加载。
  • 修复了从服务器传递 SDK 密钥时原生广告无法正常工作的问题。
  • 验证来自服务器的 SDK 密钥,然后在服务器的 SDK 密钥无效的情况下(例如在发送占位值时)回退到 Info.plist。
  • 验证来自服务器的自定义区域 ID(例如,发送占位值的情况下)。
  • 移除了 Placement API。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.50.0 版。
  • AppLovin SDK 6.9.4 版。

6.8.0.0 版

  • 经验证与 AppLovin SDK 6.8.0 兼容。
  • 不再支持原生应用安装广告。应用必须使用统一原生广告 API 来请求原生广告。
  • 现在需要使用 Google 移动广告 SDK 7.46.0 或更高版本。

6.6.1.0 版

  • 经验证与 AppLovin SDK 6.6.1 兼容。
  • 修复了对 nil 对象调用 completionHandler 而导致的崩溃问题。
  • 更新了适配器以处理多个插页式广告请求。
  • 新增了对灵活横幅广告尺寸的支持。

6.3.0.0 版

  • 经验证与 AppLovin SDK 6.3.0 兼容。
  • 更新了适配器,以使用新的激励广告 API。
  • 现在需要使用 Google 移动广告 SDK 7.41.0 或更高版本。

版本 6.2.0.0

  • 经验证与 AppLovin SDK 6.2.0 兼容。

6.1.4.0 版

  • 经验证与 AppLovin SDK 6.1.4 兼容。

版本 5.1.2.0

  • 验证了与 AppLovin SDK 5.1.2 的兼容性。

版本 5.1.1.0

  • 验证了与 AppLovin SDK 5.1.1 的兼容性。

版本 5.1.0.0

  • 经验证与 AppLovin SDK 5.1.0 兼容。

版本 5.0.2.0

  • 验证了与 AppLovin SDK 5.0.2 的兼容性。

版本 5.0.1.1

  • 添加对原生广告的支持。
  • 将 AdMob 设置为 AppLovin SDK 上的中介提供商。

版本 5.0.1.0

  • 验证了与 Applovin SDK 5.0.1 的兼容性。

4.8.4.0 版

  • 经验证与 Applovin SDK 4.8.4 兼容。

4.8.3.0 版

  • 添加对区域和智能横幅的支持。

4.7.0.0 版

  • 验证了与 AppLovin SDK 4.7.0 的兼容性。

4.6.1.0 版

  • 经验证与 AppLovin SDK 4.6.1 兼容。

4.6.0.0 版

  • 经验证与 AppLovin SDK 4.6.0 兼容。

4.5.1.0 版

  • 经验证与 AppLovin SDK 4.5.1 兼容。

版本 4.4.1.1

  • 新增了对横幅广告的支持。

4.4.1.0 版

  • 经验证与 AppLovin SDK 4.4.1 兼容。

4.3.1.0 版

  • 新增了对插页式广告的支持。

早期版本

  • 新增了对激励视频广告的支持。