将 IronSource 与中介集成

本指南面向希望使用 Google 移动广告 SDK 通过中介加载和展示 ironSource 广告的发布商。 其中介绍了如何将 ironSource 添加到广告单元的中介配置、如何设置广告联盟优化以及如何将 ironSource SDK 和适配器集成到 iOS 应用中。

支持的格式和功能

AdMob 针对 ironSource 的中介适配器具有以下功能:

格式
横幅
插页式广告
激励广告
插页式激励广告
原生
功能
自适应横幅广告
广告联盟优化 (ANO) 自动收集数据

要求

  • iOS 部署目标为 10.0 或更高版本
  • 最新版 Google 移动广告 SDK

第 1 步:设置 ironSource

注册登录您的 ironSource 帐号。

如需将应用添加到 ironSource 信息中心,请点击新建应用按钮。

输入应用详情

选择 移动应用,输入应用的App Store 网址,然后点击导入应用信息。应用信息显示后,点击添加应用按钮。

如果您的应用不可用,请选择 App Not Live in App Store 并为您的应用提供临时名称。选择 iOS作为平台,然后点击添加应用

记下新的 App Key,此密钥在应用添加后显示。您需要使用此值来设置AdMob 广告单元 ID。在相应 Live 标签页中选择您的应用支持的广告格式。然后,点击完成

实例 ID

接下来,为您添加的应用配置网络实例;ironSource 支持为激励广告和插页式广告使用多个网络实例。

从左侧导航栏中导航到广告单元和展示位置页面,在应用列表中选择您的应用,然后点击修改按钮。

选择添加网络实例链接,输入实例名称,然后点击保存

创建实例后,实例 ID 会列在实例 ID 字段中。

除了应用密钥实例 ID 之外,您还需要使用 ironSource 密钥刷新令牌来设置AdMob 广告单元 ID。

转到 ironSource 发布商信息中心内的我的帐号,然后点击 API 标签页。记下您的密钥刷新令牌

第 2 步:为广告单元 AdMob 配置中介设置

要将 ironSource 添加到广告单元的中介配置中,请先登录您的 AdMob 帐号

接下来,转到中介标签页。如果您已有要修改的中介组,请点击该中介组的名称进行修改,然后直接将 ironSource 添加为广告来源

要创建新的中介组,请选择创建中介组

输入广告格式和平台,然后点击继续

为中介组命名,然后选择要定位到的地理位置。 接下来,将中介组状态设置为已启用,然后点击添加广告单元

将此中介组与您的一个或多个现有 AdMob 广告单元相关联。然后,点击完成

现在,您应该会看到“广告单元”卡片中填充了您选择的广告单元,如下所示:

将 ironSource 添加为广告来源

广告来源卡片中,选择添加广告联盟。然后选择 ironSource

接下来,启用优化功能,然后输入在上一部分获得的密钥刷新令牌,以为 ironSource 设置 ANO。 然后输入 eCPM 值,并点击继续

输入在上一部分获得的应用密钥实例 ID

使用激励广告

在激励广告单元的设置中,提供奖励金额和奖励类型的值。然后,为确保无论投放哪个广告联盟,您都能向用户提供相同的奖励,请选中 应用于中介组中的所有广告联盟复选框。

如果您不应用此设置,则 ironSource 适配器在创建展示位置时,会传回 ironSource 信息中心中指定的奖励。

如需详细了解如何为 AdMob 广告单元设置奖励值,请参阅创建广告单元

第 3 步:导入 ironSource SDK 和适配器

  • 将以下行添加到项目的 Podfile 中:

    pod 'GoogleMobileAdsMediationIronSource'
    
  • 从命令行中运行以下命令:

    pod install --repo-update

手动集成

  • 下载最新版本的 ironSource iOS SDK,并在项目中关联 IronSource.framework

  • 变更日志中的下载链接下载最新版 ironSource 适配器,并在项目中下载 IronSourceAdapter.framework

第 4 步:需要其他代码

ironSource iOS 集成不需要其他代码。

第 5 步:测试您的实现效果

如需在 ironSource 上启用测试广告,请运行广告集成应用,并检查日志以查找如下所示的消息:

这是您的测试设备的广告 ID。将其复制到剪贴板。

转到 MONETIZE 标签页,然后点击 Testing 按钮。接下来,点击 New Test Device 按钮。

输入上一步中的设备名称广告 ID。 然后,点击保存

新添加的测试设备列在测试设备下。您可以根据需要在此模块中启用或停用测试广告

可选步骤

根据 Google《欧盟地区用户意见征求政策》,您必须确保向欧洲经济区 (EEA) 内的用户披露与使用设备标识符和个人数据有关的信息,以及征得这些用户的同意。此政策反映了欧盟《电子隐私指令》和《一般数据保护条例》(GDPR) 的要求。在征求用户意见时,您必须指明中介链中可能会收集、接收或使用个人数据的广告联盟,并提供各个广告联盟的使用情况信息。Google 目前无法自动将用户的意见传递给此类网络。

以下部分介绍了如何为 ironSource 启用或停用个性化广告。

在 SDK 版本 6.7.9 中,ironSource 添加 Consent API。以下示例代码将针对以下规则设置用户意见征求: YES 。如果您选择调用此方法,建议您在通过 Google 移动广告 SDK 请求广告之前执行此操作。

#import <IronSource/IronSource.h>
...

[IronSource setConsent:YES];

如需了解详情,请参阅 ironSource 的管理用户意见征求文档。

错误代码

如果适配器未能收到来自 ironSource 的广告,则发布商可以使用以下类中的 GADResponseInfo.adNetworkInfoArray,位于以下类下:

GADMAdapterIronSource
GADMAdapterIronSourceRewarded

广告加载失败时, ironSource 适配器抛出的代码和附带的消息如下:

错误代码 原因
101 AdMob 界面中配置的 ironSource 服务器参数缺失/无效。
102 ironSource 需要 Activity 上下文来初始化其 SDK。
103 每个 ironSource 实例 ID 只能加载 1 个广告。
501-1056 ironSource SDK 错误。如需了解详情,请参阅这份文档
101 AdMob 界面中配置的 ironSource 服务器参数缺失/无效。
102 ironSource 适配器不支持请求的广告格式。
103 已为此网络配置加载了 ironSource 广告。
508-1037 ironSource SDK 错误。如需了解详情,请参阅这份文档

IronSource iOS 中介适配器变更日志

版本 7.2.1.2.0

  • 验证了与 ironSource SDK 版本 7.2.1.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.2.0 版。
  • IronSource SDK 版本 7.2.1.2。

版本 7.2.1.1.0

  • 验证了与 ironSource SDK 版本 7.2.1.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.2.0 版。
  • IronSource SDK 版本 7.2.1.1。

版本 7.2.1.0

  • 验证了与 ironSource SDK 7.2.1 版兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.1.0 版。
  • IronSource SDK 版本 7.2.1。

版本 7.2.0.0

  • 验证了与 ironSource SDK 版本 7.2.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • IronSource SDK 7.2.0 版。

版本 7.1.14.1

  • 经验证与 Google 移动广告 SDK 9.0.0 版本兼容。
  • 现在需要使用 Google 移动广告 SDK 9.0.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • IronSource SDK 版本 7.1.14。

版本 7.1.14.0

  • 验证了与 ironSource SDK 版本 7.1.14 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.13.0。
  • IronSource SDK 版本 7.1.14。

版本 7.1.13.0

  • 验证了与 ironSource SDK 版本 7.1.13 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.13.0。
  • IronSource SDK 版本 7.1.13。

版本 7.1.12.0

  • 验证了与 ironSource SDK 版本 7.1.12 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.12.0。
  • IronSource SDK 版本 7.1.12。

版本 7.1.11.1.0

  • 经验证与 ironSource SDK 版本 7.1.11.1 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.12.0。
  • IronSource SDK 版本 7.1.11.1。

版本 7.1.11.0

  • 验证了与 ironSource SDK 版本 7.1.11 的兼容性。
  • 现在要求的最低操作系统版本为 10.0。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.11.0。
  • IronSource SDK 版本 7.1.11。

版本 7.1.10.0

  • 验证了与 ironSource SDK 版本 7.1.10 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.9.0。
  • IronSource SDK 版本 7.1.10。

版本 7.1.9.0

  • 验证了与 ironSource SDK 版本 7.1.9 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.9.0。
  • IronSource SDK 7.1.9 版。

版本 7.1.8.0

  • 验证了与 ironSource SDK 版本 7.1.8 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.8.0。
  • IronSource SDK 版本 7.1.8。

版本 7.1.7.0

  • 经验证与 ironSource SDK 7.1.7 版兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.7.0。
  • IronSource SDK 7.1.7 版。

版本 7.1.6.1.0

  • 验证了与 ironSource SDK 版本 7.1.6.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • IronSource SDK 版本 7.1.6.1。

版本 7.1.6.0

  • 经验证与 ironSource SDK 7.1.6 版兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • IronSource SDK 7.1.6 版。

版本 7.1.5.1.0

  • 验证了与 ironSource SDK 版本 7.1.5.1 的兼容性。
  • 已放宽对 Google 移动广告 SDK 8.0.0 或更高版本的依赖。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • IronSource SDK 版本 7.1.5.1。

版本 7.1.5.0

  • 验证了与 ironSource SDK 7.1.5 的版本兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.3.0 版。
  • IronSource SDK 7.1.5 版。

版本 7.1.4.0

  • 经验证与 ironSource SDK 7.1.4 版兼容。
  • 现在需要使用 Google 移动广告 SDK 8.3.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.3.0 版。
  • IronSource SDK 7.1.4 版。

版本 7.1.3.0

  • 新增了对插页式激励广告的支持。
  • 验证了与 ironSource SDK 版本 7.1.3 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 8.2.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.2.0 版。
  • IronSource SDK 版本 7.1.3。

版本 7.1.2.0

  • 验证了与 ironSource SDK 版本 7.1.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.1.0。
  • IronSource SDK 版本 7.1.2。

版本 7.1.1.0

  • 验证了与 ironSource SDK 7.1.1 的版本兼容。
  • 现在需要使用 Google 移动广告 SDK 8.1.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.1.0。
  • IronSource SDK 7.1.1 版。

版本 7.1.0.1

  • 更新了适配器以使用 .xcframework 格式。
  • 现在需要使用 Google 移动广告 SDK 8.0.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.0.0。
  • IronSource SDK 7.1.0 版。

版本 7.1.0.0

  • 验证了与 ironSource SDK 版本 7.1.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.69.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.69.0 版。
  • IronSource SDK 7.1.0 版。

版本 7.0.4.0

  • 验证了与 ironSource SDK 版本 7.0.4 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.68.0 或更高版本。
  • 添加了标准化的适配器错误代码和消息。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.68.0 版。
  • IronSource SDK 7.0.4 版。

版本 7.0.3.0

  • 验证了与 ironSource SDK 版本 7.0.3 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.66.0 版。
  • IronSource SDK 版本 7.0.3。

版本 7.0.2.0

  • 验证了与 ironSource SDK 版本 7.0.2 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.66.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.66.0 版。
  • IronSource SDK 版本 7.0.2。

版本 7.0.1.0

  • 验证了与 ironSource SDK 版本 7.0.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.64.0 版。
  • IronSource SDK 版本 7.0.1。

版本 7.0.0.0

  • 验证了与 ironSource SDK 版本 7.0.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.64.0 或更高版本。
  • 现要求使用最低的 iOS 9.0 版。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.64.0 版。
  • IronSource SDK 版本 7.0.0。

版本 6.18.0.2.0

  • 验证了与 ironSource SDK 版本 6.18.0.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.63.0 版。
  • IronSource SDK 版本 6.18.0.2。

版本 6.18.0.1.0

  • 验证了与 ironSource SDK 版本 6.18.0.1 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.63.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.63.0 版。
  • IronSource SDK 版本 6.18.0.1。

版本 6.18.0.0

  • 验证了与 ironSource SDK 版本 6.18.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.63.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.63.0 版。
  • IronSource SDK 版本 6.18.0。

版本 6.17.0.1.0

  • 验证了与 ironSource SDK 版本 6.17.0.1 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.62.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.62.0 版。
  • IronSource SDK 版本 6.17.0.1。

版本 6.17.0.0

  • 验证了与 ironSource SDK 版本 6.17.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.61.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.61.0 版。
  • IronSource SDK 版本 6.17.0。

版本 6.16.3.0

  • 已验证与 ironSource SDK 版本 6.16.3 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.60.0 版。
  • IronSource SDK 版本 6.16.3。

版本 6.16.2.0

  • 验证了与 ironSource SDK 版本 6.16.2 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.60.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.60.0 版。
  • IronSource SDK 版本 6.16.2。

版本 6.16.1.0

  • 验证了与 ironSource SDK 6.16.1 的版本兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • IronSource SDK 版本 6.16.1。

6.16.0.0 版

  • 已验证与 ironSource SDK 版本 6.16.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.58.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • IronSource SDK 版本 6.16.0。

6.15.0.1.0 版

  • 验证了与 ironSource SDK 版本 6.15.0.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.57.0 版。
  • IronSource SDK 版本 6.15.0.1。

6.15.0.0 版

  • 验证了与 ironSource SDK 版本 6.15.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.57.0 版。
  • IronSource SDK 版本 6.15.0。

6.14.0.0 版

  • 已验证与 ironSource SDK 版本 6.14.0 的兼容性。
  • 取消了对 i386 架构的支持。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.56.0 版。
  • IronSource SDK 版本 6.14.0。

6.13.0.1.0 版

  • 验证了与 ironSource SDK 版本 6.13.0.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.53.1 版。
  • IronSource SDK 版本 6.13.0.1。

6.12.0.0 版

  • 验证了与 ironSource SDK 版本 6.12.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.53.1 版。
  • IronSource SDK 版本 6.12.0。

6.11.0.0 版

  • 验证了与 ironSource SDK 版本 6.11.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.52.0 版。
  • IronSource SDK 版本 6.11.0。

6.8.7.0 版

  • 验证了与 ironSource SDK 版本 6.8.7 的兼容性。

6.8.6.0 版

  • 验证了与 ironSource SDK 版本 6.8.6 的兼容性。

6.8.5.0 版

  • 验证了与 ironSource SDK 版本 6.8.5 的兼容性。

版本 6.8.4.1.0

  • 验证了与 ironSource SDK 版本 6.8.4.1 的兼容性。

6.8.4.1 版

  • 添加了向 ironSource SDK 发送正确版本号的代码。

6.8.4.0 版

  • 验证了与 ironSource SDK 版本 6.8.4 的兼容性。

6.8.3.0 版

  • 验证了与 ironSource SDK 6.8.3 的兼容性。
  • 新增了对请求多个插页式广告的支持。
  • 修复了加载激励广告时发生崩溃的问题
  • 此版本的适配器需要使用 7.42.2 版或更高版本的 Google 移动广告 SDK。

6.8.0.1 版

  • 更新了适配器以使用新的激励广告 API
  • 此版本的适配器需要使用 7.41.0 或更高版本的 Google 移动广告 SDK

6.8.0.0 版

  • 经过验证的与 ironSource SDK 6.8.0 的兼容性

6.7.12.0 版

  • 经过验证的与 ironSource SDK 6.7.12 的兼容性

6.7.11.0 版

  • 经过验证的与 ironSource SDK 6.7.11 的兼容性

6.7.10.0 版

  • 经过验证的与 ironSource SDK 6.7.10 的兼容性

版本 6.7.9.3.1

  • 向适配器添加了 adapterDidCompletePlayingRewardBasedVideoAd: 回调。

6.7.9.3.0 版

  • 经过验证的与 ironSource SDK 6.7.9.3 的兼容性

版本 6.7.9.2.0

  • 已验证与 ironSource SDK 6.7.9.2 的兼容性

6.7.9.1.0 版

  • 已验证与 ironSource SDK 6.7.9.1 的兼容性

6.7.8.0 版

  • 经过验证的与 ironSource SDK 6.7.8 的兼容性

6.7.7.0 版

  • 为每个广告单元启动一次 IronSource SDK。

6.7.5.0 版

  • 初始版本!
  • 支持插页式视频广告和激励视频广告。
,

本指南面向希望使用 Google 移动广告 SDK 通过中介加载和展示 ironSource 广告的发布商。 其中介绍了如何将 ironSource 添加到广告单元的中介配置、如何设置广告联盟优化以及如何将 ironSource SDK 和适配器集成到 iOS 应用中。

支持的格式和功能

AdMob 针对 ironSource 的中介适配器具有以下功能:

格式
横幅
插页式广告
激励广告
插页式激励广告
原生
功能
自适应横幅广告
广告联盟优化 (ANO) 自动收集数据

要求

  • iOS 部署目标为 10.0 或更高版本
  • 最新版 Google 移动广告 SDK

第 1 步:设置 ironSource

注册登录您的 ironSource 帐号。

如需将应用添加到 ironSource 信息中心,请点击新建应用按钮。

输入应用详情

选择 移动应用,输入应用的App Store 网址,然后点击导入应用信息。应用信息显示后,点击添加应用按钮。

如果您的应用不可用,请选择 App Not Live in App Store 并为您的应用提供临时名称。选择 iOS作为平台,然后点击添加应用

记下新的 App Key,此密钥在应用添加后显示。您需要使用此值来设置AdMob 广告单元 ID。在相应 Live 标签页中选择您的应用支持的广告格式。然后,点击完成

实例 ID

接下来,为您添加的应用配置网络实例;ironSource 支持为激励广告和插页式广告使用多个网络实例。

从左侧导航栏中导航到广告单元和展示位置页面,在应用列表中选择您的应用,然后点击修改按钮。

选择添加网络实例链接,输入实例名称,然后点击保存

创建实例后,实例 ID 会列在实例 ID 字段中。

除了应用密钥实例 ID 之外,您还需要使用 ironSource 密钥刷新令牌来设置AdMob 广告单元 ID。

转到 ironSource 发布商信息中心内的我的帐号,然后点击 API 标签页。记下您的密钥刷新令牌

第 2 步:为广告单元 AdMob 配置中介设置

要将 ironSource 添加到广告单元的中介配置中,请先登录您的 AdMob 帐号

接下来,转到中介标签页。如果您已有要修改的中介组,请点击该中介组的名称进行修改,然后直接将 ironSource 添加为广告来源

要创建新的中介组,请选择创建中介组

输入广告格式和平台,然后点击继续

为中介组命名,然后选择要定位到的地理位置。 接下来,将中介组状态设置为已启用,然后点击添加广告单元

将此中介组与您的一个或多个现有 AdMob 广告单元相关联。然后,点击完成

现在,您应该会看到“广告单元”卡片中填充了您选择的广告单元,如下所示:

将 ironSource 添加为广告来源

广告来源卡片中,选择添加广告联盟。然后选择 ironSource

接下来,启用优化功能,然后输入在上一部分获得的密钥刷新令牌,以为 ironSource 设置 ANO。 然后输入 eCPM 值,并点击继续

输入在上一部分获得的应用密钥实例 ID

使用激励广告

在激励广告单元的设置中,提供奖励金额和奖励类型的值。然后,为确保无论投放哪个广告联盟,您都能向用户提供相同的奖励,请选中 应用于中介组中的所有广告联盟复选框。

如果您不应用此设置,则 ironSource 适配器在创建展示位置时,会传回 ironSource 信息中心中指定的奖励。

如需详细了解如何为 AdMob 广告单元设置奖励值,请参阅创建广告单元

第 3 步:导入 ironSource SDK 和适配器

  • 将以下行添加到项目的 Podfile 中:

    pod 'GoogleMobileAdsMediationIronSource'
    
  • 从命令行中运行以下命令:

    pod install --repo-update

手动集成

  • 下载最新版本的 ironSource iOS SDK,并在项目中关联 IronSource.framework

  • 变更日志中的下载链接下载最新版 ironSource 适配器,并在项目中下载 IronSourceAdapter.framework

第 4 步:需要其他代码

ironSource iOS 集成不需要其他代码。

第 5 步:测试您的实现效果

如需在 ironSource 上启用测试广告,请运行广告集成应用,并检查日志以查找如下所示的消息:

这是您的测试设备的广告 ID。将其复制到剪贴板。

转到 MONETIZE 标签页,然后点击 Testing 按钮。接下来,点击 New Test Device 按钮。

输入上一步中的设备名称广告 ID。 然后,点击保存

新添加的测试设备列在测试设备下。您可以根据需要在此模块中启用或停用测试广告

可选步骤

根据 Google《欧盟地区用户意见征求政策》,您必须确保向欧洲经济区 (EEA) 内的用户披露与使用设备标识符和个人数据有关的信息,以及征得这些用户的同意。此政策反映了欧盟《电子隐私指令》和《一般数据保护条例》(GDPR) 的要求。在征求用户意见时,您必须指明中介链中可能会收集、接收或使用个人数据的广告联盟,并提供各个广告联盟的使用情况信息。Google 目前无法自动将用户的意见传递给此类网络。

以下部分介绍了如何为 ironSource 启用或停用个性化广告。

在 SDK 版本 6.7.9 中,ironSource 添加 Consent API。以下示例代码将针对以下规则设置用户意见征求: YES 。如果您选择调用此方法,建议您在通过 Google 移动广告 SDK 请求广告之前执行此操作。

#import <IronSource/IronSource.h>
...

[IronSource setConsent:YES];

如需了解详情,请参阅 ironSource 的管理用户意见征求文档。

错误代码

如果适配器未能收到来自 ironSource 的广告,则发布商可以使用以下类中的 GADResponseInfo.adNetworkInfoArray,位于以下类下:

GADMAdapterIronSource
GADMAdapterIronSourceRewarded

广告加载失败时, ironSource 适配器抛出的代码和附带的消息如下:

错误代码 原因
101 AdMob 界面中配置的 ironSource 服务器参数缺失/无效。
102 ironSource 需要 Activity 上下文来初始化其 SDK。
103 每个 ironSource 实例 ID 只能加载 1 个广告。
501-1056 ironSource SDK 错误。如需了解详情,请参阅这份文档
101 AdMob 界面中配置的 ironSource 服务器参数缺失/无效。
102 ironSource 适配器不支持请求的广告格式。
103 已为此网络配置加载了 ironSource 广告。
508-1037 ironSource SDK 错误。如需了解详情,请参阅这份文档

IronSource iOS 中介适配器变更日志

版本 7.2.1.2.0

  • 验证了与 ironSource SDK 版本 7.2.1.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.2.0 版。
  • IronSource SDK 版本 7.2.1.2。

版本 7.2.1.1.0

  • 验证了与 ironSource SDK 版本 7.2.1.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.2.0 版。
  • IronSource SDK 版本 7.2.1.1。

版本 7.2.1.0

  • 验证了与 ironSource SDK 7.2.1 版兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.1.0 版。
  • IronSource SDK 版本 7.2.1。

版本 7.2.0.0

  • 验证了与 ironSource SDK 版本 7.2.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • IronSource SDK 7.2.0 版。

版本 7.1.14.1

  • 经验证与 Google 移动广告 SDK 9.0.0 版本兼容。
  • 现在需要使用 Google 移动广告 SDK 9.0.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 9.0.0 版。
  • IronSource SDK 版本 7.1.14。

版本 7.1.14.0

  • 验证了与 ironSource SDK 版本 7.1.14 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.13.0。
  • IronSource SDK 版本 7.1.14。

版本 7.1.13.0

  • 验证了与 ironSource SDK 版本 7.1.13 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.13.0。
  • IronSource SDK 版本 7.1.13。

版本 7.1.12.0

  • 验证了与 ironSource SDK 版本 7.1.12 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.12.0。
  • IronSource SDK 版本 7.1.12。

版本 7.1.11.1.0

  • 经验证与 ironSource SDK 版本 7.1.11.1 兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.12.0。
  • IronSource SDK 版本 7.1.11.1。

版本 7.1.11.0

  • 验证了与 ironSource SDK 版本 7.1.11 的兼容性。
  • 现在要求的最低操作系统版本为 10.0。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.11.0。
  • IronSource SDK 版本 7.1.11。

版本 7.1.10.0

  • 验证了与 ironSource SDK 版本 7.1.10 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.9.0。
  • IronSource SDK 版本 7.1.10。

版本 7.1.9.0

  • 验证了与 ironSource SDK 版本 7.1.9 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.9.0。
  • IronSource SDK 7.1.9 版。

版本 7.1.8.0

  • 验证了与 ironSource SDK 版本 7.1.8 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.8.0。
  • IronSource SDK 版本 7.1.8。

版本 7.1.7.0

  • 经验证与 ironSource SDK 7.1.7 版兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.7.0。
  • IronSource SDK 7.1.7 版。

版本 7.1.6.1.0

  • 验证了与 ironSource SDK 版本 7.1.6.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • IronSource SDK 版本 7.1.6.1。

版本 7.1.6.0

  • 经验证与 ironSource SDK 7.1.6 版兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • IronSource SDK 7.1.6 版。

版本 7.1.5.1.0

  • 验证了与 ironSource SDK 版本 7.1.5.1 的兼容性。
  • 已放宽对 Google 移动广告 SDK 8.0.0 或更高版本的依赖。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.5.0 版。
  • IronSource SDK 版本 7.1.5.1。

版本 7.1.5.0

  • 验证了与 ironSource SDK 7.1.5 的版本兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.3.0 版。
  • IronSource SDK 7.1.5 版。

版本 7.1.4.0

  • 经验证与 ironSource SDK 7.1.4 版兼容。
  • 现在需要使用 Google 移动广告 SDK 8.3.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.3.0 版。
  • IronSource SDK 7.1.4 版。

版本 7.1.3.0

  • 新增了对插页式激励广告的支持。
  • 验证了与 ironSource SDK 版本 7.1.3 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 8.2.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 8.2.0 版。
  • IronSource SDK 版本 7.1.3。

版本 7.1.2.0

  • 验证了与 ironSource SDK 版本 7.1.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.1.0。
  • IronSource SDK 版本 7.1.2。

版本 7.1.1.0

  • 验证了与 ironSource SDK 7.1.1 的版本兼容。
  • 现在需要使用 Google 移动广告 SDK 8.1.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.1.0。
  • IronSource SDK 7.1.1 版。

版本 7.1.0.1

  • 更新了适配器以使用 .xcframework 格式。
  • 现在需要使用 Google 移动广告 SDK 8.0.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 版本 8.0.0。
  • IronSource SDK 7.1.0 版。

版本 7.1.0.0

  • 验证了与 ironSource SDK 版本 7.1.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.69.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.69.0 版。
  • IronSource SDK 7.1.0 版。

版本 7.0.4.0

  • 验证了与 ironSource SDK 版本 7.0.4 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.68.0 或更高版本。
  • 添加了标准化的适配器错误代码和消息。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.68.0 版。
  • IronSource SDK 7.0.4 版。

版本 7.0.3.0

  • 验证了与 ironSource SDK 版本 7.0.3 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.66.0 版。
  • IronSource SDK 版本 7.0.3。

版本 7.0.2.0

  • 验证了与 ironSource SDK 版本 7.0.2 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.66.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.66.0 版。
  • IronSource SDK 版本 7.0.2。

版本 7.0.1.0

  • 验证了与 ironSource SDK 版本 7.0.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.64.0 版。
  • IronSource SDK 版本 7.0.1。

版本 7.0.0.0

  • 验证了与 ironSource SDK 版本 7.0.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.64.0 或更高版本。
  • 现要求使用最低的 iOS 9.0 版。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.64.0 版。
  • IronSource SDK 版本 7.0.0。

版本 6.18.0.2.0

  • 验证了与 ironSource SDK 版本 6.18.0.2 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.63.0 版。
  • IronSource SDK 版本 6.18.0.2。

版本 6.18.0.1.0

  • 验证了与 ironSource SDK 版本 6.18.0.1 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.63.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.63.0 版。
  • IronSource SDK 版本 6.18.0.1。

版本 6.18.0.0

  • 验证了与 ironSource SDK 版本 6.18.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.63.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.63.0 版。
  • IronSource SDK 版本 6.18.0。

版本 6.17.0.1.0

  • 验证了与 ironSource SDK 版本 6.17.0.1 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.62.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.62.0 版。
  • IronSource SDK 版本 6.17.0.1。

版本 6.17.0.0

  • 验证了与 ironSource SDK 版本 6.17.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.61.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.61.0 版。
  • IronSource SDK 版本 6.17.0。

版本 6.16.3.0

  • 已验证与 ironSource SDK 版本 6.16.3 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.60.0 版。
  • IronSource SDK 版本 6.16.3。

版本 6.16.2.0

  • 验证了与 ironSource SDK 版本 6.16.2 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.60.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.60.0 版。
  • IronSource SDK 版本 6.16.2。

版本 6.16.1.0

  • 验证了与 ironSource SDK 6.16.1 的版本兼容。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • IronSource SDK 版本 6.16.1。

6.16.0.0 版

  • 已验证与 ironSource SDK 版本 6.16.0 的兼容性。
  • 现在需要使用 Google 移动广告 SDK 7.58.0 或更高版本。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.58.0 版。
  • IronSource SDK 版本 6.16.0。

6.15.0.1.0 版

  • 验证了与 ironSource SDK 版本 6.15.0.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.57.0 版。
  • IronSource SDK 版本 6.15.0.1。

6.15.0.0 版

  • 验证了与 ironSource SDK 版本 6.15.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.57.0 版。
  • IronSource SDK 版本 6.15.0。

6.14.0.0 版

  • 已验证与 ironSource SDK 版本 6.14.0 的兼容性。
  • 取消了对 i386 架构的支持。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.56.0 版。
  • IronSource SDK 版本 6.14.0。

6.13.0.1.0 版

  • 验证了与 ironSource SDK 版本 6.13.0.1 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.53.1 版。
  • IronSource SDK 版本 6.13.0.1。

6.12.0.0 版

  • 验证了与 ironSource SDK 版本 6.12.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.53.1 版。
  • IronSource SDK 版本 6.12.0。

6.11.0.0 版

  • 验证了与 ironSource SDK 版本 6.11.0 的兼容性。

构建和测试时使用的工具:

  • Google 移动广告 SDK 7.52.0 版。
  • IronSource SDK 版本 6.11.0。

6.8.7.0 版

  • 验证了与 ironSource SDK 版本 6.8.7 的兼容性。

6.8.6.0 版

  • 验证了与 ironSource SDK 版本 6.8.6 的兼容性。

6.8.5.0 版

  • 验证了与 ironSource SDK 版本 6.8.5 的兼容性。

版本 6.8.4.1.0

  • 验证了与 ironSource SDK 版本 6.8.4.1 的兼容性。

6.8.4.1 版

  • 添加了向 ironSource SDK 发送正确版本号的代码。

6.8.4.0 版

  • 验证了与 ironSource SDK 版本 6.8.4 的兼容性。

6.8.3.0 版

  • 验证了与 ironSource SDK 6.8.3 的兼容性。
  • 新增了对请求多个插页式广告的支持。
  • 修复了加载激励广告时发生崩溃的问题
  • 此版本的适配器需要使用 7.42.2 版或更高版本的 Google 移动广告 SDK。

6.8.0.1 版

  • 更新了适配器以使用新的激励广告 API
  • 此版本的适配器需要使用 7.41.0 或更高版本的 Google 移动广告 SDK

6.8.0.0 版

  • 经过验证的与 ironSource SDK 6.8.0 的兼容性

6.7.12.0 版

  • 经过验证的与 ironSource SDK 6.7.12 的兼容性

6.7.11.0 版

  • 经过验证的与 ironSource SDK 6.7.11 的兼容性

6.7.10.0 版

  • 经过验证的与 ironSource SDK 6.7.10 的兼容性

版本 6.7.9.3.1

  • 向适配器添加了 adapterDidCompletePlayingRewardBasedVideoAd: 回调。

6.7.9.3.0 版

  • 经过验证的与 ironSource SDK 6.7.9.3 的兼容性

版本 6.7.9.2.0

  • 已验证与 ironSource SDK 6.7.9.2 的兼容性

6.7.9.1.0 版

  • 已验证与 ironSource SDK 6.7.9.1 的兼容性

6.7.8.0 版

  • 经过验证的与 ironSource SDK 6.7.8 的兼容性

6.7.7.0 版

  • 为每个广告单元启动一次 IronSource SDK。

6.7.5.0 版

  • 初始版本!
  • 支持插页式视频广告和激励视频广告。