Android sürümleri için Yerler SDK'sı

Platform seçin: Android iOS JavaScript

Google Haritalar Platformu ekibi, SDK'ları düzenli olarak yeni özellikler, hata düzeltmeleri ve performans iyileştirmeleriyle günceller. Bu sayfada, mobil SDK'lara olan bağımlılıklarınızı nasıl yöneteceğiniz konusunda yol gösterici bilgiler verilmektedir.

  • İş açısından kritik uygulamalar için, kullandığınız ana sürümün en yeni nokta sürümüne bağlantı verin (X.*) ve her yıl yeni ana sürüme yükseltin.

    Yıl boyunca uygulamanızın yeni sürümlerini yayınladıkça Android için Yerler SDK'sının daha yeni nokta sürümlerini kullanmaya başlayabilirsiniz. Yeni nokta sürümleri geriye dönük olarak uyumlu olduğundan bu işlem için uygulamanızda güncelleme yapılması gerekmez.

    Avantajları:

    • Android için Yerler SDK'sında sorunlar olduğunu fark ederseniz Mobil destek politikası uyarınca, ana sürümün ilk kullanıma sunulmasından sonraki 12 ay boyunca düzeltmeler geriye dönük olarak uyumlu bir şekilde sağlanır. Düzeltmelerden yararlanmak için acilen incompatible bir SDK sürümüne yükseltmeniz gerekmez.
    • Uygulamanız en son sürüm üzerinde oluşturulduğunda en son iyileştirmeler ve özellikler kolayca benimsenir.
    • SDK'nın en yeni ana sürümüne yıllık artımlı güncellemeler, uygulamanızı uyarlamak, yeniden yazmak ve test etmek için birden fazla ana sürümde geriye dönük olarak uyumsuz olan değişiklikleri işlemek zorunda kalmaktan daha az işlem yapmanızı gerektirebilir.

  • Kritik olmayan uygulamalar için sabit bir sürüme bağlantı oluşturun. Söz konusu düzeltilmiş sürüm için desteğin sonlandırılmasıyla ilgili bir bildirim aldığınızda, güncellenmiş uygulama kodunuzu kullanıcılarınıza sunmak için 12 ayınız olacaktır.

    Avantajları:

    • Daha seyrek bakım çalışması.
    • Uygulamanızın yeni sürümleri, kullanıcıların eski mobil işletim sistemlerini çalıştıran cihazlarını daha uzun süre (siz yeni bir SDK sürümüne yükseltmeniz gerekene kadar) desteklemeye devam eder.

E-posta adresleri izlenen Proje Sahipleri, projelerinin her birini etkileyen değişiklikler hakkında proaktif bildirimler alır. Büyük güncellemeler, kullanımdan kaldırmalar ve diğer değişikliklerden haberdar olun.

Döşeme

Uygulama düzeyindeki build.gradle dosyanızda, ön ek aralığı (+) veya latest yerine her zaman bir sürüm belirtin. Bu sürümler, öngörülemeyen ve tekrarlanamayan derlemelere yol açabilir. Android için Yerler SDK'sı anlamsal sürüm oluşturmaya bağlıdır ve yeni ana sürüm sürümleri zarar veren değişiklikler içerebilir. Desteklenen minimum API düzeyi 21'dir.

dependencies {
    // If updating kotlin-bom version number above, also edit project-level build.gradle definition of $kotlin_version variable
    implementation(platform("org.jetbrains.kotlin:kotlin-bom:$kotlin_version"))
    implementation 'com.google.android.libraries.places:places:3.3.0'
}

Bakım ve yükseltme

Android Studio kullanılabilir daha yeni sürümleri otomatik olarak kontrol eder ve bir bağımlılığın daha yeni bir sürümü kullanılabilir olduğunda bir uyarı sağlar. Teknik borcu en aza indirmek için en kısa sürede mevcut en yeni sürüme güncelleyin. Yeni bir ana sürüme güncelleme yapıyorsanız geriye dönük olarak uyumsuz değişiklikler ve kodunuzu nasıl güncelleyeceğiniz için sürüm notlarına göz atın.

Google Cloud proje sahipleri, yeni sürümler için yoklamanın yanı sıra projelerini etkileyebilecek geriye dönük uyumsuz değişiklikler hakkında e-postalar alır. Geriye dönük olarak uyumsuz değişiklikler hakkında proaktif bildirim almak için projelerinizin her birine izlenen bir e-posta adresiyle sahip rolünü atayın.

Android için Yerler SDK'sından 3.2.0 veya daha eski bir sürüm kullanıyorsanız

Yeni SDK'ya geçerken taşıma gerekmez. Yapmanız gerekenler:

  1. Uygulamanızda kullanılan API anahtarında Places API'yi (Yeni) etkinleştirin. Hem mevcut Android için Yerler SDK'sını hem de Android için Yerler SDK'sını (Yeni) kullanıyorsanız her API sürümü için ayrı bir API anahtarı oluşturmanızı öneririz. Daha fazla bilgi için API Anahtarlarını Kullanma bölümüne bakın.
  2. Modül düzeyindeki build.gradle dosyanızın dependencies bölümünde, places bağımlılığını güncelleyin ve kotlin-bom bağımlılığını ekleyin:

      dependencies {
          implementation(platform("org.jetbrains.kotlin:kotlin-bom:1.8.0"))
          implementation 'com.google.android.libraries.places:places:3.3.0'
      }

    kotlin-bom bağımlılığı hakkında daha fazla bilgi için Geçişli bağımlılıklarda en yeni kotlin-stdlib sürümünün kullanımı bölümüne bakın.

  3. Mevcut uygulamanızı, uygulamanızı başlatmak için yeni Places.initializeWithNewPlacesApiEnabled() yöntemini çağıracak şekilde güncelleyin. Daha fazla bilgi için Place API istemcisini başlatma bölümüne bakın.

Mevcut uygulamalarınız değişmeden çalışmaya devam etse de artık tüm yeni SDK özelliklerinden yararlanabilirsiniz.