Share your feedback and help shape the Display & Video 360 API product roadmap. Take the Display & Video 360 API Annual Survey for 2022 before it closes on September 30th, 2022.

Method: advertisers.lineItems.bulkUpdate

Stay organized with collections Save and categorize content based on your preferences.

Updates multiple line items.

HTTP request

POST https://displayvideo.googleapis.com/v2/advertisers/*/lineItems:bulkUpdate

The URL uses gRPC Transcoding syntax.

Request body

The request body contains data with the following structure:

JSON representation
{
  "lineItemIds": [
    string
  ],
  "targetLineItem": {
    object (LineItem)
  },
  "updateMask": string
}
Fields
lineItemIds[]

string (int64 format)

Required. IDs of line items to update.

targetLineItem

object (LineItem)

Required. A line item object containing the fields to be updated and the new values to assign to all line items specified in lineItemIds."

updateMask

string (FieldMask format)

Required. A field mask identifying which fields to update.

Only the following fields are currently supported:

This is a comma-separated list of fully qualified names of fields. Example: "user.displayName,photo".

Response body

If successful, the response body contains data with the following structure:

Response message for LineItemService.BulkUpdateLineItems.

JSON representation
{
  "updatedLineItemIds": [
    string
  ],
  "failedLineItemIds": [
    string
  ],
  "skippedLineItemIds": [
    string
  ],
  "errors": [
    {
      object (Status)
    }
  ]
}
Fields
updatedLineItemIds[]

string (int64 format)

The IDs of successfully updated line items.

failedLineItemIds[]

string (int64 format)

The IDs of line items that failed to update.

skippedLineItemIds[]

string (int64 format)

The IDs of line items that are skipped for updates. For example, unnecessary mutates that will result in effectively no changes to line items will be skipped and corresponding line item IDs can be tracked here.

errors[]

object (Status)

Errors returned by line items that failed to update.

Authorization Scopes

Requires the following OAuth scope:

  • https://www.googleapis.com/auth/display-video

For more information, see the OAuth 2.0 Overview.