रुकना

संग्रह की मदद से व्यवस्थित रहें अपनी प्राथमिकताओं के आधार पर, कॉन्टेंट को सेव करें और कैटगरी में बांटें.

इस पेज पर Google Maps Platform के उन सभी प्रॉडक्ट और सुविधाओं की जानकारी दी गई है जिन्हें बंद किया जा रहा है. इसमें Maps, रूट, और जगहों में मौजूद प्रॉडक्ट शामिल हैं.

यह सुविधा कैसे काम करती है

प्रॉडक्ट, सुविधा या वर्शन के इस्तेमाल को रोकने की तारीख, रोक लगाए जाने की तारीख के साथ शुरू होती है. प्रॉडक्ट, सुविधा या वर्शन पुराने 12 महीनों के लिए उपलब्ध रहेगा. इस सुविधा के बंद होने की तारीख बीत जाने के बाद, हो सकता है कि प्रॉडक्ट, सुविधा या वर्शन को बंद कर दिया जाए और वह उपलब्ध न हो.

प्रोजेक्ट के ऐसे मालिक जिन्हें मॉनिटर किए गए ईमेल पते मिले हैं उन्हें अपने हर प्रोजेक्ट में हुए बदलावों की सूचनाएं मिलती हैं. अहम अपडेट, रोके गए बदलावों, और दूसरे बदलावों के बारे में जानकारी पाएं.

SDK टूल के वर्शन में, 'ऐप्लिकेशन के इस्तेमाल से जुड़ी रोक'

SDK टूल और Maps JavaScript API में, सुविधा के बंद होने पर वर्शन की उपलब्धता का ध्यान रखा जाता है. नए मुख्य वर्शन में, बदलावों के बारे में एलान किया जाता है. इनमें, सुविधा के बंद होने से जुड़ी जानकारी शामिल है. साथ ही, प्रॉडक्ट की जानकारी में बताया गया है कि हर सुविधा के लिए काम करने वाला वर्शन सबसे ज़्यादा काम करता है. आप बंद की गई सुविधा का इस्तेमाल तब तक कर सकते हैं, जब तक SDK टूल का ज़्यादा से ज़्यादा वर्शन, वर्शन के साथ काम करता है. SDK के अगले मेजर वर्शन में अपग्रेड करने के लिए, आपको अपने कोड से उस सुविधा का इस्तेमाल हटाना होगा जो अब इस्तेमाल में नहीं है या फिर उसे ऐसी जगह ले जाएं.

Maps JavaScript API के वर्शन की उपलब्धता के बारे में ज़्यादा जानें. यह सुविधा हर तिमाही के हिसाब से रिलीज़ की गई है और इसे बंद करने के लिए शेड्यूल किया गया है.

Android के लिए Maps SDK टूल, iOS के लिए Maps SDK टूल, Android के लिए Places SDK टूल, और iOS के लिए Places SDK टूल पर वर्शन डिपेंडेंसी मैनेज करने के बारे में दिशा-निर्देश देखें.

इस्तेमाल पर रोक

इस सेक्शन में उन सभी प्रॉडक्ट और सुविधाओं की जानकारी दी गई है जो फ़िलहाल बंद हैं.


लोकल कॉन्टेक्स्ट लाइब्रेरी, Maps JavaScript एपीआई (v3.52.2 के तौर पर हटाई गई)

इस बीटा सुविधा के सीमित मंज़ूरी की वजह से, स्थानीय संदर्भ लाइब्रेरी को v3.52.2 के साथ रोक दिया गया है. स्थानीय संदर्भ लाइब्रेरी अगली सूचना मिलने तक काम करती रहेगी, लेकिन हम इसे नए प्रोजेक्ट में जोड़ने का सुझाव नहीं देते.

अगर आपको स्थानीय संदर्भ लाइब्रेरी जैसा अनुभव बनाने में दिलचस्पी है, तो हमारा सुझाव है कि आप क्विक बिल्डर में "नेबर डिस्कवरी" समाधान देखें या जगहों की लाइब्रेरी, Maps JavaScript एपीआई का इस्तेमाल करें. जगहों के लाइब्रेरी के कोड के नमूने और कोडलैब (कोड बनाना सिखाने वाले ट्यूटोरियल) से आपको मदद मिल सकती है.


Android के लिए Places SDK टूल के लिए Places के साथ काम करने की लाइब्रेरी (31 मार्च, 2022 से)

Android के लिए 'प्लेस SDK टूल' के लिए 'जगहों की जानकारी वाली लाइब्रेरी' के सभी वर्शन 31 मार्च, 2022 से काम नहीं करेंगे. हम Android v2.6.0 के लिए Places SDK टूल पर Places कंपैटबिलिटी लाइब्रेरी को डेवलप कर रहे हैं. इसे com.google.android.libraries.places:places-compat:2.6.0 के तौर पर डिपेंडेंसी में बताया गया है.

इस तारीख के बाद इस लाइब्रेरी का कोई भी नया वर्शन रिलीज़ नहीं किया जाएगा. Android के लिए Places SDK टूल में 2.6.0 से ऊपर के वर्शन में सुविधाओं और गड़बड़ी ठीक करने के तरीकों को ऐक्सेस करने के लिए, Android के लिए Places SDK टूल का इस्तेमाल किया जा सकता है.

'जगहों के साथ काम करने वाली लाइब्रेरी' जनवरी 2019 में लॉन्च की गई थी. इससे Android के लिए, स्टैंडअलोन SDK टूल को Play SDK टूल के पुराने वर्शन से माइग्रेट किया जा सकेगा.

सीधे Android के लिए Places SDK टूल का इस्तेमाल करने के लिए डेटा को दूसरी जगह भेजने से जुड़ी गाइड देखें. कुछ स्थितियों के कोड, मेथड के नाम, और ऑटोकंप्लीट की सुविधा के लिए दिए गए कुछ नाम, 'जगह की जानकारी से जुड़ी लाइब्रेरी' और Android के लिए 'प्लेस SDK टूल' के बीच अलग-अलग होते हैं. Android के लिए Places SDK टूल के वर्शन पर निर्भरता तय करने और उन्हें बनाए रखने के लिए वर्शन दस्तावेज़ देखें.

इस समय, जगहों की जानकारी वाली लाइब्रेरी को बंद करने की कोई योजना नहीं है. हालांकि, अगर आप जगहों के साथ काम करने की सुविधा वाली लाइब्रेरी के उपलब्ध वर्शन का इस्तेमाल जारी रखना चाहते हैं, तो SDK टूल के पुराने वर्शन के इस्तेमाल से जुड़ी सीमाओं पर ध्यान दें.


Places API और Places लाइब्रेरी में, काम न करने वाली प्लेस सर्च क्वेरी (31 मार्च, 2022 - 31 मार्च, 2023)

Places API और Places लाइब्रेरी में, टेक्स्ट खोजने, आस-पास खोजने की सुविधा, और जगह खोजने की सुविधा के लिए, काम न करने वाली प्लेस सर्च क्वेरी 31 मार्च, 2022 से काम नहीं करेंगी. साथ ही, इन्हें 31 मार्च, 2023 से INVALID_REQUEST गड़बड़ी के जवाब मिलेंगे.

जगह एपीआई और जगहों की लाइब्रेरी, Maps JavaScript एपीआई इन तीन तरीकों का इस्तेमाल करके जगहें ढूंढ सकते हैं: टेक्स्ट सर्च, आस-पास की जगहें खोजने की सुविधा, और जगह खोजें. हर तरीका, पैरामीटर के साथ काम करने वाले कॉम्बिनेशन के अनुरोध स्वीकार करता है. साथ ही, ऐसे पैरामीटर के ज़्यादातर अनुरोध को अस्वीकार कर देता है जो काम नहीं करते.

काम न करने वाले पैरामीटर के कुछ कॉम्बिनेशन अब तक सही तरीके से अस्वीकार नहीं किए गए हैं:

  • टेक्स्ट खोज के ऐसे अनुरोध जिनके लिए कोई पैरामीटर मौजूद न हो या जिनमें query मौजूद न हो या जिनमें type पैरामीटर काम न करता हो.
  • query=* की मदद से, टेक्स्ट खोज के अनुरोध.
  • keyword=* के आस-पास खोज के अनुरोध.
  • name=* के आस-पास खोज के अनुरोध.
  • input=* के साथ किए गए अनुरोध देखें.

इन काम न करने वाले स्थान खोज अनुरोधों को इनमें से किसी एक के साथ बदला जाना चाहिए:

  • आस-पास खोज करने के लिए, keyword या name पैरामीटर के बिना आस-पास की खोज अनुरोधों का इस्तेमाल किया जा सकता है. यह सुझाव दिया जाता है कि type पैरामीटर का इस्तेमाल एक ही तरह के के साथ करें (टेबल 1: जगह किस तरह की है देखें). यह टेक्स्ट पैरामीटर से जुड़े अनुरोधों के मौजूदा व्यवहार से सबसे ज़्यादा मिलता-जुलता है. इसका इस्तेमाल करने के लिए, query पैरामीटर खाली या उपलब्ध नहीं होता है.

  • जियोकोडिंग एपीआई latlng पैरामीटर वाले अनुरोधों का इस्तेमाल करके, नज़दीकी पते खोजे जा सकते हैं. यह इन तरीकों से मौजूदा व्यवहार के लिए सबसे करीब है:

    • query=* की मदद से, टेक्स्ट खोज के अनुरोध.
    • keyword=* के आस-पास खोज के अनुरोध.
    • name=* के आस-पास खोज के अनुरोध.
    • input=* के साथ किए गए अनुरोध देखें.

कॉन्टेंट की सुरक्षा से जुड़ी नीति में अपडेट (21 मार्च, 2022 - मई 2023)

कॉन्टेंट की सुरक्षा नीति (CSP) का इस्तेमाल करने वाली ऐसी वेबसाइटों के लिए सहायता जो Maps JavaScript API में googleapis.com के बारे में नहीं बताती हैं, उन्हें v3.49 के तौर पर बंद कर दिया गया है और v3.50 से शुरू नहीं हो पाएंगी. इसके बाद, 23.49 वर्शन 2.29 में बंद हो जाएगा. इसके बाद, Maps JavaScript API, CSP डायरेक्टिव का इस्तेमाल करके सभी अनुरोधों को अस्वीकार कर देगा. इनमें googleapis.com के बारे में जानकारी नहीं होती.

अपनी वेबसाइट के इस्तेमाल में किसी तरह की रुकावट से बचने के लिए, अपने सीएसपी में googleapis.com की जानकारी दें. Maps JavaScript API के मौजूदा सभी वर्शन, सीएसपी के साथ काम करते हैं.


Google Maps Platform की गेमिंग सेवाएं (18 अक्टूबर, 2021 - 31 दिसंबर, 2022)

Google Maps Platform की गेमिंग सेवाओं को 18 अक्टूबर, 2021 से बंद कर दिया गया है. इसे 31 दिसंबर, 2022 को बंद कर दिया जाएगा. बंद होने के दौरान, Google बड़ी गड़बड़ियों और रुकावटों के लिए सहायता और समाधान देता रहेगा. मदद के लिए, गेमिंग सेवाओं के लिए ट्रांज़िशन गाइड देखें. इससे आपको अपने प्रोजेक्ट के लिए, आगे की योजना बनाने में मदद मिलेगी.


पुरानी जगहों के आईडी (16 मार्च, 2021 - 30 मार्च, 2022)

Google Maps Platform के सभी एपीआई, 30 मार्च, 2022 से जगह के कुछ पुराने आईडी स्वीकार नहीं करेंगे. पुराने आईडी का इस्तेमाल करके, किए गए सभी अनुरोधों को 30 मार्च, 2022 से अस्वीकार कर दिया जाएगा. साथ ही, गड़बड़ी का कोड INVALID_REQUEST दिखेगा. उपयोगकर्ता अनुभव में गिरावट को रोकने के लिए, कृपया 30 मार्च, 2022 से पहले 12 महीने से ज़्यादा पुराने सभी जगह के आईडी रीफ़्रेश करें.


google.load में मैप मॉड्यूल (13 अक्टूबर, 2020 - 13 अक्टूबर, 2021)

google.load के लिए "Maps" मॉड्यूल देने वाली सेवा, 13 अक्टूबर, 2020 से बंद कर दी जाएगी. यह 13 अक्टूबर, 2021 को बंद हो जाएगी. google.load में "मैप" मॉड्यूल लोड करने के लिए बाद के अनुरोधों में गड़बड़ी होगी और कोई मैप लोड नहीं होगा. ज़्यादा जानकारी के लिए, डेटा को दूसरी जगह भेजने से जुड़ी गाइड देखें.


iOS GMSPlaceField के लिए Places SDK टूल अब NS_OPTIONS मैक्रो का इस्तेमाल करता है (v4.0.0 की तरह)

iOS के लिए Places SDK टूल v4.0.0 के साथ, GMSPlaceField अब बेहतर स्विफ़्ट सहायता के लिए,NS_ENUM के बजाय NS_OPTIONS मैक्रो का इस्तेमाल करता है. GMSPlaceField पर NS_OPTIONS में माइग्रेट करने के बारे में ज़्यादा पढ़ें.

GMSPlaceField को NS_ENUM के तौर पर इस्तेमाल करते रहने के लिए, v3.10.0 या इससे पहले की डिपेंडेंसी में बताएं.


iOS के लिए, SDK टूल के जगहें: setAutocompleteBoundsusingउत्तरीईस्टकॉर्न:दक्षिणईस्ट कोने, initWithBounds:filter (v3.10.0 - v4.0.0)

setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner हेल्पर तरीके को v3.10.0 के साथ बंद कर दिया गया है. और यह v4.0.0 और इसके बाद के वर्शन पर काम नहीं करता. इसके बजाय, locationBias, या locationRestriction का इस्तेमाल करें.

initWithBounds:filter तरीका को v3.10.0 के साथ बंद कर दिया गया है, और यह v4.0.0 और इसके बाद के वर्शन पर काम नहीं करता. इसके बजाय, GMSAutocompleteFetcher में initWithFilter: का इस्तेमाल करें.

v3.10.0 के लिए, इन तरीकों का इस्तेमाल किया जा सकता है.

बदलाव करने के तरीकों के बारे में ज़्यादा जानने के लिए, अपेंडिक्स 1 देखें.


GMSCoordinateBounds जगह पर अपने-आप पूरा होने की सुविधा (v3.9.0 - v4.0.0)

iOS Autocomplete सेवा के लिए Places SDK टूल में GMSCoordinateBounds का इस्तेमाल करने वाली कई प्रॉपर्टी/पैरामीटर को v3.9.0 के तौर पर बंद कर दिया गया है और ये v4.0.0 और इसके बाद के वर्शन में काम नहीं करते हैं. इसके साथ काम न करने वाली प्रॉपर्टी/पैरामीटर का वर्शन v3.10.0 होना चाहिए.

GMSAutocompleteViewController में सीमाएं

नीचे दी गई GMSAutocompleteViewController प्रॉपर्टी के इस्तेमाल पर रोक लगा दी गई है:

एक जैसे फ़ंक्शन के लिए, GMSAutocompleteFilter.locationBias या GMSAutocompleteFilter.locationRestriction के साथ GMSAutocompleteViewController.autocompleteFilter का इस्तेमाल करें. इन रिप्लेसमेंट प्रॉपर्टी के लिए iOS के लिए Places SDK टूल का कम से कम वर्शन v3.8.0 है.

findAutocompletePredictionsFromQuery और autocompleteQuery में सीमाएं

एक जैसे फ़ंक्शन के लिए, GMSAutocompleteFilter.locationBias या GMSAutocompleteFilter.locationRestriction के साथ findAutocompletePredictionsFromQuery:filter:sessionToken:callback का इस्तेमाल करें. इन रिप्लेसमेंट प्रॉपर्टी वाले iOS के लिए Places SDK टूल का कम से कम वर्शन v3.8.0 है.

बदलाव करने के तरीकों के बारे में ज़्यादा जानने के लिए, अपेंडिक्स 1 देखें.


जगहें फ़ील्ड GMSPlace.openNowStatus (v3.0.0 - v4.0.0)

iOS के लिए जगहें SDK टूल में 'जगहें' फ़ील्ड/प्रॉपर्टी GMSPlace.openNowStatus v3.0.0 के तौर पर उपलब्ध नहीं है और v4.0.0 और इसके बाद के वर्शन में काम नहीं करती है. इस फ़ील्ड के लिए, ज़्यादा से ज़्यादा v3.10.0 वर्शन इस्तेमाल किया जा सकता है.

इसके बजाय, फ़ंक्शन GMSPlace.isOpen या GMSPlace.isOpenAtDate का इस्तेमाल करें. इन बदले जाने वाले फ़ंक्शन के साथ iOS के लिए Places SDK टूल का कम से कम वर्शन v3.3.0 है.


जगहों का फ़ील्ड: permanently_closed (26 मई, 2020 को बंद किया गया)

Places API और Places लाइब्रेरी में Places फ़ील्ड permanently_closed, Maps JavaScript API बहिष्कृत हो गया है और इसका उपयोग नहीं किया जाना चाहिए. इसके बजाय, कारोबार की स्थिति जानने के लिए, business_status (जगहों के लिए एपीआई) या business_status (जगहों की लाइब्रेरी, JavaScript एपीआई) का इस्तेमाल करें. Places लाइब्रेरी का कम से कम वर्शन, business_status के साथ Maps JavaScript API v3.40 है.


जगहों के फ़ील्ड open_now, utc_offset (20 नवंबर, 2019 को बंद)

'जगहें' लाइब्रेरी में 'जगहें' फ़ील्ड open_now और utc_offset फ़ील्ड, 20 नवंबर, 2019 से काम नहीं कर रहे हैं और इनका इस्तेमाल नहीं किया जाना चाहिए.

ये फ़ील्ड सिर्फ़ जगहें लाइब्रेरी, Maps JavaScript एपीआई में काम नहीं करती हैं.

  • open_now फ़ील्ड को जगह की जानकारी में PlaceResult.opening_hours.isOpen() से बदल दिया गया है. आस-पास की खोज और टेक्स्ट खोज के लिए, openNow:true अनुरोध पैरामीटर का उपयोग करके उन स्थानों को फ़िल्टर करें, जो वर्तमान में खुले हैं. 'ढूंढें' के लिए कोई अनुमति नहीं दी गई है. यह मान पाने के लिए, अब आपको जगह की जानकारी का अनुरोध करना होगा.
  • utc_offset फ़ील्ड को जगह की जानकारी में PlaceResult.utc_offset_minutes से बदल दिया गया है.

ज़्यादा जानने के लिए, जगहों का फ़ील्ड माइग्रेट करना देखें.


Maps JavaScript API: google.maps.event.addDomListener() और google.maps.event.addDomListenerOnce() (7 अप्रैल, 2022 को बंद कर दिया गया)

Maps JavaScript API में, [google.maps.event.addDomListener()](/maps/documentation/javascript/reference/event#event.addDomListener) और [google.maps.event.addDomListenerOnce()](/maps/documentation/javascript/reference/event#event.addDomListenerOnce) फ़ंक्शन के इस्तेमाल पर रोक लगा दी गई है. इनका इस्तेमाल नहीं करना चाहिए. इसके बजाय, स्टैंडर्ड addEventListener() तरीके का इस्तेमाल करें.

ये तरीके काम करते रहेंगे. साथ ही, इन्हें बंद करने की कोई योजना नहीं है.


रोके गए पूरे

इस सेक्शन में, बंद किए गए सभी प्रॉडक्ट और सुविधाओं की सूची दी गई है. ये प्रॉडक्ट और सुविधाएं अब उपलब्ध नहीं हैं.


Maps JavaScript API v2 (19 मई, 2010 - 26 मई, 2021)

Maps JavaScript API का दूसरा वर्शन 26 मई, 2021 से उपलब्ध नहीं है. इस वजह से, आपकी साइट के वर्शन 2 मैप काम करना बंद कर देंगे. साथ ही, इससे JavaScript की गड़बड़ियां भी मिलेंगी. अपनी साइट पर मैप का इस्तेमाल जारी रखने के लिए, Maps JavaScript API v3 पर माइग्रेट करें. अपने Maps JavaScript एपीआई ऐप्लिकेशन को v2 से v3 में अपग्रेड करने के बारे में ज़्यादा जानें.


जगहों के फ़ील्ड: reference, id, alt_id, scope (3 सितंबर, 2019 - 10 अगस्त, 2020)

id, alt_id, और scope के लिए फ़ील्ड फ़ील्ड, 10 अगस्त, 2020 से उपलब्ध नहीं है. जगहें फ़ील्ड reference के इस्तेमाल पर रोक लगा दी गई है. इसका इस्तेमाल नहीं किया जाना चाहिए.

  • id रिस्पॉन्स फ़ील्ड को place_id रिस्पॉन्स फ़ील्ड से बदल दिया गया है.
  • reference रिस्पॉन्स फ़ील्ड को place_id रिस्पॉन्स से बदल दिया गया है. इसलिए, इसका इस्तेमाल नहीं किया जाना चाहिए.
  • alt_id और scope फ़ील्ड में इसके बराबर वैल्यू नहीं है, क्योंकि इनका इस्तेमाल सिर्फ़ जगह की जानकारी जोड़ने की सेवा के लिए किया गया था. इसे जुलाई 2018 में बंद कर दिया गया था.

ज़्यादा जानकारी के लिए, जगह की जानकारी का डेटा दूसरी जगह भेजना देखें.


iOS 5.0 के लिए Maps SDK टूल में iOS 10, ARMv7 32-बिट आर्किटेक्चर

iOS 5.0 वर्शन के लिए Maps SDK टूल के बाद से, iOS 10 और ARMv7 32-बिट आर्किटेक्चर अब काम नहीं करता.

iOS के लिए Places SDK टूल

iOS 5.0 के लिए Places SDK टूल के रिलीज़ होने के साथ, GMSCoordinateBounds को GMSPlacesViewportInfo से बदल दिया गया है.

Fusion Tables लेयर (प्रयोग के मुताबिक) (3 दिसंबर, 2018 - 3 दिसंबर, 2019)

Maps JavaScript API में फ़्यूज़न टेबल का लेयर 3 दिसंबर, 2019 को बंद कर दिया गया था. यह वर्शन 3.38 (3.37) का आखिरी वर्शन है, जिसमें फ़्यूज़न टेबल का इस्तेमाल नहीं किया जा सकता. ज़्यादा जानें.


Android और iOS के लिए Places SDK टूल (29 जनवरी, 2019 - 29 जुलाई, 2019)

29 जनवरी, 2019 से Android और iOS के लिए अपग्रेड किए गए Places SDK टूल, Places SDK टूल के मौजूदा वर्शन की जगह ले लेंगे. 29 जनवरी, 2019 से iOS के लिए 'प्लेस SDK टूल', और Android के लिए 'प्लेस SDK टूल' को बंद कर दिया गया था. इसे 29 जुलाई, 2019 को बंद कर दिया गया था.


स्थान जोड़ें और स्थान हटाएं (30 जून, 2017 - 30 जून, 2018)

'जगह की जानकारी जोड़ें' और 'जगह की जानकारी मिटाएं' सुविधा 30 जून, 2018 से बंद कर दी गई है.


अतिरिक्त विषय 1: iOS में काम करने वाले एपीआई बदलने के लिए जगहों के SDK टूल की खास जानकारी

नीचे दी गई टेबल में, इस्तेमाल न किए जाने वाले हर तरीके या प्रॉपर्टी के लिए इस्तेमाल करने का तरीका बताया गया है.

काम न करने वाला तरीका/प्रॉपर्टी इसका इस्तेमाल करें
setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner
(GMSAutocompleteViewController में)
locationRestriction और locationBias
setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner
(GMSAutocompleteResultsViewController में)
locationRestriction और locationBias
setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner
(GMSAutocompleteTableDataSource में)
locationRestriction और locationBias
initWithBounds:filter
(GMSAutocompleteFetcher में)
initWithFilter:
autocompleteBounds और autocompleteBoundsMode
(GMSAutocompleteViewController में)
locationBias या locationRestriction के साथ GMSAutocompleteViewController.autocompleteFilter.
findAutocompletePredictionsFromQuery:bounds:boundsMode:filter:SessionToken:callback, autocompleteQuery:bounds:filter:callback, और autocompleteQuery:bounds:boundsMode:filter:callback
(GMSPlacesClient में)
findAutocompletePredictionsFromQuery:filter:sessionToken:callback, जिसमें locationBias या locationRestriction हो.

iOS के लिए रिप्लेसमेंट प्रॉपर्टी वाला Places SDK टूल, v3.8.0 का कम से कम वर्शन होना चाहिए.