Supported platforms

Desktop browser compatibility table

Gmail's AMP rendering relies on modern browser features which are not supported by all web browsers.

On incompatible browsers, emails fallback to HTML.

Browser Minimum version
Chrome 69
Edge Not supported
Firefox 58
Internet Explorer Not supported
Opera 48
Safari 10

Mobile support

Mobile support is currently in open beta.

Requirements

Dynamic emails are supported in the latest version of the official Gmail app for iOS and official Gmail app for Android.

On Android, the minimum required OS version is 5.0 (Android Lollipop) with the system WebView version of 74 or above.

Joining the beta

To join the beta channel for dynamic emails in Gmail on Android and iOS, follow these steps.

  1. Make sure you're logged in with the Gmail account you want to join the beta channel with. This should be your user test account you use to receive dynamic emails.

  2. Navigate to AMP in Gmail mobile - beta channel.

  3. Click Join group, and then confirm by clicking Join this group in the dialog.

  4. Your account will be enrolled in the next 24-48 hours.

Alternatively, you can join the group directly from this page: