Method: courses.announcements.patch

Updates one or more fields of an announcement.

This method returns the following error codes:

  • PERMISSION_DENIED if the requesting developer project did not create the corresponding announcement or for access errors.
  • INVALID_ARGUMENT if the request is malformed.
  • FAILED_PRECONDITION if the requested announcement has already been deleted.
  • NOT_FOUND if the requested course or announcement does not exist

HTTP request

PATCH https://classroom.googleapis.com/v1/courses/{courseId}/announcements/{id}

The URL uses Google API HTTP annotation syntax.

Path parameters

Parameters
courseId

string

Identifier of the course. This identifier can be either the Classroom-assigned identifier or an alias.

id

string

Identifier of the announcement.

Query parameters

Parameters
updateMask

string (FieldMask format)

Mask that identifies which fields on the announcement to update. This field is required to do an update. The update fails if invalid fields are specified. If a field supports empty values, it can be cleared by specifying it in the update mask and not in the Announcement object. If a field that does not support empty values is included in the update mask and not set in the Announcement object, an INVALID_ARGUMENT error will be returned.

The following fields may be specified by teachers:

  • text
  • state
  • scheduledTime

A comma-separated list of fully qualified names of fields. Example: "user.displayName,photo".

Request body

The request body contains an instance of Announcement.

Response body

If successful, the response body contains an instance of Announcement.

Authorization Scopes

Requires the following OAuth scope:

  • https://www.googleapis.com/auth/classroom.announcements

For more information, see the OAuth 2.0 Overview.

Try it!

Send feedback about...

Classroom API
Classroom API
Need help? Visit our support page.