Workspaces: create_version

Requiere autorización

Crea un recurso Container Version a partir de las entidades presentes en el recurso Workspace, elimina el recurso Workspace y configura el recurso Container Version básico en la versión recién creada. Pruébalo ahora.

Solicitud

Solicitud HTTP

POST https://www.googleapis.com/tagmanager/v2/+path:create_version

Parámetros

Nombre de parámetro Valor Descripción
Parámetros de ruta
path string Ruta relativa de la API del recurso Workspace de GTM. Ejemplo: accounts/{account_id}/containers/{container_id}/workspaces/{workspace_id}

Autorización

Esta solicitud requiere autorización con el siguiente ámbito. Consulta más información sobre la autenticación y la autorización.

Ámbito
https://www.googleapis.com/auth/tagmanager.edit.containerversions

Cuerpo de la solicitud

En el cuerpo de la solicitud, proporciona datos con la siguiente estructura:

{
  "name": string,
  "notes": string
}
Nombre de propiedad Valor Descripción Notas
name string Nombre del recurso Container Version que se creará.
notes string Notas del recurso Container Version que se creará.

Respuesta

Si este método se realiza correctamente, el cuerpo de respuesta tendrá la siguiente estructura:

{
  "containerVersion": accounts.containers.versions Resource,
  "syncStatus": {
    "mergeConflict": boolean,
    "syncError": boolean
  },
  "compilerError": boolean,
  "newWorkspacePath": string
}
Nombre de propiedad Valor Descripción Notas
containerVersion nested object Recurso Container Version creado.
syncStatus nested object Indica si se ha creado la versión al sincronizar el recurso Workspace con el último Container Version.
syncStatus.mergeConflict boolean La operación de sincronización ha detectado un conflicto de combinación.
syncStatus.syncError boolean Se ha producido un error durante la operación de sincronización.
compilerError boolean Indica si hay errores de compilador.
newWorkspacePath string Ruta del recurso Workspace generada automáticamente como resultado de la creación de la versión. Este campo solo debe rellenarse si la versión que se ha creado no es una vista previa rápida.

Pruébalo

Utiliza el siguiente explorador de APIs para llamar a este método con datos en tiempo real y ver la respuesta.