रुकना

इस पेज पर Google Maps Platform के उन सभी प्रॉडक्ट और सुविधाओं की सूची दी गई है जिन पर रोक लगी है. इसमें मैप, रूट, और जगहें में मौजूद प्रॉडक्ट शामिल हैं.

अमान्य ट्रैफ़िक को रोकने की सुविधा कैसे काम करती है

किसी प्रॉडक्ट, सुविधा या वर्शन का इस्तेमाल बंद करने की समयसीमा, एलान की तारीख से शुरू होती है. प्रॉडक्ट, सुविधा या वर्शन, बंद होने की अवधि (आम तौर पर 12 महीने) के दौरान भी उपलब्ध रहेगा. रोके जाने की अवधि खत्म होने के बाद, प्रॉडक्ट, सुविधा या वर्शन को बंद कर दिया जाएगा. वह प्रॉडक्ट, सुविधा या वर्शन उपलब्ध नहीं रहेगा.

प्रोजेक्ट के मालिकों को निगरानी वाले ईमेल पतों पर, प्रोजेक्ट पर होने वाले बदलावों के बारे में अपने-आप सूचनाएं मिलती हैं. बड़े अपडेट, किसी सुविधा को बंद होने, और अन्य बदलावों के बारे में सूचना पाएं.

SDK टूल के वर्शन में, सुविधा बंद हो गई है

SDK टूल और Maps JavaScript API में, सुविधा बंद होने के चरण, वर्शन उपलब्ध होने के हिसाब से तय होते हैं. नए मेजर वर्शन में नुकसान पहुंचाने वाले बदलावों का एलान किया गया है. इनमें सुविधा का इस्तेमाल बंद होना और प्रॉडक्ट की जानकारी वाली जानकारी शामिल है. इससे पता चलता है कि हर उस सुविधा के सबसे ज़्यादा वर्शन के साथ काम करने वाले वर्शन का कितना इस्तेमाल किया जा सकता है. बंद की गई सुविधा का इस्तेमाल तब तक जारी रखा जा सकता है, जब तक उस SDK टूल के साथ काम करने वाला ज़्यादा से ज़्यादा वर्शन उपलब्ध है. SDK टूल के अगले मेजर वर्शन पर अपग्रेड करने के लिए, आपको अपने कोड से उस सुविधा का इस्तेमाल हटाना होगा जो अब सेवा में नहीं है या उसकी जगह पर माइग्रेट करना होगा.

Maps JavaScript API वर्शन की उपलब्धता के बारे में ज़्यादा जानें. यह वर्शन तीन महीने में रिलीज़ होने और बंद होने के शेड्यूल के बाद आता है.

Android के लिए Maps SDK टूल, iOS के लिए Maps SDK टूल, Android के लिए जगहें SDK टूल, और iOS के लिए साइट के SDK टूल की मदद से, वर्शन डिपेंडेंसी मैनेज करने के बारे में दिशा-निर्देश देखें.

इस्तेमाल पर रोक लगाई गई है

इस सेक्शन में वे सभी प्रॉडक्ट और सुविधाएं शामिल होती हैं जो फ़िलहाल बंद हो चुकी हैं.


Maps JavaScript API में google.maps.Marker (फ़रवरी 2023 से बंद कर दिया गया है)

google.maps.marker.AdvancedMarkerElement: करीब-करीब सभी मामलों में इस्तेमाल करने में आसान, ज़्यादा परफ़ॉर्म करने वाला, ज़्यादा ऐक्सेस करने लायक, ज़्यादा सुविधाओं से भरा, और ज़्यादा पसंद के मुताबिक बनाया गया. Maps JavaScript API में google.maps.Marker को 3.56 से बंद कर दिया गया है.

मुझे क्या करना होगा? इसके बजाय, google.maps.marker.AdvancedMarkerElement का इस्तेमाल करें. google.maps.marker.AdvancedMarkerElement के साथ Maps JavaScript API का कम से कम वर्शन 3.53.2 है. इस समय google.maps.Marker को बंद करने के लिए शेड्यूल नहीं किया गया है, लेकिन google.maps.MarkerElement पर google.maps.marker.AdvancedMarkerElement की सलाह दी जाती है. हालांकि google.maps.Marker को किसी भी बड़े रिग्रेशन के लिए बग समाधान मिलते रहेंगे, लेकिन google.maps.Marker में मौजूद मौजूदा गड़बड़ियों पर ध्यान नहीं दिया जाएगा. सहायता बंद करने के कम से कम 12 महीने पहले आपको इसकी सूचना दी जाएगी.


Maps JavaScript API स्थान ऑटोकंप्लीट सेवा में सीमाएं, जगह, और दायरा (मई 2023 से बंद)

Maps JavaScript API में, जगह की जानकारी के अपने-आप पूरे होने की सुविधा के लिए, मई 2023 से अनुरोध के ये विकल्प बंद कर दिए गए हैं: सीमाएं, जगह, और दायरा. इसके बजाय, कृपया locationBias और Locationपाबंदी का इस्तेमाल करें.

यह सुविधा काम करती रहेगी. साथ ही, सहायता बंद करने से 12 महीने पहले आपको सूचना दी जाएगी.


Android पर Places SDK टूल के साथ काम करने वाली जगहों की लाइब्रेरी (31 मार्च, 2022 तक)

Android के लिए, Places SDK टूल के साथ काम करने वाली जगहों की लाइब्रेरी के सभी वर्शन 31 मार्च, 2022 से बंद कर दिए गए हैं. हम Android v2.6.0 के लिए Places SDK पर, 'जगहें काम करने की क्षमता' लाइब्रेरी का डेवलपमेंट रोक रहे हैं (इसे com.google.android.libraries.places:places-compat:2.6.0 के तौर पर डिपेंडेंसी में बताया गया है).

इस तारीख के बाद, इस लाइब्रेरी का कोई भी नया वर्शन रिलीज़ नहीं किया जाएगा. Android के लिए स्थल SDK में 2.6.0 के बाद के वर्शन में सुविधाओं को ऐक्सेस करने और बग समाधान करने का एक ही तरीका है Android के लिए स्थल SDK का उपयोग करना.

'जगहें' के साथ काम करने वाली लाइब्रेरी को जनवरी 2019 में लॉन्च किया गया था. इसका मकसद, लेगसी SDK टूल (Play Services में उपलब्ध) से Android के लिए, Places SDK टूल में माइग्रेशन को आसान बनाना था.

सीधे Android के लिए Places SDK टूल का इस्तेमाल करने के लिए, डेटा को दूसरी जगह भेजने से जुड़ी गाइड देखें. कुछ स्टेटस कोड, तरीके के नाम, और ऑटोकंप्लीट क्लास के नाम, जगहों के साथ काम करने वाली लाइब्रेरी और Android के लिए 'जगहें SDK' टूल के बीच अलग-अलग होते हैं. Android के लिए स्थल SDK के वर्शन पर निर्भरता तय करने और बनाए रखने के लिए वर्शन दस्तावेज़ देखें.

फ़िलहाल, Spaces के साथ काम करने वाली लाइब्रेरी को बंद करने की कोई योजना नहीं है. हालांकि, अगर जगहों के साथ काम करने वाली लाइब्रेरी के उपलब्ध वर्शन का इस्तेमाल जारी रखना है, तो SDK टूल के पुराने वर्शन पर काम करने से जुड़ी सीमाओं पर ध्यान दें.


कॉन्टेंट की सुरक्षा के बारे में नीति का अपडेट (21 मार्च, 2022 - मई 2023)

कॉन्टेंट की सुरक्षा के बारे में नीति (सीएसपी) का इस्तेमाल करने वाली ऐसी वेबसाइटों के लिए सहायता को v3.49 से हटा दिया गया है जो Maps JavaScript API में googleapis.com के बारे में नहीं बताती हैं. v3.50 से शुरू होने पर, इन्हें इस्तेमाल नहीं किया जा सकेगा. ऐप्लिकेशन के आखिरी वर्शन v3.49 को, 2023 की दूसरी तिमाही में बंद कर दिया जाएगा. इसके बाद, Maps JavaScript API उन सभी अनुरोधों को अस्वीकार कर देगा जिनमें googleapis.com के बारे में नहीं बताया जाएगा. ऐसा सीएसपी निर्देशों का इस्तेमाल करके किया जाएगा.

वेबसाइट इस्तेमाल करने के दौरान किसी तरह की रुकावट न हो, इसके लिए अपने सीएसपी में googleapis.com के बारे में बताएं. Maps JavaScript API के सभी मौजूदा वर्शन, सीएसपी के साथ काम करते हैं.


Google Maps Platform की गेमिंग सेवाएं (18 अक्टूबर, 2021 से 31 दिसंबर, 2022)

Google Maps Platform की गेमिंग सेवाओं को 18 अक्टूबर, 2021 से बंद कर दिया गया है. इन्हें 31 दिसंबर, 2022 को बंद कर दिया जाएगा. सेवा बंद होने के दौरान, Google बड़ी गड़बड़ियों और रुकावटों के लिए सहायता और समाधान देता रहेगा. गेमिंग सेवाओं के ट्रांज़िशन गाइड देखें. यहां आपको उन संसाधनों की जानकारी मिलेगी जिनसे आपको अपने प्रोजेक्ट के लिए अगला कदम उठाने में मदद मिलेगी.


पुराने प्लेस आईडी (16 मार्च, 2021 से 30 मार्च, 2022)

सभी Google Maps Platform एपीआई 30 मार्च, 2022 से कुछ पुराने प्लेस आईडी स्वीकार नहीं करेंगे. पुराने आईडी का इस्तेमाल करके किए गए अनुरोध 30 मार्च, 2022 से अस्वीकार कर दिए जाएंगे. साथ ही, उन्हें गड़बड़ी कोड INVALID_REQUEST दिखेगा. उपयोगकर्ता अनुभव को खराब होने से बचाने के लिए, कृपया 30 मार्च, 2022 से 12 महीने पहले के सभी प्लेस आईडी रीफ़्रेश करें.


google.load में Maps मॉड्यूल (13 अक्टूबर, 2020 से 13 अक्टूबर, 2021)

google.load के लिए "Maps" मॉड्यूल उपलब्ध कराने वाली सेवा को 13 अक्टूबर, 2020 से बंद कर दिया जाएगा. इसे 13 अक्टूबर, 2021 को बंद कर दिया जाएगा. "Maps" मॉड्यूल को google.load में लोड करने के बाद में किए गए अनुरोधों की वजह से गड़बड़ी हो जाएगी और कोई मैप लोड नहीं होगा. ज़्यादा जानकारी के लिए, माइग्रेशन गाइड देखें.


iOS के लिए SDK टूल GMSPlaceField अब NS_OPTIONS मैक्रो (वर्शन 4.0.0 तक) का इस्तेमाल करता है

iOS के लिए Places SDK टूल से शुरुआत की जा रही है v4.0.0 GMSPlaceField अब Swift के साथ बेहतर तरीके से काम करने के लिए, NS_ENUM के बजाय NS_OPTIONS मैक्रो का इस्तेमाल करता है. GMSPlaceField पर NS_OPTIONS के तौर पर माइग्रेट करने के बारे में ज़्यादा जानें.

GMSPlaceField को NS_ENUM के तौर पर इस्तेमाल करना जारी रखने के लिए, अपनी डिपेंडेंसी में v3.10.0 या इससे पहले के वर्शन की जानकारी दें.


iOS के तरीकों के लिए जगहें SDK टूल: setAutocompleteBoundsकाइस्तेमालनॉरईस्टकॉर्नर:SouthWestCorner, initWithBounds:filter (v3.10.0 - v4.0.0)

v3.10.0 के बाद से, setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner का हेल्पर तरीका अब काम नहीं करता है. यह v4.0.0 और इसके बाद के वर्शन में काम नहीं करता. इसके बजाय, locationBias या locationRestriction का इस्तेमाल करें.

v3.10.0 के बाद से, initWithBounds:filter वाला तरीका अब काम नहीं करता. v4.0.0 और इसके बाद के वर्शन में यह तरीका काम नहीं करता. इसके बजाय, GMSAutocompleteFetcher में initWithFilter: का इस्तेमाल करें.

काम नहीं करने वाले इन तरीकों के लिए, ज़्यादा से ज़्यादा v3.10.0 वर्शन काम करता है.

आइटम बदलने के तरीकों के बारे में जानने के लिए, अपेंडिक्स 1 देखें.


जगह ऑटोकंप्लीट में GMSCoordinateBounds (v3.9.0 - v4.0.0)

iOS ऑटोकंप्लीट सेवा के लिए Places SDK में GMSCoordinateBounds का इस्तेमाल करने वाले कई प्रॉपर्टी/पैरामीटर v3.9.0 के बाद अब काम नहीं करते हैं और v4.0.0 और इसके बाद के वर्शन में काम नहीं करते हैं. अब काम नहीं करने वाली प्रॉपर्टी/पैरामीटर के लिए, v3.10.0 वर्शन काम करता है.

GMSAutocompleteViewController में सीमाएं

ये GMSAutocompleteViewController प्रॉपर्टी अब काम नहीं करतीं:

इसके जैसे फ़ंक्शन के लिए, GMSAutocompleteViewController.autocompleteFilter का इस्तेमाल GMSAutocompleteFilter.locationBias या GMSAutocompleteFilter.locationRestriction के साथ करें. इन रिप्लेसमेंट प्रॉपर्टी के साथ, iOS के लिए Places SDK का कम से कम वर्शन 3.8.0 है.

findAutocompletePredictionsFromQuery और autocompleteQuery में सीमाएं

इसके जैसे फ़ंक्शन के लिए, GMSAutocompleteFilter.locationBias या GMSAutocompleteFilter.locationRestriction के साथ findAutocompletePredictionsFromQuery:filter:sessionToken:callback का इस्तेमाल करें. इन रिप्लेसमेंट प्रॉपर्टी के साथ, iOS के लिए Places SDK टूल का कम से कम वर्शन v3.8.0 है.

आइटम बदलने के तरीकों के बारे में जानने के लिए, अपेंडिक्स 1 देखें.


जगहों का फ़ील्ड GMSPlace.openNowStatus (v3.0.0 - v4.0.0)

iOS के लिए Places SDK में, Places फ़ील्ड/प्रॉपर्टी GMSPlace.openNowStatus को v3.0.0 से हटा दिया गया है. साथ ही, यह v4.0.0 और इसके बाद के वर्शन में काम नहीं करती है. अब काम नहीं करने वाले फ़ील्ड के लिए ज़्यादा से ज़्यादा v3.10.0 वर्शन है.

इसके बजाय, GMSPlace.isOpen या GMSPlace.isOpenAtDate फ़ंक्शन का इस्तेमाल करें. इन फ़ंक्शन के साथ, iOS के लिए Places SDK टूल का कम से कम वर्शन v3.3.0 है.


जगह का फ़ील्ड: permanently_closed (26 मई, 2020 से काम नहीं करता)

Places API और Places लाइब्रेरी में जगहें फ़ील्ड permanently_closed, Maps JavaScript API अब काम नहीं करता और इसका इस्तेमाल नहीं किया जाना चाहिए. इसके बजाय, कारोबारों के चालू होने की स्थिति जानने के लिए, business_status (जगहें एपीआई) या business_status (जगहों की लाइब्रेरी) का इस्तेमाल करें. जगहों की लाइब्रेरी, business_status के साथ Maps JavaScript API का कम से कम वर्शन v3.40 है.


जगह के फ़ील्ड open_now, utc_offset (20 नवंबर, 2019 से रोक दिए गए हैं)

Maps JavaScript API और जगहों की लाइब्रेरी में जगहें open_now और utc_offset के फ़ील्ड को 20 नवंबर, 2019 से बंद कर दिया गया है. इसका इस्तेमाल नहीं किया जाना चाहिए.

ये फ़ील्ड सिर्फ़ Places लाइब्रेरी और Maps JavaScript API में काम करते हैं.

  • जगह की जानकारी में, open_now फ़ील्ड को PlaceResult.opening_hours.isOpen() से बदल दिया गया है. आस-पास खोज और टेक्स्ट खोज के लिए, openNow:true अनुरोध पैरामीटर का इस्तेमाल करके, खुली हुई जगहों को फ़िल्टर करें. 'जगह ढूंढें' सुविधा के लिए, इसके बराबर की कोई जानकारी नहीं दी गई है. यह मान पाने के लिए, अब आपको जगह की जानकारी का अनुरोध करना होगा.
  • जगह की जानकारी में, utc_offset फ़ील्ड को PlaceResult.utc_offset_minutes से बदल दिया गया है.

ज़्यादा जानने के लिए, लोकेशन फ़ील्ड माइग्रेशन देखें.


Maps JavaScript API: google.maps.event.addDomListener() और google.maps.event.addDomListenerOnce() (7 अप्रैल, 2022 से काम नहीं करतीं)

Maps JavaScript API में, [google.maps.event.addDomListener()](/maps/documentation/javascript/reference/event#event.addDomListener) और [google.maps.event.addDomListenerOnce()](/maps/documentation/javascript/reference/event#event.addDomListenerOnce) फ़ंक्शन अब काम नहीं करते. इनका इस्तेमाल नहीं करना चाहिए. इसके बजाय, स्टैंडर्ड addEventListener() तरीके का इस्तेमाल करें.

ये तरीके काम करते रहेंगे. इन्हें बंद करने का कोई प्लान नहीं है.


हटाए गए प्रोग्राम की वजह से हटाए गए

इस सेक्शन में, वे सभी प्रॉडक्ट और सुविधाएं शामिल हैं जिन्हें बंद कर दिया गया है. ये प्रॉडक्ट और सुविधाएं अब उपलब्ध नहीं हैं.


लोकल कॉन्टेक्स्ट लाइब्रेरी, Maps JavaScript API (v3.51.2 से अब सेवा में नहीं है)

इस बीटा सुविधा का सीमित इस्तेमाल होने की वजह से, लोकल कॉन्टेक्स्ट लाइब्रेरी जनवरी 2024 में बंद कर दी गई थी.

अगर आपको लोकल कॉन्टेक्स्ट लाइब्रेरी जैसा अनुभव खुद बनाना है, तो हमारा सुझाव है कि आप Quick Builder में "पड़ोस डिस्कवरी" समाधान का इस्तेमाल करें. इसके अलावा, प्लेस लाइब्रेरी और Maps JavaScript API का इस्तेमाल भी किया जा सकता है. Places लाइब्रेरी के कोड सैंपल और कोडलैब आपकी मदद कर सकते हैं.


iOS v2.5 और इससे पहले के वर्शन के लिए Maps SDK टूल (जनवरी 2022 - जनवरी 2023)

iOS के लिए Maps SDK टूल के वर्शन 2.5 और इससे पहले के वर्शन को जनवरी 2023 में बंद कर दिया गया था. इस वजह से, iOS के लिए Maps SDK टूल के साथ काम करने वाले ओएस के कम से कम वर्शन को iOS 8 पर और आईडीई के साथ काम करने वाले कम से कम वर्शन को Xcode 8 पर सेट कर दिया गया था.

हम आपको iOS के लिए Maps SDK टूल के सबसे नए वर्शन की जानकारी देने और उसका इस्तेमाल करने के लिए प्रोत्साहित करते हैं.


Maps JavaScript API v2 (19 मई, 2010 से 26 मई, 2021)

Maps JavaScript API का दूसरा वर्शन 26 मई, 2021 से उपलब्ध नहीं है. इस वजह से, आपकी साइट के v2 मैप काम करना बंद कर देंगे और JavaScript की गड़बड़ियां दिखेंगी. अपनी साइट पर मैप का इस्तेमाल जारी रखने के लिए, Maps JavaScript API v3 पर माइग्रेट करें. अपने Maps JavaScript API ऐप्लिकेशन को v2 से v3 में अपग्रेड करने के बारे में ज़्यादा जानें.


जगहों के फ़ील्ड: reference, id, alt_id, scope (3 सितंबर, 2019 से 10 अगस्त, 2020)

जगहें फ़ील्ड id, alt_id, और scope 10 अगस्त, 2020 से उपलब्ध नहीं हैं. जगहें फ़ील्ड reference के इस्तेमाल पर रोक लगा दी गई है और इसका इस्तेमाल नहीं किया जाना चाहिए.

  • id रिस्पॉन्स फ़ील्ड को place_id रिस्पॉन्स फ़ील्ड से बदल दिया गया है.
  • reference रिस्पॉन्स फ़ील्ड को place_id रिस्पॉन्स से बदल दिया गया है. इसका इस्तेमाल नहीं किया जाना चाहिए.
  • alt_id और scope फ़ील्ड की कोई वैल्यू नहीं है, क्योंकि इनका इस्तेमाल सिर्फ़ उस जगह से जुड़ी सेवा के लिए किया गया था जिसे जुलाई 2018 में बंद कर दिया गया था.

ज़्यादा जानकारी के लिए, जगह के फ़ील्ड का माइग्रेशन देखें.


iOS वर्शन 10, iOS 5.0 के लिए Maps SDK टूल में ARMv7 32-बिट आर्किटेक्चर

iOS 10 और ARMv7 32-बिट आर्किटेक्चर के लिए Maps SDK टूल अब काम नहीं करता.

iOS के लिए Places SDK टूल

iOS 5.0 के लिए जगहें SDK टूल रिलीज़ होने के बाद, GMSCoordinateBounds को बंद कर दिया गया है और GMSPlacesViewportInfo से बदल दिया गया है.

फ़्यूज़न टेबल लेयर (प्रयोग के तौर पर) (3 दिसंबर, 2018 से 3 दिसंबर, 2019)

Maps JavaScript API में फ़्यूज़न टेबल लेयर 3 दिसंबर, 2019 को बंद कर दी गई थी और यह वर्शन 3.38 के बाद से उपलब्ध नहीं है. फ़्यूज़न टेबल के साथ काम करने वाला आखिरी वर्शन 3.37 है. ज़्यादा जानें.


Android और iOS के लिए स्थान SDK टूल (29 जनवरी, 2019 - 29 जुलाई, 2019)

29 जनवरी, 2019 से, Android और iOS के लिए अपग्रेड किए गए Places SDK टूल ने, Places SDK के मौजूदा वर्शन की जगह ले ली है. iOS के लिए Places SDK, Android के लिए Places SDK, और प्लेस पिकर के मौजूदा वर्शन 29 जनवरी, 2019 से बंद कर दिए गए थे और 29 जुलाई, 2019 को बंद कर दिए गए थे.


स्थान जोड़ना और स्थान हटाना (30 जून, 2017 - 30 जून, 2018)

30 जून, 2018 से, जगह की जानकारी जोड़ने और जगह मिटाने की सुविधा बंद कर दी गई है और अब उपलब्ध नहीं है.


Places API और Places लाइब्रेरी, Maps JavaScript API में ऐसी 'जगह की खोज' क्वेरी काम नहीं कर रही हैं (31 मार्च, 2022 - 31 मार्च, 2023)

Maps JavaScript API को 31 मार्च, 2022 से बंद कर दिया गया है. इसके बारे में 31 मार्च, 2023 से INVALID_REQUEST गड़बड़ी का जवाब मिलेगा.

जगहें एपीआई और जगहों की लाइब्रेरी, Maps JavaScript API, जगहों को ढूंढने के तीन तरीकों का इस्तेमाल करते हैं: टेक्स्ट सर्च, आस-पास की खोज, और जगह ढूंढें. हर तरीका, पैरामीटर के साथ काम करने वाले कॉम्बिनेशन वाले अनुरोधों को स्वीकार करता है. साथ ही, काम न करने वाले पैरामीटर के कॉम्बिनेशन वाले ज़्यादातर अनुरोधों को अस्वीकार कर देता है.

आज तक काम न करने वाले पैरामीटर के कुछ कॉम्बिनेशन को ठीक से अस्वीकार नहीं किया गया है:

  • ऐसे टेक्स्ट खोज अनुरोध जिनमें query पैरामीटर या तो खाली हो या जो मौजूद न हो. साथ ही, इन अनुरोधों में type पैरामीटर का इस्तेमाल न किया जा सकता हो.
  • query=* को टेक्स्ट खोजने के अनुरोध.
  • keyword=* की मदद से, आस-पास मौजूद खोज के अनुरोध.
  • name=* की मदद से, आस-पास मौजूद खोज के अनुरोध.
  • input=* की मदद से, जगह के अनुरोध खोजें.

जगह की जानकारी खोजने के ऐसे अनुरोध जो काम नहीं करते उन्हें इनमें से किसी एक से बदलना ज़रूरी है:

  • keyword (या name) पैरामीटर के बिना आस-पास खोज के अनुरोधों का इस्तेमाल, आस-पास के संस्थानों को ढूंढने के लिए किया जा सकता है. हमारा सुझाव है कि काम करने वाले किसी एक टाइप के साथ type पैरामीटर का भी इस्तेमाल करें (टेबल 1: जगह के टाइप देखें). यह खाली या मौजूद न होने वाले query पैरामीटर के साथ, टेक्स्ट खोज के अनुरोधों के मौजूदा व्यवहार के सबसे करीब होता है.

  • जियोकोडिंग एपीआई latlng पैरामीटर वाले अनुरोधों का इस्तेमाल, सबसे नज़दीकी पते ढूंढने के लिए किया जा सकता है. यह इनके मौजूदा व्यवहार से सबसे ज़्यादा मेल खाता है:

    • query=* को टेक्स्ट खोजने के अनुरोध.
    • keyword=* की मदद से, आस-पास मौजूद खोज के अनुरोध.
    • name=* की मदद से, आस-पास मौजूद खोज के अनुरोध.
    • input=* की मदद से, जगह के अनुरोध खोजें.

अपेंडिक्स 1: iOS के अब एपीआई को बदलने के लिए, Places SDK टूल से जुड़ी खास जानकारी

नीचे दी गई टेबल में, अब काम नहीं करने वाले हर तरीके या प्रॉपर्टी के लिए बदले जाने का तरीका दिखाया गया है.

अब काम नहीं करने वाला तरीका/प्रॉपर्टी इसके बजाय, इसका इस्तेमाल करें
setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner
(GMSAutocompleteViewController में)
locationRestriction और locationBias
setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner
(GMSAutocompleteResultsViewController में)
locationRestriction और locationBias
setAutocompleteBoundsUsingNorthEastCorner:SouthWestCorner
(GMSAutocompleteTableDataSource में)
locationRestriction और locationBias
initWithBounds:filter
(GMSAutocompleteFetcher में)
initWithFilter:
autocompleteBounds और autocompleteBoundsMode
(GMSAutocompleteViewController में)
locationBias या locationRestriction के साथ GMSAutocompleteViewController.autocompleteFilter.
findAutocompletePredictionsFromQuery:bounds:boundsMode:filter:SessionToken:callback, autocompleteQuery:bounds:filter:callback, और autocompleteQuery:bounds:boundsMode:filter:callback
(GMSPlacesClient में)
findAutocompletePredictionsFromQuery:filter:sessionToken:callback, locationBias या locationRestriction से.

iOS के लिए, Places SDK टूल का कम से कम वर्शन v3.8.0 है.