Google Tarafından Barındırılan Kitaplıklar, en popüler açık kaynaklı JavaScript kitaplıkları için kararlı, güvenilir, yüksek hızlı ve tüm dünyada kullanılabilen bir içerik dağıtım ağıdır.

Google, kitaplıktaki her çalışma için doğrudan kilit paydaşlarla çalışır ve yayınlanan en son sürümleri kabul eder.

Kütüphaneler

Barındırılan bir kitaplığı yüklemek için söz konusu kitaplığın (aşağıda gösterilmiştir) HTML snippet'ini kopyalayıp web sayfanıza yapıştırın. Örneğin, jQuery'yi yüklemek için web sayfanıza <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.7.1/jquery.min.js"></script> snippet'ini yerleştirin.

Kendi web siteniz yalnızca HTTP kullanıyor olsa bile, CDN'den kitaplıkları HTTPS üzerinden yüklemenizi öneririz. Günümüzde performans hızlı ve önbelleğe alma aynı şekilde çalışıyor. CDN dosyaları, CORS ve Timing-Allow başlıklarıyla yayınlanır ve 1 yıl boyunca önbelleğe alınmalarına izin verilir.

CesiumJS

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/cesiumjs/1.78/Build/Cesium/Cesium.js"></script>
site:
github.com/CesiumGS/cesium
sürümleri:
1,78

D3.js

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/d3js/7.9.0/d3.min.js"></script>
site:
d3js.org
versions:
7,9,0, 7,8,5, 7,8,4, 7,8,3, 7,8,4, 7,8,3, 7,8,2, 1, 7,8,1, 7,8,0, 7,7,0, 7,6,1, 7,4,2, 7,0,0
6,7,0, 6,6,2, 6,7,0,


Dojo

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/dojo/1.13.0/dojo/dojo.js"></script>
site:
dojoTool.org
sürümleri:

Ext Core

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/ext-core/3.1.0/ext-core.js"></script>
site:
sencha.com/products/extcore
sürümleri:
3.1.0, 3.0.0

Hammer.JS

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/hammerjs/2.0.8/hammer.min.js"></script>
site:
hammerjs.github.io
sürümleri:
2.0.8

Indefinite Observable

snippet:
<script type="module">
  import { IndefiniteObservable } from "https://ajax.googleapis.com/ajax/libs/indefinite-observable/2.0.1/indefinite-observable.bundle.js";
</script>
site:
https://github.com/material-motion/indefinite-observable-js
sürümleri:
2.0.1, 1.0.1

jQuery

3.x snippet:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.7.1/jquery.min.js"></script>
2.x snippet'i:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>
1.x snippet:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
site:
jquery.com
sürümler:
3.7.1, 3.7.0, 3.6.0, 1.2,1, 1,2,1, 1,2,1, 1,2,1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 3.6.3, 3.6.2, 3.6.1, 3.6.0, 3.4.1, 3.4.1, 3.4.1, 3.4.1
not:
3.3.0, 2.1.2, 1.2.5 ve 1.2.4, vahşi ortamda kısa ve istikrarsız yaşamları nedeniyle barındırılmamaktadır.

jQuery Mobile

snippet:
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jquerymobile/1.4.5/jquery.mobile.min.css">
<script src="https://ajax.googleapis.com/ajax/libs/jquerymobile/1.4.5/jquery.mobile.min.js"></script>
site:
jquerymobile.com
sürümleri:
1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0
Not:
Bu kitaplık jQuery'e bağlıdır. Bu modülü yüklemeden önce jQuery de yüklemeniz gerekir.

jQuery UI

snippet:
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.13.3/themes/smoothness/jquery-ui.css">
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.13.3/jquery-ui.min.js"></script>
site:
jqueryui.com
versions:
1.13.3, 1.13.2, 1.13.1, 1.13.2, 1.13.1, 1.13.0,
not:
Bu kitaplık jQuery'ye dayanır. Bu modülü yüklemeden önce jQuery'yi de yüklemeniz gerekir. Sürüm 1.8.3, kısa ömrü nedeniyle barındırılmamaktadır ve 1.8.3 takma adı aslında 1.8.4'ü yüklemektedir.

List.js

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/listjs/2.3.1/list.min.js"></script>
site:
listjs.com
sürümleri:
2.3.1

Material Motion

snippet:
<script type="module">
  import {
    Draggable,
    Point2DSpring,
    Tossable,
    combineStyleStreams,
    getPointerEventStreamsFromElement,
  } from "https://ajax.googleapis.com/ajax/libs/material-motion/0.1.0/material-motion.bundle.js";
</script>
site:
https://github.com/material-motion/material-motion-js
sürümleri:
0,1.0

Model-Viewer

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/model-viewer/3.0.0/model-viewer.min.js"></script>
site:
modelviewer.dev
sürümleri:
3.0.0, 2.1.1, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.12.0, 1.11.1, 1.10.0, 1.9.0, 1.8.0, 1.10.0, 1.9.0, 1.1.1.1.1.1.1.1.1.1.1.1.1.1,1

MooTools

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/mootools/1.6.0/mootools.min.js"></script>
site:
mootools.net
sürümleri:
1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.1.1.1.1.1.1.1.1.1. 1.1.1.1''''''' başarılı ve
Not:
1.5.1 ve önceki sürümlerde, küçültülmüş sürümün dosya adına mintools.min.js yerine mootools-yui-compress.js denir.

Myanmar Tools

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/myanmar-tools/1.2.1/zawgyi_detector.min.js"></script> <script src="https://ajax.googleapis.com/ajax/libs/myanmar-tools/1.2.1/zawgyi_converter.min.js"></script>
site:
https://github.com/google/myanmar-tools/
önerilen sürümler:
1.2.1
Tüm barındırılan sürümler:
1.0.1
1.1.0
1.1.1
1.1.3
1.2.0
1.2.1

Prototype

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/prototype/1.7.3.0/prototype.js"></script>
site:
prototypejs.org
sürümleri:
1.7.3.0, 1.7.2.0, 1.7.1.0, 1.7.0.0, 1.6.1.0, 1.6.0.3, 1.6.0.2

script.aculo.us

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js"></script>
site:
script.aculo.us
sürümleri:
1.9.0, 1.8.3, 1.8.2, 1.8.1
Not:
Bu kitaplık Prototype öğesine bağlıdır. Bu modülü yüklemeden önce Prototipi yüklemeniz gerekir.

Shaka Player

snippet:
<!-- for non-UI builds: -->
<script src="https://ajax.googleapis.com/ajax/libs/shaka-player/4.9.8/shaka-player.compiled.js"></script>

<!-- or, for UI builds: -->
<script src="https://ajax.googleapis.com/ajax/libs/shaka-player/4.9.8/shaka-player.ui.js"></script>
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/shaka-player/4.9.8/controls.css">
site:
https://github.com/google/shaka-player/
korunan sürümler:
4.9.8, 4.8.17, 4.7.15, 4.6.18, 4.5.0, 4.4.3, 4.3.16, 4.2.14
barındırılan tüm sürümler:
4.9.0 - 4.9.8, 4.8.0 - 2-3.0.3.0,2-3.0,2-3.0,2-3.0,2-3.0,2-3.0,2-3.0,2-3.0,2-3.4, 4.7.0 - 4.7.15, 4.6.0 - 4.6.18, 4.5.0 - 4.4.0 - 4.4.3, 4.3.0 - 4.3.0, -

SPF

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/spf/2.4.0/spf.js"></script>
site:
youtube.github.io/spfjs
sürümleri:
2.4.0, 2.3.2, 2.3.1, 2.3.0, 2.2.0, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0

SWFObject

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
site:
github.com/swfobject/swfobject
sürümleri:
2,2, 2,1

three.js

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/threejs/r84/three.min.js"></script>
site:
threejs.org
sürümleri:
r84, r83, r82, r81, r80, r79, r78, r77, r76, r75, r74, r73, r72, r71, r70, r69, r68, r67, r49

Web Font Loader

snippet>
<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js"></script>
site:
github.com/typekit/webfontloader
sürümleri:
1.6.26, 1.6.16, 1.5.18, 1.5.10, 1.5.6, 1.5.3, 1.5.2, 1.5.0

Sorun giderme

Eski bir sürüm mü görüyorsunuz? /jqueryui/1/... gibi "otomatik sürüm " bağlantılarını değil, tam sürümlere başvuruda bulunan URL'ler kullandığınızdan emin olun. Önbelleğe alma konusundaki endişeler ve hatta alt sürümler arasında bile uyumsuzluk olması nedeniyle, otomatik sürüm takma adlarını bir süre önce kullanımdan kaldırdık ve güncellemeyi durdurduk. Bu yüzden, (bunları kullanmaya devam eden mevcut siteleri kesintiye uğratmamak için) kalıcı olarak eski sürüme dönmeleri gerekecek.

Sorunlarla karşılaşırsanız: