Google Hosted Libraries es una red de distribución de contenido estable, confiable, de alta velocidad y disponible a nivel mundial para las bibliotecas de JavaScript más populares y de código abierto.

Google trabaja directamente con las partes interesadas clave para cada esfuerzo de la biblioteca y acepta las versiones más recientes a medida que se publican.

Bibliotecas

Para cargar una biblioteca alojada, copia y pega el fragmento HTML de esa biblioteca (que se muestra a continuación) en tu página web. Por ejemplo, para cargar jQuery, incorpora el fragmento <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.7.1/jquery.min.js"></script> en tu página web.

Te recomendamos que cargues bibliotecas desde la CDN a través de HTTPS, incluso si tu propio sitio web solo usa HTTP. En la actualidad, el rendimiento es rápido y el almacenamiento en caché funciona de la misma manera. Los archivos de la CDN se entregan con encabezados CORS y Timing-Allow, y se pueden almacenar en caché durante 1 año.

CesiumJS

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/cesiumjs/1.78/Build/Cesium/Cesium.js"></script>
site:
github.com/CesiumGS/cesium
versiones:
1.78

D3.js

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/d3js/7.9.0/d3.min.js"></script>
site:
d3js.org
versions:
7.9.0, 7.8.5, 7.8.4, 7.8.3, 7.8.2, 7.8.1, 7.8.0, 7.7.0, 7.6.1, 7.4.2, 7.0.0
6.7.5.6.5.6.6


Dojo

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/dojo/1.13.0/dojo/dojo.js"></script>
site:
dojotoolkit.org
versiones:
.

Ext Core

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/ext-core/3.1.0/ext-core.js"></script>
site:
sencha.com/products/extcore
versiones:
3.1.0, 3.0.0

Hammer.JS

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/hammerjs/2.0.8/hammer.min.js"></script>
site:
hammerjs.github.io
versiones:
2.0.8

Indefinite Observable

fragmento:
<script type="module">
  import { IndefiniteObservable } from "https://ajax.googleapis.com/ajax/libs/indefinite-observable/2.0.1/indefinite-observable.bundle.js";
</script>
site:
https://github.com/material-motion/indefinite-observable-js
versiones:
2.0.1, 1.0.1

jQuery

Fragmento 3.x:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.7.1/jquery.min.js"></script>
Fragmento 2.x:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>
Fragmento 1.x:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
site:
jquery.com
versiones:
3.7.1, 3.7.1, 3.6.4, 3.6.3, 3.6.2, 3.6.1, 3.6.0, 3.5.1, 3.5.0, 3.4.1, 3.4.0, 3.3.1, 3.2.1
nota:
No se alojan las versiones 3.3.0, 2.1.2, 1.2.5 ni 1.2.4 debido a sus vidas inestables y breves.

jQuery Mobile

fragmento:
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jquerymobile/1.4.5/jquery.mobile.min.css">
<script src="https://ajax.googleapis.com/ajax/libs/jquerymobile/1.4.5/jquery.mobile.min.js"></script>
site:
jquerymobile.com
versiones:
1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0
Nota:
Esta biblioteca depende de jQuery. También debes cargar jQuery antes de cargar este módulo.

jQuery UI

fragmento:
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.13.3/themes/smoothness/jquery-ui.css">
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.13.3/jquery-ui.min.js"></script>
site:
jqueryui.com
versions:
1.13.3, 1.13.2, 1.13.1, 1.13.0, 1.12.1, 1.12.0, 1.1.1.1.1.1.1.1.1.8.1.1.1.8.1.1.1.1.8.
nota:
Esta biblioteca depende de jQuery. También debes cargar jQuery antes de cargar este módulo. La versión 1.8.3 no se aloja debido a su corta vida, y el alias 1.8.3 en realidad carga 1.8.4.

List.js

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/listjs/2.3.1/listjs.min.js"></script>
site:
listjs.com
versiones:
2.3.1

Material Motion

fragmento:
<script type="module">
  import {
    Draggable,
    Point2DSpring,
    Tossable,
    combineStyleStreams,
    getPointerEventStreamsFromElement,
  } from "https://ajax.googleapis.com/ajax/libs/material-motion/0.1.0/material-motion.bundle.js";
</script>
site:
https://github.com/material-motion/material-motion-js
versiones:
0.1.0

Model-Viewer

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/model-viewer/3.0.0/model-viewer.min.js"></script>
site:
modelviewer.dev
versiones:
3.0.0, 2.1.1, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.12.0, 1.11.1, 1.10.0, 1.9.0, 1.8.0, 1.7.2, 1.1.1, 1.1.1, 1.0.1.1.

MooTools

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/mootools/1.6.0/mootools.min.js"></script>
site:
mootools.net
versiones:
1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.1, 1.2.1.
Nota:
Para las versiones 1.5.1 y anteriores, el nombre de archivo de la versión reducida se llama mootools-yui-compressed.js en lugar de mintools.min.js.

Myanmar Tools

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/myanmar-tools/1.2.1/zawgyi_detector.min.js"></script> <script src="https://ajax.googleapis.com/ajax/libs/myanmar-tools/1.2.1/zawgyi_converter.min.js"></script>
site:
https://github.com/google/myanmar-tools/
versiones recomendadas:
1.2.1
todas las versiones alojadas:
1.0.1
1.1.0
1.1.1
1.1.3
1.2.0
1.2.1

Prototype

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/prototype/1.7.3.0/prototype.js"></script>
site:
prototypejs.org
versiones:
1.7.3.0, 1.7.2.0, 1.7.1.0, 1.7.0.0, 1.6.1.0, 1.6.0.3, 1.6.0.2

script.aculo.us

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js"></script>
site:
script.aculo.us
versiones:
1.9.0, 1.8.3, 1.8.2, 1.8.1
Nota:
Esta biblioteca depende de Prototype. Antes de cargar este módulo, debes cargar el prototipo.

Shaka Player

fragmento:
<!-- for non-UI builds: -->
<script src="https://ajax.googleapis.com/ajax/libs/shaka-player/4.9.8/shaka-player.compiled.js"></script>

<!-- or, for UI builds: -->
<script src="https://ajax.googleapis.com/ajax/libs/shaka-player/4.9.8/shaka-player.ui.js"></script>
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/shaka-player/4.9.8/controls.css">
site:
https://github.com/google/shaka-player/
versiones mantenidas:
4.9.8, 4.8.17, 4.7.15, 4.6.18, 4.5.0, 4.4.3, 4.3.16 y 4.2.14
en todas las versiones alojadas:
4.9.0 - 4.9.8, 4.8.0 - 4.8.17, 4.7.0 - 4.7.15, 4.6.0 - 4.6.18, 4.5.0, 4.4.0 - 4.4.3.

SPF

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/spf/2.4.0/spf.js"></script>
site:
youtube.github.io/spfjs
versiones:
2.4.0, 2.3.2, 2.3.1, 2.3.0, 2.2.0, 2.1.2, 2.1.1, 2.1.0, 2.0.1 y 2.0.0

SWFObject

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
site:
github.com/swfobject/swfobject
versiones:
2.2, 2.1

three.js

fragmento:
<script src="https://ajax.googleapis.com/ajax/libs/threejs/r84/three.min.js"></script>
site:
threejs.org
versiones:
r84, r83, r82, r81, r80, r79, r78, r77, r76, r75, r74, r73, r72, r71, r70, r69.

Web Font Loader

Fragmento gt;
<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js"></script>
site:
github.com/typekit/webfontloader
versiones:
1.6.26, 1.6.16, 1.5.18, 1.5.10, 1.5.6, 1.5.3, 1.5.2, 1.5.0

Solución de problemas

¿Ves una versión desactualizada? Asegúrate de no utilizar los vínculos de "versión automática", como /jqueryui/1/..., sino que usa URLs que hagan referencia a versiones exactas. Debido a las inquietudes sobre el almacenamiento en caché y la falta de compatibilidad entre versiones incluso menores, dimos de baja y hace algún tiempo dejamos de actualizar los alias de la versión automática, de modo que siempre se referirán a una versión anterior (para no dañar los sitios existentes que aún los usan).

Si tienes problemas, haz lo siguiente: