The Google Plugin for Eclipse is deprecated and will be removed in January 2018. Migrate to Cloud Tools for Eclipse and/or the GWT Eclipse Plugin as soon as possible to avoid disruption.

Changing the JDK Compliance Level

You can change the compiler compliance level by going to the Java Compiler page as shown in the steps below.

  1. In the Project Explorer view, right-click on the project and then select Properties.
  2. Select the Java Compiler page in the Properties window.
  3. In the JDK Compliance section, select the desired Compiler compliance level.
  4. Click Apply and then Ok.




If your project is a facet-enabled project, you will also need to set the Java version in the Project Facets page by doing the following.

  1. In the Project Explorer view, right-click on the project and then select Properties.
  2. Select the Project Facets page in the Properties window. This page lists the facets in the project and their versions.
  3. Select the desired version number for the Java facet.
  4. Click Apply and then Ok.




Send feedback about...

Google Plugin for Eclipse