Google Plugin for Eclipse 4.4 (Luna) Installation Instructions

This procedure installs the Google Plugin for Eclipse, the GWT SDK, and the Google App Engine SDK. If you are not running Eclipse version 4.4 (Luna), please consult Downloading and Installing the Plugin for the correct plugin version to use.

  1. Start Eclipse, running JVM version 1.7.0 or later.
  2. Select Help > Install New Software... In the dialog that appears, enter the update site URL into the Work with text box:

    https://dl.google.com/eclipse/plugin/4.4

    And press the enter key.

  3. The required component is Google Plugin for Eclipse. Select the checkbox next to Google Plugin for Eclipse 4.4/4.5/4.6.
    • If you want to install the Google App Engine Java SDK, select the checkbox next to Google App Engine Engine Java SDK.
    • If you want to install the Maven Integration for Google App Engine, select the checkbox next to Google App Engine Maven Integration.

    Note: If you are installing the plugin on a multi-user install of Eclipse, please see this FAQ entry.

    Installing the SDKs is optional; you can always install them later on.

    If you are having trouble installing from the update site, please see this FAQ entry.

  4. Click Next.
  5. Review the features that you are about to install. Click Next.
  6. Read the license agreements and then select I accept the terms of the license agreements. Click Finish.

  7. Click OK on the Security Warning.

    If this concerns you, consider upgrading to Eclipse 4.5 or later and using the newer Cloud Tools for Eclipse which is fully signed instead.

  8. You will then be asked if you would like to restart Eclipse. Click Restart Now.

  9. Now you are ready to build App Engine web applications. If you encountered issues during the installation, please see the FAQ.

Send feedback about...

Google Plugin for Eclipse