Downloading and Installing the Plugin

App Engine does not yet support Java 8. You can build with version 8 of the JDK locally if and only if you set the Compiler compliance level for your project to Java 1.7. You cannot deploy an application that requires Java 8 to App Engine.

You can install the Google Plugin for Eclipse using the software update feature of Eclipse. Be sure to use the plugin that corresponds to your version of Eclipse. Follow the installation instructions provided at the links below or, if you are familiar with installing Eclipse plugins, you can simply paste the appropriate plugin link directly into Eclipse.

Eclipse version Installation instructions Direct plugin link
Eclipse 4.5 (Mars) Plugin for Eclipse 4.5 (Mars) https://dl.google.com/eclipse/plugin/4.5
Eclipse 4.4 (Luna) Plugin for Eclipse 4.4 (Luna) https://dl.google.com/eclipse/plugin/4.4

If you are looking for older versions of the plugin, click here.

If you are having trouble installing from the update sites (due to firewall issues, for instance), you can install the Google Plugin for Eclipse by downloading and installing an archive of the update site.

Send feedback about...

Google Plugin for Eclipse