enum ExchangeRateError.Reason (v201808)

The reasons for the target error.


Namespace
https://www.google.com/apis/ads/publisher/v201808
Enumeration Description
INVALID_CURRENCY_CODE The currency code is invalid and does not follow ISO 4217.
UNSUPPORTED_CURRENCY_CODE The currency code is not supported.
CURRENCY_CODE_ALREADY_EXISTS The currency code already exists. When creating an exchange rate, its currency should not be associated with any existing exchange rate. When creating a list of exchange rates, there should not be two exchange rates associated with same currency.
INVALID_EXCHANGE_RATE The exchange rate value is invalid. When the ExchangeRate.refreshRate is ExchangeRateRefreshRate.FIXED, the ExchangeRate.exchangeRate should be larger than 0. Otherwise it is invalid.
EXCHANGE_RATE_NOT_FOUND The exchange rate value is not found. When the ExchangeRate.refreshRate is ExchangeRateRefreshRate.DAILY or ExchangeRateRefreshRate.MONTHLY, the ExchangeRate.exchangeRate should be assigned by Google. It is not found if Google cannot find such an exchange rate.
CANNOT_DELETE_EXCHANGE_RATE_WITH_ACTIVE_RATE_CARDS The exchange rate cannot be deleted as it is still being used by active rate cards.
UNKNOWN The value returned if the actual value is not exposed by the requested API version.

Send feedback about...

Ad Manager API
Ad Manager API
Need help? Visit our support page.