בקטע הזה מוסבר איך לוודא שהמערכת עומדת בדרישות המינימום, איך להגדיר את קבוצת Workspace ואיך לקבל את Driver SDK.
לפני שמתחילים
כדי להשתמש ב-Driver SDK ל-iOS, האפליקציה שלכם צריכה לעמוד בקריטריונים הבאים:
- יש לכם את Navigation SDK.
- מפעילים את SDK של מפות ל-iOS במסוף Google Cloud ומקבלים מפתח API.
בדיקת דרישות המערכת המינימליות
כדאי לעיין בהערות לגבי הגרסה כדי לראות מהן הדרישות המינימליות של גרסת Driver SDK שבה אתם משתמשים. הערות מוצר
- במכשיר הנייד צריכה לפעול מערכת iOS בגרסה 16 ואילך.
- Xcode של Apple בגרסה 26 ואילך.
קבלת גישה ל-Google Workspace
אם אתם לקוחות Google Workspace, אתם צריכים לבצע את השלבים הבאים:
יוצרים קבוצה ב-Workspace. מידע נוסף זמין במאמר קבוצה ב-Workspace.
לדוגמה, מומלץ לתת לקבוצה שם כמו
google-maps-platform-sdk-users@workspacedomain.comבמהלך ההצטרפות.צריך לציין את השם כדי ש-Google תוסיף את קבוצת Workspace לרשימת ההיתרים שמעניקה גישה למאגרי CocoaPods הנכונים.
מוודאים שכתובות האימייל של המשתמשים ושל חשבון השירות שזקוקים לגישה מופיעות ברשימה הזו.
אם הארגון שלכם לא יכול ליצור קבוצות ב-Workspace, אתם יכולים לשלוח ל-Google רשימה של כתובות אימייל של משתמשים וחשבונות שירות שצריכים גישה לארטיפקטים האלה.
כניסה באמצעות Cloud SDK
לפיתוח מקומי, נכנסים באמצעות Cloud SDK. פרטים נוספים זמינים במאמר התקנת ה-CLI של gcloud.
בדוגמאות הבאות אפשר לראות איך נכנסים באמצעות Cloud SDK.
gcloud
gcloud auth login
אתם צריכים להשתמש בכתובת אימייל שמשויכת לקבוצת Workspace.
הגדרת המארחים של האוטומציה
כדי להגדיר את המארחים של האוטומציה במערכות בנייה או בשילוב מתמשך, צריך להשתמש ברשימת השיטות שצוינו לשימוש בחשבון שירות כדי לבצע אימות מול ממשקי ה-API והשירותים של Google. לפרטים, ראו את הקטע על חשבונות שירות בדף שיטות אימות ב-Google.
אם התהליך פועל בסביבת Google Cloud, צריך להשתמש בזיהוי אוטומטי של פרטי הכניסה. מידע נוסף זמין במאמר בנושא זיהוי אוטומטי של פרטי כניסה.
אחרת, מאחסנים את קובץ המפתח של חשבון השירות במיקום מאובטח במערכת הקבצים של המארח ומגדירים את משתנה הסביבה GOOGLE_APPLICATION_CREDENTIALS בהתאם. מידע נוסף זמין במאמר בנושא GOOGLE_APPLICATION_CREDENTIALS.
כתובת האימייל בחשבון השירות שמשויכת לפרטי הכניסה צריכה להיות חברה בקבוצת Workspace.
קבלת Driver SDK
מתקינים ומגדירים את Driver SDK.
CocoaPods
מתקינים את הכלי CocoaPods: פותחים חלון טרמינל ומריצים את הפקודה הבאה.
sudo gem install cocoapodsפרטים נוספים זמינים במדריך למתחילים לשימוש ב-CocoaPods.
יוצרים Podfile ל-Driver SDK: משתמשים ב-Podfile כדי להתקין את ה-API ואת יחסי התלות שלו.
יוצרים קובץ בשם
Podfileבספריית הפרויקט. הקובץ הזה מגדיר את יחסי התלות של הפרויקט.עורכים את ה-Podfile ומוסיפים את התלויות. דוגמה שכוללת את יחסי התלות:
source "https://github.com/CocoaPods/Specs.git" target 'YOUR_APPLICATION_TARGET_NAME_HERE' do pod 'GoogleRidesharingDriver' endהנה דוגמה שכוללת את ה-pods של אלפא ובטא עבור Driver SDK כתלות:
source "https://cpdc-eap.googlesource.com/ridesharing-driver-sdk.git" source "https://github.com/CocoaPods/Specs.git" target 'YOUR_APPLICATION_TARGET_NAME_HERE' do pod 'GoogleRidesharingDriver' endשומרים את ה-Podfile: פותחים חלון Terminal ועוברים לתיקייה עם ה-Podfile:
cd <path-to-project>
מריצים את הפקודה pod install: הפקודה הזו תתקין את ממשקי ה-API שצוינו ב-Podfile, יחד עם כל התלויות שלהם.
pod installפותחים את הפרויקט ב-Xcode: סוגרים את Xcode, ואז פותחים (בלחיצה כפולה) את קובץ ה- .xcworkspace של הפרויקט כדי להפעיל את Xcode. כדי לפתוח את הפרויקט מאוחר יותר, צריך להשתמש בקובץ .xcworkspace.
Swift Package Manager
אפשר להתקין את Driver SDK באמצעות Swift Package Manager. כדי להוסיף את ה-SDK, צריך לוודא שהסרתם את כל יחסי התלות הקיימים ב-Driver SDK.
כדי להוסיף את ה-SDK לפרויקט חדש או קיים, פועלים לפי השלבים הבאים:
-
פותחים את Xcode
projectאוworkspace, ואז עוברים אל File > Add Package Dependencies (קובץ > הוספת תלות בחבילה). - מזינים את כתובת ה-URL https://github.com/googlemaps/ios-driver-sdk, מקישים על Enter כדי למשוך את החבילה, ולוחצים על 'הוספת חבילה'.
-
כדי להתקין
versionספציפי, מגדירים את השדה Dependency Rule (כלל תלות) לאחת מהאפשרויות שמבוססות על גרסה. בפרויקטים חדשים, מומלץ לציין את הגרסה העדכנית ולהשתמש באפשרות Exact Version (גרסה מדויקת). בסיום, לוחצים על 'הוספת חבילה'. -
בחלון Choose Package Products (בחירת מוצרים לחבילה), מוודאים שהמוצר
GoogleRidesharingDriverיתווסף ליעדmainשצוין. בסיום, לוחצים על 'הוספת חבילה'. - כדי לאמת את ההתקנה, עוברים לחלונית כללי של היעד. בקטע Frameworks, Libraries, and Embedded Content (מסגרות, ספריות ותוכן מוטמע) אמורים להופיע החבילות המותקנות. אפשר גם לעיין בקטע Package Dependencies (תלות בחבילה) ב-Project Navigator (סייר הפרויקטים) כדי לאמת את החבילה ואת הגרסה שלה.
כדי לעדכן את package בפרויקט קיים, פועלים לפי השלבים הבאים:
- ב-Xcode, עוברים אל File > Packages > Update To Latest Package Versions (קובץ > חבילות > עדכון לגרסאות החבילה העדכניות ביותר).
- כדי לאמת את ההתקנה, עוברים לקטע Package Dependencies (תלות בחבילה) ב-Project Navigator (סרגל הניווט של הפרויקט) כדי לאמת את החבילה ואת הגרסה שלה.
כדי להסיר את Driver SDK הקיים שהותקן באופן ידני, פועלים לפי השלבים הבאים:
בהגדרות התצורה של פרויקט Xcode, מחפשים את Frameworks, Libraries, and Embedded Content (מסגרות, ספריות ותוכן מוטמע). כדי להסיר את המסגרת הבאה, משתמשים בסימן המינוס
(-):GoogleRidesharingDriver.xcframework
בספרייה ברמה העליונה של פרויקט Xcode, מסירים את חבילת
GoogleRidesharingDriver.
התקנה ידנית
במדריך הזה מוסבר איך להוסיף באופן ידני את ה-XCFramework שמכיל את Driver SDK לפרויקט, ואיך להגדיר את הגדרות ה-build ב-Xcode.
לפני שממשיכים במדריך הזה, צריך:
מורידים את XCFramework, חבילה בינארית שמשמשת להתקנת Driver SDK. אפשר להשתמש בחבילה הזו בכמה פלטפורמות, כולל במחשבים עם Apple silicon
מתקינים את Navigation SDK.
כדי להתקין את Driver SDK באופן ידני:
מורידים את הקובץ הבינארי ואת המשאבים של ה-SDK:
מחלצים את הקבצים הדחוסים כדי לגשת ל-XCFramework ולמשאבים.
מפעילים את Xcode ופותחים פרויקט קיים או יוצרים פרויקט חדש. אם אתם חדשים ב-iOS, אתם צריכים ליצור פרויקט חדש ולבחור בתבנית iOS App.
אם קבוצת הפרויקטים לא מכילה קבוצת Frameworks, צריך ליצור אותה.
כדי להתקין את Driver SDK, גוררים את הקובץ
GoogleRidesharingDriver.xcframeworkלפרויקט בקטע Frameworks, Libraries, and Embedded Content. אם מתבקשים, בוחרים באפשרות העתקת פריטים.גוררים את הקובץ
GoogleRidesharingDriver.bundleשהורדתם אל ספריית הרמה העליונה של פרויקט Xcode. אם מופיעה בקשה, בוחרים באפשרות העתקת פריטים.בוחרים את הפרויקט בחלונית הניווט בפרויקט, ואז בוחרים את היעד של האפליקציה.
פותחים את הכרטיסייה Build Phases (שלבי בנייה), ובקטע Link Binary with Libraries (קישור קובץ בינארי לספריות), מוסיפים את המסגרות והספריות הבאות אם הן עדיין לא מופיעות:
Accelerate.frameworkAudioToolbox.frameworkAVFoundation.frameworkCoreData.frameworkCoreGraphics.frameworkCoreLocation.frameworkCoreTelephony.frameworkCoreText.frameworkGLKit.frameworkImageIO.frameworklibc++.tbdlibxml2.tbdlibz.tbdLocalAuthentication.frameworkOpenGLES.frameworkQuartzCore.frameworkSystemConfiguration.frameworkUIKit.frameworkWebKit.framework
בוחרים את הפרויקט ולא יעד ספציפי, ופותחים את הכרטיסייה Build Settings. בקטע Other Linker Flags (דגלים אחרים של כלי הקישור), מוסיפים את הערך
-ObjCגם לניפוי באגים וגם לגרסת ההפצה.אם ההגדרות האלה לא מוצגות, צריך לשנות את המסנן בסרגל Build Settings מ-Basic ל-All.
בדיקת קובץ מניפסט הפרטיות של אפל
Apple דורשת פרטי פרטיות של אפליקציות ב-App Store. אפשר לעבור אל הדף של Apple App Store בנושא פרטיות באפליקציות כדי לקבל עדכונים ומידע נוסף.
קובץ המניפסט של הפרטיות של אפל נכלל בחבילת המשאבים של ה-SDK. כדי לוודא שקובץ הצהרת הפרטיות נכלל ולבדוק את התוכן שלו, יוצרים ארכיון של האפליקציה ומפיקים דוח פרטיות מהארכיון.
המאמרים הבאים
הגדרת פרויקט במסוף Google Cloud