排解註冊問題

如果您在註冊或設定連結的應用程式時遇到問題,請參閱下表,瞭解常見的錯誤訊息、原因和疑難排解步驟。

問題 錯誤訊息 原因 修正/疑難排解步驟

未指定的「擷取工具」失敗

「無法擷取 MCP 伺服器詳細資料,請再試一次。」(或「擷取工具」按鈕失敗,且未顯示特定錯誤訊息)。

網址無效、伺服器離線或網路錯誤,導致 Google Connected Console 無法完成對 MCP 端點的要求。

請確認下列事項:

  • 請仔細檢查 MCP 端點網址是否正確,且使用 https://。
  • 確認 MCP 伺服器正在運作。
  • 確認 MCP 伺服器可透過公開網際網路存取 (Google 無法連線至 localhost 或私人內部網路位址)。

無法連上 MCP 伺服器

「無法連上 MCP 伺服器」

Google 後端無法連線至 MCP 端點。

常見原因和修正方法包括:

  • 防火牆限制:確認防火牆或 WAF 未封鎖 Google 的傳出 IP 範圍。
  • API Gateway 規則:確認 API Gateway 接受 POST 要求,且不會在 MCP initialize 握手期間拒絕 Google 的 clientInfo。
  • 子網域不符:如果使用專屬子網域 (例如 gemini.mcp.company.com),請確認其 /.well-known/oauth-protected-resource 中繼資料與該子網域相符,而非指向不同的基本網域 (mcp.company.com)。

不支援的 MCP 傳輸 (HTTP 405)

「MCP 伺服器拒絕要求 (HTTP 405 方法不允許)。請確認網址指向可接受 POST 要求的 Streamable HTTP 端點,而非舊版 SSE 端點。

端點網址指向舊版 HTTP+SSE 端點,該端點僅接受 GET 要求,或拒絕 JSON-RPC POST 要求。

更新 MCP 伺服器和端點網址,改用 MCP Streamable HTTP 傳輸,接受 initialize 和 tools/list 的 POST 要求。

缺少 OAuth 受保護資源檔案

「MCP 伺服器上沒有 /.well-known/oauth-protected-resource 檔案」

Google 嘗試探索 OAuth 2.0 受保護資源中繼資料 (RFC 9728),但失敗。

  • 如果 MCP 伺服器不需要驗證:這項錯誤通常是因為 MCP 端點網址有錯字或缺少路徑區段 (例如 https://mcp.example.com,而非 https://mcp.example.com/mcp),並傳回 HTTP 404 或 500,導致用戶端改用 OAuth 探索。確認確切的 MCP 端點路徑會針對未經驗證的 POST initialize 和 tools/list 要求傳回 HTTP 200 OK,然後在「存取憑證」的「您的伺服器是否需要授權?」下方選取「否」。
  • 如果 MCP 伺服器需要驗證:請在 MCP 伺服器上託管有效的 /.well-known/oauth-protected-resource JSON 檔案,並在 authorization_servers 陣列中宣告信任的授權伺服器。

缺少 OAuth 授權伺服器中繼資料,或中繼資料無效

「OAuth 伺服器上沒有 /.well-known/oauth-authorization-server 檔案」或「含有無效或不完整的 JSON」

OAuth 伺服器未在 /.well-known/oauth-authorization-server 公開有效的 RFC 8414 中繼資料文件。

  • 在 /.well-known/oauth-authorization-server (或 /.well-known/openid-configuration) 代管有效的 RFC 8414 導覽文件,其中包含 authorization_endpoint 和 token_endpoint。
  • 或者,您也可以在「憑證」部分,手動輸入「自訂授權端點」和「自訂權杖端點」網址。

網域驗證失敗

網域憑證顯示「驗證失敗」或「驗證失敗」,並顯示工具提示訊息 (例如 HTTP 404、不允許重新導向或權杖不符)。

Google 無法驗證您在 https://<domain>/.well-known/google-connected-apps 的驗證權杖。

  • 找不到檔案 (HTTP 404):請確認下載的 google-connected-apps.json 內容已發布至 https://<domain>/.well-known/google-connected-apps (網址路徑中沒有 .json 副檔名)。
  • 不允許重新導向:請直接透過 HTTP 200 OK 提供驗證酬載,不要將 /.well-known/google-connected-apps 重新導向至其他網址。
  • 權杖不符:確認 JSON 回應包含 "verification_tokens": ["<YOUR_TOKEN>"],且權杖與開發人員帳戶產生的權杖完全相同。

Dynamic Client Registration (DCR) 或 CIMD 失敗

「Dynamic Client Registration (RFC 7591) 失敗」、「OAuth 伺服器不支援 Dynamic Client Registration (RFC 7591)」或「用戶端 ID 中繼資料文件 (CIMD) 註冊失敗」

自動註冊 OAuth 用戶端失敗,或 OAuth 供應商不支援這項功能,或 Google 的重新導向 URI 遭拒。

  • 確認 OAuth 伺服器已將「伺服器驗證憑證」下方顯示的所有六個應用程式專屬 Google 重新導向 URI (https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain> 等) 加入許可清單。請注意,許多 OAuth 2.1 伺服器會拒絕萬用字元 (*) 重新導向 URI。
  • 如果 OAuth 供應商不支援 CIMD 或 RFC 7591 DCR,請在「存取憑證」中選取「預先註冊」(適用於使用者委派的 OAuth) 或「機器對機器 (OAuth 用戶端憑證)」,並提供靜態「用戶端 ID」和「用戶端密鑰」。

OAuth 登入彈出式視窗遭封鎖或空白

「驗證彈出式視窗遭到瀏覽器封鎖」,或 OAuth 登入視窗在工具同步或測試期間無法正常顯示。

瀏覽器的彈出式視窗攔截器,或登入頁面上的嚴格 X-Frame-Options/Content-Security-Policy 標頭,導致彈出式視窗流程無法運作。

  • 請在瀏覽器中允許控制台的彈出式視窗,然後再試一次。
  • 在「使用開發人員憑證完成驗證」下方的「存取憑證」中,將「透過彈出式視窗驗證」切換為「透過重新導向驗證 (備用)」,驗證流程就會在同一個分頁中以全螢幕模式開啟。

缺少 MCP 伺服器指令

警告訊息:「您的 MCP 伺服器沒有指令。建議在伺服器結構定義中新增指示。

MCP 伺服器未在 initialize 回應中傳回 instructions 欄位。

  • 初始化 MCP 伺服器時,請明確定義系統指示 (伺服器定義中的 instructions 參數)。
  • 如果是無狀態或自訂 HTTP 實作,請確認 initialize 方法的 JSON-RPC 回應酬載中包含 instructions 欄位,然後選取「重新同步工具」。

UI 資源大小限制或不支援的 MIME 類型

擷取問題錯誤資訊卡:「資源累計大小不得超過 100 MB」或「資源『<uri>』的 MIME 類型『<type>』不受支援」。

MCP 伺服器傳回的 UI 資源總大小超出上限,或使用了不支援的 MIME 類型。

  • 請縮減伺服器傳回的所有資訊清單 UI 資源累計大小,確保不超過上限。
  • 確認所有 UI 資源都使用支援的 MIME 類型:text/html、text/html;profile=mcp-app、text/javascript 或 text/css。

圖示上傳卡住或「發生未預期的錯誤」

在「應用程式詳細資料」中上傳應用程式圖示時,上傳作業卡在載入狀態,或顯示「發生未預期的錯誤。請再試一次」(通常會顯示代碼 4E696748)。

這通常是由過時的瀏覽器工作階段、衝突的瀏覽器擴充功能,或快取的驗證狀態所引起。

請依序嘗試下列步驟:

  1. 使用全新的瀏覽器設定檔:使用全新的瀏覽器設定檔開啟新視窗。
  2. 使用無痕/私密模式:在私密瀏覽視窗中登入 Google Connected Console,然後上傳圖示。
  3. 清除快取:清除瀏覽器的快取和 Cookie 後再試一次,並確認圖示是有效的 512 px × 512 px PNG 或 JPEG 檔案,且大小不超過 1 MB。