| Problem |
Fehlermeldung |
Ursache |
Schritte zur Fehlerbehebung |
Nicht näher bezeichneter Fehler bei „Abruftools“ |
„MCP-Serverdetails konnten nicht abgerufen werden. Bitte versuche es noch einmal.“ (oder die Schaltfläche Tools abrufen schlägt ohne eine bestimmte Fehlermeldung fehl). |
Die Connected Console konnte die Anfrage an Ihren MCP-Endpunkt aufgrund einer ungültigen URL, eines Offline-Servers oder eines Netzwerkfehlers nicht abschließen. |
Prüfen Sie Folgendes:
- Prüfen Sie, ob die URL für den MCP-Endpunkt korrekt ist und
https:// verwendet.
- Prüfe, ob dein MCP-Server ausgeführt wird.
- Prüfen Sie, ob Ihr MCP-Server über das öffentliche Internet erreichbar ist. Google kann nicht auf
localhost oder private Intranetadressen zugreifen.
|
MCP-Server ist nicht erreichbar |
„Der MCP-Server ist nicht erreichbar“ |
Das Backend von Google konnte keine Verbindung zu Ihrem MCP-Endpunkt herstellen. |
Häufige Ursachen und Lösungen:
- Firewall-Einschränkungen: Achten Sie darauf, dass Ihre Firewall oder WAF die ausgehenden IP-Bereiche von Google nicht blockiert.
- API-Gateway-Regeln: Prüfen Sie, ob Ihr API-Gateway
POST-Anfragen akzeptiert und die clientInfo-Anfragen von Google während des MCP-initialize-Handshakes nicht ablehnt.
- Subdomain-Abweichung: Wenn Sie eine dedizierte Subdomain (z. B.
gemini.mcp.company.com) verwenden, müssen die /.well-known/oauth-protected-resource-Metadaten mit dieser Subdomain übereinstimmen und dürfen nicht auf eine andere Basisdomain (mcp.company.com) verweisen.
|
Nicht unterstützter MCP-Transport (HTTP 405) |
„Der MCP-Server hat die Anfrage abgelehnt (HTTP 405 Method Not Allowed). Achte darauf, dass die URL auf einen streambaren HTTP-Endpunkt verweist, der POST-Anfragen akzeptiert, und nicht auf einen veralteten SSE-Endpunkt. |
Die Endpunkt-URL verweist auf einen veralteten HTTP+SSE-Endpunkt, der nur GET-Anfragen akzeptiert oder JSON-RPC-POST-Anfragen ablehnt. |
Aktualisieren Sie Ihren MCP-Server und die Endpunkt-URL, um den streamfähigen HTTP-Transport von MCP zu verwenden, der POST-Anfragen für initialize und tools/list akzeptiert.
|
Fehlende OAuth-Datei für geschützte Ressourcen |
„Die Datei /.well-known/oauth-protected-resource ist auf dem MCP-Server nicht vorhanden“ |
Google hat versucht, die Metadaten der OAuth 2.0-geschützten Ressource (RFC 9728) zu ermitteln, was jedoch fehlgeschlagen ist. |
- Wenn Ihr MCP-Server KEINE Authentifizierung erfordert: Dieser Fehler tritt in der Regel auf, wenn die URL des MCP-Endpunkts einen Tippfehler oder ein fehlendes Pfadsegment enthält (z. B.
https://mcp.example.com statt https://mcp.example.com/mcp) und HTTP 404 oder 500 zurückgibt, was dazu führt, dass der Client auf die OAuth-Erkennung zurückgreift. Prüfe, ob der genaue MCP-Endpunktpfad HTTP 200 OK für nicht authentifizierte POST-Anfragen vom Typ initialize und tools/list zurückgibt, und wähle unter Zugangsdaten bei Erfordert dein Server eine Autorisierung? die Option Nein aus.
- Wenn Ihr MCP-Server eine Authentifizierung erfordert: Hosten Sie eine gültige
/.well-known/oauth-protected-resource-JSON-Datei auf Ihrem MCP-Server, die Ihre vertrauenswürdigen Autorisierungsserver im authorization_servers-Array angibt.
|
Fehlende oder ungültige Metadaten des OAuth-Autorisierungsservers |
„Die Datei /.well-known/oauth-authorization-server ist auf dem OAuth-Server nicht vorhanden“ oder „enthält ungültiges oder unvollständiges JSON“ |
Ihr OAuth-Server stellt unter /.well-known/oauth-authorization-server kein gültiges RFC 8414-Metadatendokument bereit. |
- Hosten Sie ein gültiges RFC 8414-Discovery-Dokument unter
/.well-known/oauth-authorization-server (oder /.well-known/openid-configuration), das authorization_endpoint und token_endpoint enthält.
- Alternativ können Sie im Bereich Anmeldedaten die URLs für den benutzerdefinierten Autorisierungsendpunkt und den benutzerdefinierten Token-Endpunkt manuell eingeben.
|
Domainbestätigung schlägt fehl |
Für das Domainzertifikat wird Bestätigung fehlgeschlagen oder Bestätigung fehlgeschlagen mit einer Kurzinfo angezeigt (z. B. HTTP 404, Weiterleitung nicht zulässig oder Tokenkonflikt). |
Google konnte Ihr Challenge-Token unter https://<domain>/.well-known/google-connected-apps nicht bestätigen. |
- Datei nicht gefunden (HTTP 404): Prüfen Sie, ob der heruntergeladene
google-connected-apps.json-Inhalt unter https://<domain>/.well-known/google-connected-apps veröffentlicht ist (ohne die Erweiterung .json im URL-Pfad).
- Weiterleitungen nicht zulässig: Stellen Sie die Bestätigungsnutzlast direkt mit
HTTP 200 OK bereit. Leiten Sie /.well-known/google-connected-apps nicht an eine andere URL weiter.
- Token-Abweichung: Prüfen Sie, ob die JSON-Antwort
"verification_tokens": ["<YOUR_TOKEN>"] mit dem genauen Token enthält, das für Ihr Entwicklerkonto generiert wurde.
|
Fehler bei der dynamischen Clientregistrierung (DCR) oder CIMD |
„Dynamische Clientregistrierung (RFC 7591) fehlgeschlagen“, „Der OAuth-Server unterstützt die dynamische Clientregistrierung (RFC 7591) nicht“ oder „Registrierung des Client-ID-Metadatendokuments (CIMD) fehlgeschlagen“ |
Die automatische OAuth-Clientregistrierung ist fehlgeschlagen oder wird von Ihrem OAuth-Anbieter nicht unterstützt, oder die Weiterleitungs-URIs von Google wurden abgelehnt. |
- Achte darauf, dass dein OAuth-Server alle sechs app-spezifischen Google-Weiterleitungs-URIs auf die Zulassungsliste setzt, die unter Server-Anmeldedaten (
https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain> usw.) angezeigt werden. Beachten Sie, dass viele OAuth 2.1-Server Weiterleitungs-URIs mit Platzhaltern (*) ablehnen.
- Wenn Ihr OAuth-Anbieter CIMD oder RFC 7591 DCR nicht unterstützt, wählen Sie unter Zugriffsanmeldedaten die Option Vorregistriert (für nutzerdelegiertes OAuth) oder Maschine-zu-Maschine (OAuth-Clientanmeldedaten) aus und geben Sie eine statische Client-ID und einen statischen Clientschlüssel an.
|
OAuth-Anmelde-Pop-up blockiert oder leer |
„Das Pop-up zur Authentifizierung wurde von deinem Browser blockiert“ oder das OAuth-Anmeldefenster wird während der Synchronisierung oder des Tests des Tools nicht richtig angezeigt. |
Pop-up-Blocker im Browser oder strenge X-Frame-Options- oder Content-Security-Policy-Header auf Ihrer Anmeldeseite haben den Pop-up-Vorgang verhindert. |
- Erlauben Sie Pop‑ups für die Console in Ihrem Browser und versuchen Sie es dann noch einmal.
- Wechseln Sie in Zugangsdaten unter Mit Entwickleranmeldedaten authentifizieren von Über Pop-up authentifizieren zu Über Weiterleitung authentifizieren (Fallback), damit der Authentifizierungsablauf im Vollbildmodus im selben Tab geöffnet wird.
|
Anweisungen für den MCP-Server fehlen |
Warnmeldung: „Dein MCP-Server hat keine Anweisungen. Wir empfehlen, dem Serverschema Anweisungen hinzuzufügen.“ |
Ihr MCP-Server hat in seiner initialize-Antwort kein instructions-Feld zurückgegeben. |
- Definieren Sie Systemanweisungen explizit, wenn Sie Ihren MCP-Server initialisieren (Parameter
instructions in Ihrer Serverdefinition).
- Achten Sie bei zustandslosen oder benutzerdefinierten HTTP-Implementierungen darauf, dass das Feld
instructions in der JSON-RPC-Antwortnutzlast für die Methode initialize enthalten ist. Wählen Sie dann Tools neu synchronisieren aus.
|
Größenbeschränkung für UI-Ressourcen oder nicht unterstützter MIME-Typ |
Fehlerkarte Probleme beim Abrufen: „Die kumulative Ressourcengröße darf 100 MB nicht überschreiten.“ oder „Nicht unterstützter MIME-Typ ‚<type>‘ für Ressource ‚<uri>‘.“ |
Dein MCP-Server hat UI-Ressourcen zurückgegeben, deren Gesamtgröße das Limit überschreitet oder die einen nicht unterstützten MIME-Typ verwenden. |
- Reduzieren Sie die kumulative Größe aller Manifest-UI-Ressourcen, die von Ihrem Server zurückgegeben werden, damit das Limit nicht überschritten wird.
- Achten Sie darauf, dass alle UI-Ressourcen einen der unterstützten MIME-Typen verwenden:
text/html, text/html;profile=mcp-app, text/javascript oder text/css.
|
Symbol-Upload hängt oder „Unerwarteter Fehler“ |
Wenn Sie unter App-Details ein App-Symbol hochladen, friert der Upload bei einem Ladesymbol ein oder es wird die Meldung „Ein unerwarteter Fehler ist aufgetreten. Bitte versuche es noch einmal.“ (oft mit dem Code 4E696748). |
Dies wird in der Regel durch eine veraltete Browsersitzung, in Konflikt stehende Browsererweiterungen oder einen im Cache gespeicherten Authentifizierungsstatus verursacht. |
Führe die folgenden Schritte in der angegebenen Reihenfolge aus:
- Neues Browserprofil verwenden: Öffnen Sie ein neues Fenster mit einem neuen Browserprofil.
- Inkognitomodus / privates Surfen verwenden: Melden Sie sich in einem privaten Browserfenster in der Google Connected Console an und laden Sie das Symbol hoch.
- Cache leeren: Leeren Sie den Cache Ihres Browsers und löschen Sie die Cookies, bevor Sie es noch einmal versuchen. Prüfen Sie, ob Ihr Symbol eine gültige PNG- oder JPEG-Datei mit einer Auflösung von 512 × 512 Pixeln und einer Größe von unter 1 MB ist.
|