| المشكلة |
رسالة الخطأ |
السبب |
خطوات الإصلاح / تحديد المشاكل وحلّها |
تعذُّر استخدام "أدوات الجلب" لسبب غير محدّد |
"تعذَّر استرجاع تفاصيل خادم MCP. يُرجى إعادة المحاولة." (أو يتعطّل زر جلب الأدوات بدون رسالة خطأ محدّدة). |
تعذّر على "وحدة التحكّم الشاملة" إكمال الطلب المُرسَل إلى نقطة نهاية MCP بسبب عنوان URL غير صالح أو خادم غير متصل بالإنترنت أو خطأ في الشبكة. |
تحقَّق مما يلي:
- يُرجى التحقّق من أنّ عنوان URL لنقطة نهاية MCP دقيق ويستخدم
https://.
- تأكَّد من أنّ خادم MCP قيد التشغيل.
- تأكَّد من إمكانية الوصول إلى خادم MCP من الإنترنت العام (لا يمكن لـ Google الوصول إلى
localhost أو عناوين الشبكة الداخلية الخاصة).
|
لا يمكن الوصول إلى خادم MCP |
"لا يمكن الوصول إلى خادم MCP" |
تعذّر على الخلفية في Google إنشاء اتصال بنقطة نهاية MCP. |
تشمل الأسباب الشائعة والحلول ما يلي:
- قيود جدار الحماية: تأكَّد من أنّ جدار الحماية أو جدار حماية تطبيق الويب (WAF) لا يحظران نطاقات عناوين IP الصادرة من Google.
- قواعد بوابة واجهة برمجة التطبيقات: تأكَّد من أنّ بوابة واجهة برمجة التطبيقات تقبل طلبات
POST ولا ترفض طلبات clientInfo من Google أثناء عملية تأكيد الاتصال initialize في MCP.
- عدم تطابق النطاق الفرعي: إذا كنت تستخدم نطاقًا فرعيًا مخصّصًا (مثل
gemini.mcp.company.com)، تأكَّد من أنّ بيانات /.well-known/oauth-protected-resource الوصفية تتطابق مع هذا النطاق الفرعي بدلاً من الإشارة إلى نطاق أساسي مختلف (mcp.company.com).
|
نقل MCP غير متوافق (HTTP 405) |
"رفض خادم MCP الطلب (HTTP 405 Method Not Allowed). يُرجى التأكّد من أنّ عنوان URL يشير إلى نقطة نهاية HTTP قابلة للبث تقبل طلبات POST، وليس نقطة نهاية SSE قديمة". |
يشير عنوان URL لنقطة النهاية إلى نقطة نهاية HTTP+SSE قديمة تقبل طلبات GET فقط أو ترفض طلبات JSON-RPC POST. |
يُرجى تعديل خادم MCP وعنوان URL لنقطة النهاية لاستخدام بروتوكول نقل HTTP القابل للبث في MCP الذي يقبل طلبات POST لـ initialize وtools/list.
|
ملف المورد المحمي عبر OAuth غير متوفّر |
"لا يتوفّر ملف /.well-known/oauth-protected-resource على خادم MCP" |
حاولت Google استكشاف البيانات الوصفية للموارد المحمية في OAuth 2.0 (RFC 9728)، ولكن تعذّر ذلك. |
- إذا كان خادم MCP لا يتطلّب مصادقة: يحدث هذا الخطأ عادةً عندما يحتوي عنوان URL لنقطة نهاية MCP على خطأ إملائي أو جزء مسار مفقود (على سبيل المثال،
https://mcp.example.com بدلاً من https://mcp.example.com/mcp) ويعرض HTTP 404 أو 500، ما يؤدي إلى عودة العميل إلى عملية اكتشاف OAuth. يُرجى التأكّد من أنّ مسار نقطة نهاية MCP الدقيق يعرض HTTP 200 OK لطلبات POST initialize وtools/list غير المصادَق عليها، واختيار لا ضمن هل يتطلب الخادم تفويضًا؟ في بيانات اعتماد الوصول.
- إذا كان خادم MCP يتطلب مصادقة: استضِف ملف JSON صالحًا باسم
/.well-known/oauth-protected-resource على خادم MCP يعلن عن خوادم التفويض الموثوقة في مصفوفة authorization_servers.
|
بيانات وصفية غير متوفّرة أو غير صالحة لخادم مصادقة OAuth |
"لا يتوفّر ملف /.well-known/oauth-authorization-server على خادم OAuth" أو "يحتوي على تنسيق JSON غير صالح أو غير مكتمل" |
لا يعرض خادم OAuth مستند بيانات وصفية صالحًا وفقًا لمعيار RFC 8414 على /.well-known/oauth-authorization-server. |
- استضافة مستند استكشاف صالح RFC 8414 على
/.well-known/oauth-authorization-server (أو /.well-known/openid-configuration) يحتوي على authorization_endpoint وtoken_endpoint
- بدلاً من ذلك، في قسم بيانات الاعتماد، أدخِل عنوانَي URL لنقطة نهاية التفويض المخصّصة ونقطة نهاية الرمز المميّز المخصّصة يدويًا.
|
تعذُّر إثبات ملكية النطاق |
تعرض شهادة النطاق الرسالة "تعذّر التحقّق" أو "تعذّر إثبات الملكية" مع رسالة تلميح (مثل HTTP 404 أو إعادة التوجيه غير مسموح بها أو عدم تطابق الرمز المميّز). |
تعذّر على Google التحقّق من رمز الاختبار في https://<domain>/.well-known/google-connected-apps. |
- لم يتم العثور على الملف (HTTP 404): تأكَّد من نشر محتوى
google-connected-apps.json الذي تم تنزيله على https://<domain>/.well-known/google-connected-apps (بدون إضافة .json في مسار عنوان URL).
- عدم السماح بعمليات إعادة التوجيه: يجب عرض حمولة التحقّق مباشرةً باستخدام
HTTP 200 OK، وعدم إعادة توجيه /.well-known/google-connected-apps إلى عنوان URL آخر.
- عدم تطابق الرمز المميّز: تأكَّد من أنّ استجابة JSON تحتوي على
"verification_tokens": ["<YOUR_TOKEN>"] مع الرمز المميّز نفسه الذي تم إنشاؤه لحساب المطوّر الخاص بك.
|
تعذُّر التسجيل الديناميكي للعميل (DCR) أو مستند البيانات الوصفية لمعرّف العميل (CIMD) |
"تعذّر التسجيل الديناميكي للعميل (RFC 7591)" أو "لا يتيح خادم OAuth ميزة التسجيل الديناميكي للعميل (RFC 7591)" أو "تعذّر تسجيل مستند البيانات الوصفية لمعرّف العميل (CIMD)" |
تعذّر التسجيل التلقائي لعميل OAuth أو أنّ موفّر OAuth لا يتيحه، أو تم رفض معرّفات الموارد المنتظمة (URI) لإعادة التوجيه من Google. |
- تأكَّد من أنّ خادم OAuth يضيف جميع معرّفات الموارد المنتظمة (URI) الستة الخاصة بإعادة التوجيه من Google والخاصة بالتطبيق إلى القائمة المسموح بها، والتي تظهر ضمن بيانات اعتماد مصادقة الخادم (
https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain>، وما إلى ذلك). يُرجى العِلم أنّ العديد من خوادم OAuth 2.1 ترفض معرّفات الموارد المنتظمة (URI) لإعادة التوجيه التي تتضمّن أحرف بدل (*).
- إذا كان موفّر OAuth لا يتيح استخدام CIMD أو RFC 7591 DCR، اختَر مُسجَّل مسبقًا (لبروتوكول OAuth المفوَّض من المستخدم) أو من جهاز إلى جهاز (بيانات اعتماد عميل OAuth) في بيانات اعتماد الوصول وقدِّم معرّف عميل وسر عميل ثابتَين.
|
النافذة المنبثقة لتسجيل الدخول باستخدام OAuth محظورة أو فارغة |
"حظَر المتصفّح نافذة المصادقة المنبثقة" أو تعذّر عرض نافذة تسجيل الدخول عبر OAuth بشكل صحيح أثناء مزامنة الأداة أو اختبارها. |
منعت أدوات حظر النوافذ المنبثقة في المتصفّح أو عناوين X-Frame-Options / Content-Security-Policy الصارمة في صفحة تسجيل الدخول ظهور النافذة المنبثقة. |
- يُرجى السماح بالنوافذ المنبثقة لوحدة التحكّم في المتصفّح، ثم إعادة المحاولة.
- في بيانات اعتماد الوصول ضمن المصادقة باستخدام بيانات اعتماد المطوّر، بدِّل من المصادقة عبر نافذة منبثقة إلى المصادقة عبر إعادة التوجيه (احتياطي) لفتح مسار المصادقة في وضع ملء الشاشة في علامة التبويب نفسها.
|
تعليمات خادم MCP غير متوفّرة |
رسالة التحذير: "لا يتضمّن خادم MCP أي تعليمات. ننصحك بإضافة تعليمات إلى مخطط الخادم". |
لم يعرض خادم MCP حقل instructions في استجابة initialize. |
- حدِّد تعليمات النظام بوضوح عند إعداد خادم MCP (المَعلمة
instructions في تعريف الخادم).
- بالنسبة إلى عمليات تنفيذ HTTP المخصّصة أو التي لا تتضمّن حالة، تأكَّد من تضمين الحقل
instructions في حمولة استجابة JSON-RPC لطريقة initialize، ثم انقر على إعادة مزامنة الأدوات.
|
تجاوز الحدّ الأقصى لحجم مورد واجهة المستخدم أو نوع MIME غير متوافق |
بطاقة الخطأ مشاكل في الجلب: "لا يمكن أن يتجاوز الحجم التراكمي للموارد 100 ميغابايت" أو "نوع MIME غير متوافق '<type>' للمورد '<uri>'" |
عرض خادم MCP موارد واجهة مستخدم يتجاوز حجمها الإجمالي الحدّ الأقصى أو تستخدم نوع MIME غير متوافق. |
- قلِّل الحجم التراكمي لجميع موارد واجهة المستخدم في البيان التي يعرضها الخادم لكي لا يتجاوز الحدّ الأقصى.
- تأكَّد من أنّ جميع موارد واجهة المستخدم تستخدم أحد أنواع MIME المتوافقة:
text/html أو text/html;profile=mcp-app أو text/javascript أو text/css.
|
توقُّف تحميل الرمز أو ظهور رسالة "خطأ غير متوقّع" |
عند تحميل رمز تطبيق في تفاصيل التطبيق، يتوقف التحميل عند مؤشر التحميل أو تظهر رسالة "حدث خطأ غير متوقّع. يُرجى إعادة المحاولة" (غالبًا مع الرمز 4E696748). |
يحدث هذا الخطأ عادةً بسبب جلسة متصفّح قديمة أو إضافات متصفّح متعارضة أو حالة مصادقة مخزّنة مؤقتًا. |
جرِّب الخطوات التالية بالترتيب:
- استخدام ملف شخصي جديد في المتصفّح: افتح نافذة جديدة باستخدام ملف شخصي جديد في المتصفّح.
- استخدام وضع التصفّح المتخفي أو التصفّح بخصوصية تامة: سجِّل الدخول إلى وحدة التحكّم الشاملة من Google في نافذة تصفّح بخصوصية تامة وحمِّل الرمز.
- محو ذاكرة التخزين المؤقت: امحُ ذاكرة التخزين المؤقت وملفات تعريف الارتباط في المتصفّح قبل إعادة المحاولة، وتأكَّد من أنّ الرمز صالح بتنسيق PNG أو JPEG وبأبعاد 512 × 512 بكسل وبحجم أقل من 1 ميغابايت.
|