Google Web Toolkit

System Requirements

  • Windows XP/Vista/7 or Linux+GTK2 or OSX
    • 32-bit & 64-bit
    • Linux GTK 2.14 or higher (GTK 2.20 or higher recommended)
  • Eclipse must be launched using JDK 1.5 or higher
  • The Eclipse JDT must be fully installed. The PDE must be installed for SWT/RCP support.
  • The product may not work with remote desktop environments (except simple ones like VNC)
  • Any Eclipse 3.4, 3.5, 3.6 or 3.7 based IDE
    • Eclipse SDK 3.4.x, 3.5.x, 3.6.x, or 3.7.x (JDK 1.5 or higher)
    • Rational Application Developer 7.5.x
    • Etc.
  • XML-based APIs such as Eclipse XWT require Eclipse 3.5 or higher
    • The Eclipse XML Editors and Tools feature should be loaded for XML editing

Installing the Update Site or Zip editions for Eclipse 3.4 or above requires the full Eclipse SDK including the JDT (and PDE for SWT/RCP support). Use the Eclipse Classic, Java or RCP/RAP Developers distribution or install the JDT and PDE separately.

When using any XML-based API such as Eclipse XWT, the Eclipse XML Editors and Tools feature should be loaded into Eclipse for the optimal XML editing experience.

Except as otherwise noted, the content of this page is licensed under the Creative Commons Attribution 3.0 License.

Authentication required

You need to be signed in with Google+ to do that.

Signing you in...

Google Developers needs your permission to do that.