Le librerie ospitate da Google sono una rete di distribuzione di contenuti stabile, affidabile, ad alta velocità e disponibile a livello globale per le librerie JavaScript open source più diffuse.

Google collabora direttamente con i principali stakeholder per ogni sforzo della libreria e accetta le versioni più recenti non appena vengono rilasciate.

Librerie

Per caricare una libreria ospitata, copia e incolla lo snippet HTML della libreria (mostrato di seguito) nella tua pagina web. Ad esempio, per caricare jQuery, incorpora lo snippet <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.7.1/jquery.min.js"></script> nella pagina web.

Ti consigliamo di caricare le librerie dalla CDN tramite HTTPS, anche se il tuo sito web utilizza solo HTTP. Al giorno d'oggi le prestazioni sono rapide e la memorizzazione nella cache funziona allo stesso modo. I file della CDN vengono pubblicati con le intestazioni CORS e Timing-Allow e possono essere memorizzati nella cache per 1 anno.

CesiumJS

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/cesiumjs/1.78/Build/Cesium/Cesium.js"></script>
site:
github.com/CesiumGS/cesium
versioni:
1,78

D3.js

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/d3js/7.9.0/d3.min.js"></script>
site:
d3js.org
versions:
7,9,0, 7.8.5, 7.8.4, 7.8.3, 7.8.2, 7.8.1, 7.8.0, 7.7.0, 7.6.1, 7.4.2, 7.0.0
6.7.0, 6.6.2, 6.


Dojo

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/dojo/1.13.0/dojo/dojo.js"></script>
site:
dojotoolkit.org
versioni:
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 0 1

Ext Core

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/ext-core/3.1.0/ext-core.js"></script>
site:
sencha.com/products/extcore
versioni:
3.1.0, 3.0.0

Hammer.JS

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/hammerjs/2.0.8/hammer.min.js"></script>
site:
hammerjs.github.io
versioni:
2,0,8

Indefinite Observable

snippet:
<script type="module">
  import { IndefiniteObservable } from "https://ajax.googleapis.com/ajax/libs/indefinite-observable/2.0.1/indefinite-observable.bundle.js";
</script>
site:
https://github.com/material-motion/indetermina-observable-js
versioni:
2.0.1, 1.0.1

jQuery

Snippet 3.x:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.7.1/jquery.min.js"></script>
Snippet 2.x:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>
Snippet 1.x:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
site:
jquery.com
versioni:
.2.1.2.1.2.1.2.1, 3.1.2, 3.1.2, 3.1.0, 3.6.4, 3.6.3, 3.6.2, 3.6.1, 3.6.0, 3.5.1, 3.5.0, 3.4.1, 3.4.0, 3.2
Nota:
3.3.0, 2.1.2, 1.2.5 e 1.2.4 non sono ospitati a causa della loro breve e instabilità nella natura.

jQuery Mobile

snippet:
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jquerymobile/1.4.5/jquery.mobile.min.css">
<script src="https://ajax.googleapis.com/ajax/libs/jquerymobile/1.4.5/jquery.mobile.min.js"></script>
site:
jquerymobile.com
versioni:
1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0
Nota:
Questa libreria dipende da jQuery. Devi anche caricare jQuery prima di caricare questo modulo.

jQuery UI

snippet:
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.13.3/themes/smoothness/jquery-ui.css">
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.13.3/jquery-ui.min.js"></script>
site:
jqueryui.com
versions:
Nota:
Questa raccolta dipende da jQuery. Devi anche caricare jQuery prima di caricare questo modulo. La versione 1.8.3 non è ospitata a causa della sua breve durata e l'alias 1.8.3 in realtà carica la versione 1.8.4.

List.js

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/listjs/2.3.1/list.min.js"></script>
site:
listjs.com
versioni:
2,3,1

Material Motion

snippet:
<script type="module">
  import {
    Draggable,
    Point2DSpring,
    Tossable,
    combineStyleStreams,
    getPointerEventStreamsFromElement,
  } from "https://ajax.googleapis.com/ajax/libs/material-motion/0.1.0/material-motion.bundle.js";
</script>
site:
https://github.com/material-motion/material-motion-js
versioni:
0,1,0

Model-Viewer

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/model-viewer/3.0.0/model-viewer.min.js"></script>
site:
modelviewer.dev
versioni:
3.0.0, 2.1.1, 2.1.0, 2.0.2, 2.0.1, 2.0.0, 1.12.0, 1.11.1, 1.10.0, 1.9.0, 1.8.0, 1.7.2, 1.7.0, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1

MooTools

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/mootools/1.6.0/mootools.min.js"></script>
site:
mootools.net
versioni:
1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.2, 1.3.1, 1.3.1, 1.2.1, 1.2.1, 1.2.1.
Nota:
Per le versioni 1.5.1 e precedenti, il nome file della versione minimizzata si chiama mootools-yui-compush.js invece di mintools.min.js.

Myanmar Tools

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/myanmar-tools/1.2.1/zawgyi_detector.min.js"></script> <script src="https://ajax.googleapis.com/ajax/libs/myanmar-tools/1.2.1/zawgyi_converter.min.js"></script>
site:
https://github.com/google/myanmar-tools/
Versioni consigliate:
1,2,1
tutte le versioni ospitate:
1,0,1
1,1,0
1,1,1
1,1,3
1,2,0
1,2,1

Prototype

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/prototype/1.7.3.0/prototype.js"></script>
site:
prototypejs.org
versioni:
1.7.3.0, 1.7.2.0, 1.7.1.0, 1.7.0.0, 1.6.1.0, 1.6.0.3, 1.6.0.2

script.aculo.us

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js"></script>
site:
script.aculo.us
versioni:
1.9.0, 1.8.3, 1.8.2, 1.8.1
Nota:
Questa raccolta dipende da Prototype. Prima di caricare questo modulo, devi caricare il prototipo.

Shaka Player

snippet:
<!-- for non-UI builds: -->
<script src="https://ajax.googleapis.com/ajax/libs/shaka-player/4.10.6/shaka-player.compiled.js"></script>

<!-- or, for UI builds: -->
<script src="https://ajax.googleapis.com/ajax/libs/shaka-player/4.10.6/shaka-player.ui.js"></script>
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/shaka-player/4.10.6/controls.css">
site:
https://github.com/google/shaka-player/
maintained versions:
4.9.18, 4.8.20, 4.7.15, 4.6.18, 4.5.0, 4.4.3, 4.3.16, 4.2.14, 4.10.6
all hosted versions:
4.9.0 - 4.9.18, 4.8.0 - 4.8.20, 4.7.0 - 4.7.15, 4.6.0 - 4.6.18, 4.5.0, 4.4.0 - 4.4.3, 4.3.0 - 4.3.16, 4.2.0 - 4.2.14, 4.10.0 - 4.10.6, 4.1.0 - 4.1.7, 4.0.0 - 4.0.5, 3.3.0 - 3.3.19, 3.2.0 - 3.2.21, 3.1.0 - 3.1.8, 3.0.0 - 3.0.15, 2.5.0-beta - 2.5.23, 2.4.0 - 2.4.7, 2.3.0 - 2.3.10, 2.2.0 - 2.2.10, 2.1.0 - 2.1.9, 2.0.6 - 2.0.9, 1.6.5

SPF

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/spf/2.4.0/spf.js"></script>
site:
youtube.github.io/spfjs
versioni:
2.4.0, 2.3.2, 2.3.1, 2.3.0, 2.2.0, 2.1.2, 2.1.1, 2.1.0, 2.0.1, 2.0.0

SWFObject

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
site:
github.com/swfobject/swfobject
versioni:
2.2, 2.1

three.js

snippet:
<script src="https://ajax.googleapis.com/ajax/libs/threejs/r84/three.min.js"></script>
site:
threejs.org
versioni:
r84, r83, r82, r81, r80, r79, r78, r77, r76, r75, r74, r73, r72, r71, r70, r69, r68, r67, r49

Web Font Loader

snippet&GT;
<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js"></script>
site:
github.com/typekit/webfontloader
versioni:
1.6.26, 1.6.16, 1.5.18, 1.5.10, 1.5.6, 1.5.3, 1.5.2, 1.5.0

Risolvere i problemi

Vedi una versione obsoleta? Assicurati di non utilizzare i link della "versione automatica", come /jqueryui/1/..., ma di usare invece URL che fanno riferimento alle versioni esatte. A causa di problemi relativi alla memorizzazione nella cache e alla mancanza di compatibilità tra versioni anche secondarie, abbiamo deprecato e interrotto l'aggiornamento degli alias versione automatici qualche tempo fa, pertanto faranno riferimento definitivamente a una versione precedente (per non interrompere i siti esistenti che li utilizzano ancora).

In caso di problemi:

  • Controlla che non ci siano errori di battitura. Ricorda che JavaScript è un linguaggio che fa distinzione tra maiuscole e minuscole.
  • Utilizzare un debugger JavaScript. In Chrome, utilizza Chrome DevTools. In Firefox, puoi utilizzare Firefox DevTools integrato. In IE puoi utilizzare gli strumenti per sviluppatori F12.