reCAPTCHA

Using reCAPTCHA with phpBB2

The reCAPTCHA phpBB2 plugin uses a CAPTCHA to prevent forum spam.

We recommend that you use the reCAPTCHA phpBB MOD to install reCAPTCHA. There are two mods available, one for registration and one for guest posts.

In addition to the phpBB MOD, there's also a patch to enable reCAPTCHA on registration. To install reCAPTCHA using a patch, follow these directions:

  1. Download the zip file and extract.
  2. Move the file recaptchalib.php to your phpBB includes directory.
  3. Apply the first patch by running the following command from your phpBB includes directory:
    patch -b usercp_register.php < /path/to/usercp_register.patch
  4. Move the profile_add_body.tpl.patch file to the phpBB templates/<your_theme> directory (by default <your_theme> is 'subSilver')
  5. Apply the second patch by running the following command from the phpBB templates/<your_theme> directory:
    patch -b profile_add_body.tpl < /path/to/profile_add_body.tpl.patch
  6. Sign-up for reCAPTCHA keys here. reCAPTCHA will issue you a public and private key. Open usercp_register.php in your includes directory and update the $recaptcha_public_key and $recaptcha_private_key with the values you were issued.
  7. That's it! Your reCAPTCHA widget should now appear on the user registration page.

FAQ

What if the patch command fails?

The patch was created using unified diff (diff -u). Different versions of this file or other modifications may cause a conflict. You can study the patch file to see what is being modified and how this caused a conflict with your file.

I want to roll back the patch changes or uninstall reCAPTCHA, how do I do this?

When you ran the patch command with the '-b' option, a backup of files was made in the same directory. Use the mv command to overwrite the patched file with the original. You can also delete the recaptchalib.php file from your includes directory.

Требуется аутентификация

Чтобы выполнить это действие, необходимо войти в аккаунт Google+.

Выполняется вход...

Google Developers требуется ваше разрешение на эту операцию.