Prerequisites

Select one of the following protocols to learn more about the prerequisites for its integration process.


This section outlines the prerequisites to start the integration process with the NXP MIFARE DESFire or MIFARE Plus protocols:

  • Sign a non-disclosure agreement (NDA) with Google. This click-to-accept online form is shared by Google's business development team.
  • Engage with NXP to get a TSH license, and agree to their terms and conditions.
  • Confirm that your fare validators and terminals have MIFARE DESFire or MIFARE Plus. Google Pay doesn't work with MIFARE classic. Any MIFARE classic terminals need to be upgraded to either DESFire or Plus.
  • Ensure that your Android-powered phones have Google Play services version 20.0.0 or later.
  • Adhere to our Terms of Service guidelines and the Google Play developer policy for payments.

If you meet all of these prerequisite requirements, fill out the Interest form for Google Pay Transit.