# InetAddress

public class **InetAddress** extends [Object](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html)  
implements [Serializable](https://developers.google.com/j2objc/javadoc/jre/reference/java/io/Serializable.html)

|---|---|---|
| Known Direct Subclasses [Inet4Address](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet4Address.html), [Inet6Address](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet6Address.html) |---|---| | [Inet4Address](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet4Address.html) | This class represents an Internet Protocol version 4 (IPv4) address. | | [Inet6Address](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet6Address.html) | This class represents an Internet Protocol version 6 (IPv6) address. | |||

This class represents an Internet Protocol (IP) address.

An IP address is either a 32-bit or 128-bit unsigned number
used by IP, a lower-level protocol on which protocols like UDP and
TCP are built. The IP address architecture is defined by [*RFC 790: Assigned Numbers*](http://www.ietf.org/rfc/rfc790.txt), [*RFC 1918: Address Allocation for Private Internets*](http://www.ietf.org/rfc/rfc1918.txt), [*RFC 2365: Administratively Scoped IP Multicast*](http://www.ietf.org/rfc/rfc2365.txt), and [*RFC 2373: IP Version 6 Addressing Architecture*](http://www.ietf.org/rfc/rfc2373.txt). An instance of an
InetAddress consists of an IP address and possibly its
corresponding host name (depending on whether it is constructed
with a host name or whether it has already done reverse host name
resolution).

### Address types

> | *unicast* | An identifier for a single interface. A packet sent to a unicast address is delivered to the interface identified by that address. The Unspecified Address -- Also called anylocal or wildcard address. It must never be assigned to any node. It indicates the absence of an address. One example of its use is as the target of bind, which allows a server to accept a client connection on any interface, in case the server host has multiple interfaces. The *unspecified* address must not be used as the destination address of an IP packet. The *Loopback* Addresses -- This is the address assigned to the loopback interface. Anything sent to this IP address loops around and becomes IP input on the local host. This address is often used when testing a client. |
> | *multicast* | An identifier for a set of interfaces (typically belonging to different nodes). A packet sent to a multicast address is delivered to all interfaces identified by that address. |
> |---|---|

#### IP address scope

*Link-local* addresses are designed to be used for addressing
on a single link for purposes such as auto-address configuration,
neighbor discovery, or when no routers are present.

*Site-local* addresses are designed to be used for addressing
inside of a site without the need for a global prefix.

*Global* addresses are unique across the internet.

#### Textual representation of IP addresses

The textual representation of an IP address is address family specific.


For IPv4 address format, please refer to [Inet4Address#format](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet4Address#format); For IPv6
address format, please refer to [Inet6Address#format](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet6Address#format).

There is a [couple of
System Properties](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/doc-files/net-properties#Ipv4IPv6) affecting how IPv4 and IPv6 addresses are used.

#### Host Name Resolution

Host name-to-IP address *resolution* is accomplished through the use of a combination of local machine configuration information and network naming services such as the Domain Name System (DNS) and Network Information Service(NIS). The particular naming services(s) being used is by default the local machine configured one. For any host name, its corresponding IP address is returned.

*Reverse name resolution* means that for any IP address,
the host associated with the IP address is returned.

The InetAddress class provides methods to resolve host names to
their IP addresses and vice versa.

#### InetAddress Caching

The InetAddress class has a cache to store successful as well as unsuccessful host name resolutions.

By default, when a security manager is installed, in order to
protect against DNS spoofing attacks,
the result of positive host name resolutions are
cached forever. When a security manager is not installed, the default
behavior is to cache entries for a finite (implementation dependent)
period of time. The result of unsuccessful host
name resolution is cached for a very short period of time (10
seconds) to improve performance.

If the default behavior is not desired, then a Java security property
can be set to a different Time-to-live (TTL) value for positive
caching. Likewise, a system admin can configure a different
negative caching TTL value when needed.

Two Java security properties control the TTL values used for
positive and negative host name resolution caching:

> **networkaddress.cache.ttl**
>
> :   Indicates the caching policy for successful name lookups from the name service. The value is specified as as integer to indicate the number of seconds to cache the successful lookup. The default setting is to cache for an implementation specific period of time.
>     A value of -1 indicates "cache forever".
>
> **networkaddress.cache.negative.ttl** (default: 10)
>
> :   Indicates the caching policy for un-successful name lookups from the name service. The value is specified as as integer to indicate the number of seconds to cache the failure for un-successful lookups.
>     A value of 0 indicates "never cache".
>     A value of -1 indicates "cache forever".

<br />

##### See Also

- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByAddress(byte[])`
- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByAddress(java.lang.String,%20byte[])`
- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getAllByName(java.lang.String)`
- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByName(java.lang.String)`
- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getLocalHost()`

### Public Method Summary

|---|---|
| boolean | [equals](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#equals(java.lang.Object))([Object](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html) obj) Compares this object against the specified object. |
| byte\[\] | [getAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getAddress())() Returns the raw IP address of this `InetAddress` object. |
| static [InetAddress\[\]](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getAllByName](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getAllByName(java.lang.String))([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host) Given the name of a host, returns an array of its IP addresses, based on the configured name service on the system. |
| static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getByAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByAddress(byte[]))(byte\[\] addr) Returns an `InetAddress` object given the raw IP address . |
| static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getByAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByAddress(java.lang.String,%20byte[],%20int))([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host, byte\[\] addr, int scopeId) |
| static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getByAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByAddress(java.lang.String,%20byte[]))([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host, byte\[\] addr) Creates an InetAddress based on the provided host name and IP address. |
| static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getByName](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByName(java.lang.String))([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host) Determines the IP address of a host, given the host's name. |
| [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) | [getCanonicalHostName](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getCanonicalHostName())() Gets the fully qualified domain name for this IP address. |
| [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) | [getHostAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getHostAddress())() Returns the IP address string in textual presentation. |
| [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) | [getHostName](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getHostName())() Gets the host name for this IP address. |
| static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getLocalHost](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getLocalHost())() Returns the address of the local host. |
| static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html) | [getLoopbackAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getLoopbackAddress())() Returns the loopback address. |
| int | [hashCode](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#hashCode())() Returns a hashcode for this IP address. |
| boolean | [isAnyLocalAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isAnyLocalAddress())() Utility routine to check if the InetAddress in a wildcard address. |
| boolean | [isLinkLocalAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isLinkLocalAddress())() Utility routine to check if the InetAddress is an link local address. |
| boolean | [isLoopbackAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isLoopbackAddress())() Utility routine to check if the InetAddress is a loopback address. |
| boolean | [isMCGlobal](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isMCGlobal())() Utility routine to check if the multicast address has global scope. |
| boolean | [isMCLinkLocal](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isMCLinkLocal())() Utility routine to check if the multicast address has link scope. |
| boolean | [isMCNodeLocal](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isMCNodeLocal())() Utility routine to check if the multicast address has node scope. |
| boolean | [isMCOrgLocal](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isMCOrgLocal())() Utility routine to check if the multicast address has organization scope. |
| boolean | [isMCSiteLocal](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isMCSiteLocal())() Utility routine to check if the multicast address has site scope. |
| boolean | [isMulticastAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isMulticastAddress())() Utility routine to check if the InetAddress is an IP multicast address. |
| boolean | [isReachable](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isReachable(int))(int timeout) Test whether that address is reachable. |
| boolean | [isReachable](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isReachable(java.net.NetworkInterface,%20int,%20int))([NetworkInterface](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/NetworkInterface.html) netif, int ttl, int timeout) Test whether that address is reachable. |
| boolean | [isSiteLocalAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#isSiteLocalAddress())() Utility routine to check if the InetAddress is a site local address. |
| [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) | [toString](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#toString())() Converts this IP address to a `String`. |

### Inherited Method Summary

From class [java.lang.Object](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html)

|---|---|
| [Object](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html) | [clone](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#clone())() Creates and returns a copy of this `Object`. |
| boolean | [equals](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#equals(java.lang.Object))([Object](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html) obj) Compares this instance with the specified object and indicates if they are equal. |
| void | [finalize](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#finalize())() Invoked when the garbage collector has detected that this instance is no longer reachable. |
| final [Class](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Class.html)\<?\> | [getClass](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#getClass())() Returns the unique instance of `https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Class.html` that represents this object's class. |
| int | [hashCode](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#hashCode())() Returns an integer hash code for this object. |
| final void | [notify](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#notify())() Causes a thread which is waiting on this object's monitor (by means of calling one of the `wait()` methods) to be woken up. |
| final void | [notifyAll](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#notifyAll())() Causes all threads which are waiting on this object's monitor (by means of calling one of the `wait()` methods) to be woken up. |
| [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) | [toString](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#toString())() Returns a string containing a concise, human-readable description of this object. |
| final void | [wait](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#wait(long,%20int))(long timeout, int nanos) Causes the calling thread to wait until another thread calls the `notify()` or `notifyAll()` method of this object or until the specified timeout expires. |
| final void | [wait](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#wait(long))(long timeout) Causes the calling thread to wait until another thread calls the `notify()` or `notifyAll()` method of this object or until the specified timeout expires. |
| final void | [wait](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html#wait())() Causes the calling thread to wait until another thread calls the `notify()` or `notifyAll()` method of this object. |

## Public Methods

#### public boolean
**equals**
([Object](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/Object.html) obj)

Compares this object against the specified object.
The result is `true` if and only if the argument is
not `null` and it represents the same IP address as
this object.


Two instances of `InetAddress` represent the same IP
address if the length of the byte arrays returned by
`getAddress` is the same for both, and each of the
array components is the same for the byte arrays.

##### Parameters

| obj | the object to compare against. |
|---|---|

##### Returns

- `true` if the objects are the same; `false` otherwise.

##### See Also

- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getAddress()`

#### public byte\[\]
**getAddress**
()

Returns the raw IP address of this `InetAddress`
object. The result is in network byte order: the highest order
byte of the address is in `getAddress()[0]`.

##### Returns

- the raw IP address of this object.

#### public static [InetAddress\[\]](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getAllByName**
([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host)

Given the name of a host, returns an array of its IP addresses,
based on the configured name service on the system.

The host name can either be a machine name, such as
"`java.sun.com`", or a textual representation of its IP
address. If a literal IP address is supplied, only the
validity of the address format is checked.

For `host` specified in *literal IPv6 address*,
either the form defined in RFC 2732 or the literal IPv6 address
format defined in RFC 2373 is accepted. A literal IPv6 address may
also be qualified by appending a scoped zone identifier or scope_id.
The syntax and usage of scope_ids is described
[here](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet6Address#scoped).

If the host is `null` then an `InetAddress`
representing an address of the loopback interface is returned.
See [RFC 3330](http://www.ietf.org/rfc/rfc3330.txt)
section 2 and [RFC 2373](http://www.ietf.org/rfc/rfc2373.txt)
section 2.5.3.

If there is a security manager and `host` is not
null and `host.length() ` is not equal to zero, the
security manager's
`checkConnect` method is called
with the hostname and `-1`
as its arguments to see if the operation is allowed.

##### Parameters

| host | the name of the host, or `null`. |
|---|---|

##### Returns

- an array of all the IP addresses for a given host name.

##### Throws

| [UnknownHostException](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/UnknownHostException.html) | if no IP address for the `host` could be found, or if a scope_id was specified for a global IPv6 address. |
| [SecurityException](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/SecurityException.html) | if a security manager exists and its `checkConnect` method doesn't allow the operation. |
|---|---|

##### See Also

- `https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/SecurityManager.html#checkConnect(java.lang.String,%20int)`

#### public static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getByAddress**
(byte\[\] addr)

Returns an `InetAddress` object given the raw IP address .
The argument is in network byte order: the highest order
byte of the address is in `getAddress()[0]`.

This method doesn't block, i.e. no reverse name service lookup
is performed.

IPv4 address byte array must be 4 bytes long and IPv6 byte array
must be 16 bytes long

##### Parameters

| addr | the raw IP address in network byte order |
|---|---|

##### Returns

- an InetAddress object created from the raw IP address.

##### Throws

| [UnknownHostException](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/UnknownHostException.html) | if IP address is of illegal length |
|---|---|

#### public static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getByAddress**
([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host, byte\[\] addr, int scopeId)

<br />

##### Parameters

| host |   |
| addr |   |
| scopeId |   |
|---|---|

##### Throws

| [UnknownHostException](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/UnknownHostException.html) |   |
|---|---|

#### public static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getByAddress**
([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host, byte\[\] addr)

Creates an InetAddress based on the provided host name and IP address.
No name service is checked for the validity of the address.

The host name can either be a machine name, such as
"`java.sun.com`", or a textual representation of its IP
address.

No validity checking is done on the host name either.

If addr specifies an IPv4 address an instance of Inet4Address
will be returned; otherwise, an instance of Inet6Address
will be returned.

IPv4 address byte array must be 4 bytes long and IPv6 byte array
must be 16 bytes long

##### Parameters

| host | the specified host |
| addr | the raw IP address in network byte order |
|---|---|

##### Returns

- an InetAddress object created from the raw IP address.

##### Throws

| [UnknownHostException](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/UnknownHostException.html) | if IP address is of illegal length |
|---|---|

#### public static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getByName**
([String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html) host)

Determines the IP address of a host, given the host's name.

The host name can either be a machine name, such as
"`java.sun.com`", or a textual representation of its
IP address. If a literal IP address is supplied, only the
validity of the address format is checked.

For `host` specified in literal IPv6 address,
either the form defined in RFC 2732 or the literal IPv6 address
format defined in RFC 2373 is accepted. IPv6 scoped addresses are also
supported. See [here](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/Inet6Address#scoped) for a description of IPv6
scoped addresses.

If the host is `null` then an `InetAddress`
representing an address of the loopback interface is returned.
See [RFC 3330](http://www.ietf.org/rfc/rfc3330.txt)
section 2 and [RFC 2373](http://www.ietf.org/rfc/rfc2373.txt)
section 2.5.3.

<br />

##### Parameters

| host | the specified host, or `null`. |
|---|---|

##### Returns

- an IP address for the given host name.

##### Throws

| [UnknownHostException](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/UnknownHostException.html) | if no IP address for the `host` could be found, or if a scope_id was specified for a global IPv6 address. |
| [SecurityException](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/SecurityException.html) | if a security manager exists and its checkConnect method doesn't allow the operation |
|---|---|

#### public [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html)
**getCanonicalHostName**
()

Gets the fully qualified domain name for this IP address.
Best effort method, meaning we may not be able to return
the FQDN depending on the underlying system configuration.

If there is a security manager, this method first
calls its `checkConnect` method
with the hostname and `-1`
as its arguments to see if the calling code is allowed to know
the hostname for this IP address, i.e., to connect to the host.
If the operation is not allowed, it will return
the textual representation of the IP address.

##### Returns

- the fully qualified domain name for this IP address, or if the operation is not allowed by the security check, the textual representation of the IP address.

##### See Also

- `https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/SecurityManager.html#checkConnect(java.lang.String,%20int)`

#### public [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html)
**getHostAddress**
()

Returns the IP address string in textual presentation.

##### Returns

- the raw IP address in a string format.

#### public [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html)
**getHostName**
()

Gets the host name for this IP address.

If this InetAddress was created with a host name,
this host name will be remembered and returned;
otherwise, a reverse name lookup will be performed
and the result will be returned based on the system
configured name lookup service. If a lookup of the name service
is required, call
`https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getCanonicalHostName()`.

If there is a security manager, its
`checkConnect` method is first called
with the hostname and `-1`
as its arguments to see if the operation is allowed.
If the operation is not allowed, it will return
the textual representation of the IP address.

##### Returns

- the host name for this IP address, or if the operation is not allowed by the security check, the textual representation of the IP address.

##### See Also

- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getCanonicalHostName()`
- `https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/SecurityManager.html#checkConnect(java.lang.String,%20int)`

#### public static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getLocalHost**
()

Returns the address of the local host. This is achieved by retrieving
the name of the host from the system, then resolving that name into
an `InetAddress`.

Note: The resolved address may be cached for a short period of time.

If there is a security manager, its
`checkConnect` method is called
with the local host name and `-1`
as its arguments to see if the operation is allowed.
If the operation is not allowed, an InetAddress representing
the loopback address is returned.

##### Returns

- the address of the local host.

##### Throws

| [UnknownHostException](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/UnknownHostException.html) | if the local host name could not be resolved into an address. |
|---|---|

##### See Also

- `https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/SecurityManager.html#checkConnect(java.lang.String,%20int)`
- `https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html#getByName(java.lang.String)`

#### public static [InetAddress](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/InetAddress.html)
**getLoopbackAddress**
()

Returns the loopback address.


The InetAddress returned will represent the IPv4
loopback address, 127.0.0.1, or the IPv6 loopback
address, ::1. The IPv4 loopback address returned
is only one of many in the form 127.\*.\*.\*

##### Returns

- the InetAddress loopback instance.

#### public int
**hashCode**
()

Returns a hashcode for this IP address.

##### Returns

- a hash code value for this IP address.

#### public boolean
**isAnyLocalAddress**
()

Utility routine to check if the InetAddress in a wildcard address.

##### Returns

- a `boolean` indicating if the Inetaddress is a wildcard address.

#### public boolean
**isLinkLocalAddress**
()

Utility routine to check if the InetAddress is an link local address.

##### Returns

- a `boolean` indicating if the InetAddress is a link local address; or false if address is not a link local unicast address.

#### public boolean
**isLoopbackAddress**
()

Utility routine to check if the InetAddress is a loopback address.

##### Returns

- a `boolean` indicating if the InetAddress is a loopback address; or false otherwise.

#### public boolean
**isMCGlobal**
()

Utility routine to check if the multicast address has global scope.

##### Returns

- a `boolean` indicating if the address has is a multicast address of global scope, false if it is not of global scope or it is not a multicast address

#### public boolean
**isMCLinkLocal**
()

Utility routine to check if the multicast address has link scope.

##### Returns

- a `boolean` indicating if the address has is a multicast address of link-local scope, false if it is not of link-local scope or it is not a multicast address

#### public boolean
**isMCNodeLocal**
()

Utility routine to check if the multicast address has node scope.

##### Returns

- a `boolean` indicating if the address has is a multicast address of node-local scope, false if it is not of node-local scope or it is not a multicast address

#### public boolean
**isMCOrgLocal**
()

Utility routine to check if the multicast address has organization scope.

##### Returns

- a `boolean` indicating if the address has is a multicast address of organization-local scope, false if it is not of organization-local scope or it is not a multicast address

#### public boolean
**isMCSiteLocal**
()

Utility routine to check if the multicast address has site scope.

##### Returns

- a `boolean` indicating if the address has is a multicast address of site-local scope, false if it is not of site-local scope or it is not a multicast address

#### public boolean
**isMulticastAddress**
()

Utility routine to check if the InetAddress is an
IP multicast address.

##### Returns

- a `boolean` indicating if the InetAddress is an IP multicast address

#### public boolean
**isReachable**
(int timeout)

Test whether that address is reachable. Best effort is made by the
implementation to try to reach the host, but firewalls and server
configuration may block requests resulting in a unreachable status
while some specific ports may be accessible.


Android implementation attempts ICMP ECHO REQUESTs first, on failure it
will fall back to TCP ECHO REQUESTs. Success on either protocol will
return true.


The timeout value, in milliseconds, indicates the maximum amount of time
the try should take. If the operation times out before getting an
answer, the host is deemed unreachable. A negative value will result
in an IllegalArgumentException being thrown.

##### Parameters

| timeout | the time, in milliseconds, before the call aborts |
|---|---|

##### Returns

- a `boolean` indicating if the address is reachable.

##### Throws

| [IOException](https://developers.google.com/j2objc/javadoc/jre/reference/java/io/IOException.html) | if a network error occurs |
| [IllegalArgumentException](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/IllegalArgumentException.html) | if `timeout` is negative. |
|---|---|

#### public boolean
**isReachable**
([NetworkInterface](https://developers.google.com/j2objc/javadoc/jre/reference/java/net/NetworkInterface.html) netif, int ttl, int timeout)

Test whether that address is reachable. Best effort is made by the
implementation to try to reach the host, but firewalls and server
configuration may block requests resulting in a unreachable status
while some specific ports may be accessible.


Android implementation attempts ICMP ECHO REQUESTs first, on failure it
will fall back to TCP ECHO REQUESTs. Success on either protocol will
return true.


The `network interface` and `ttl` parameters
let the caller specify which network interface the test will go through
and the maximum number of hops the packets should go through.
A negative value for the `ttl` will result in an
IllegalArgumentException being thrown.


The timeout value, in milliseconds, indicates the maximum amount of time
the try should take. If the operation times out before getting an
answer, the host is deemed unreachable. A negative value will result
in an IllegalArgumentException being thrown.

##### Parameters

| netif | the NetworkInterface through which the test will be done, or null for any interface |
| ttl | the maximum numbers of hops to try or 0 for the default |
| timeout | the time, in milliseconds, before the call aborts |
|---|---|

##### Returns

- a `boolean`indicating if the address is reachable.

##### Throws

| [IllegalArgumentException](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/IllegalArgumentException.html) | if either `timeout` or `ttl` are negative. |
| [IOException](https://developers.google.com/j2objc/javadoc/jre/reference/java/io/IOException.html) | if a network error occurs |
|---|---|

#### public boolean
**isSiteLocalAddress**
()

Utility routine to check if the InetAddress is a site local address.

##### Returns

- a `boolean` indicating if the InetAddress is a site local address; or false if address is not a site local unicast address.

#### public [String](https://developers.google.com/j2objc/javadoc/jre/reference/java/lang/String.html)
**toString**
()

Converts this IP address to a `String`. The
string returned is of the form: hostname / literal IP
address.

If the host name is unresolved, no reverse name service lookup
is performed. The hostname part will be represented by an empty string.

##### Returns

- a string representation of this IP address.