Google Plugin for Eclipse

DataNucleus libraries for JPA and JDO

App Engine supports the JDO and JPA standards for storing objects into a database. The App Engine SDK carries the DataNucleus libraries that implement these standards.

Version 1 of the DataNucleus library supports JDO 2.3 and JPA 1.0.

Version 2 of the DataNucleus library is an experimental, innovative, and rapidly changing new feature for Google App Engine. It supports JDO 3.0 and JPA 2.0.

From Google Plugin for Eclipse 3.1.0 onwards, you can select the DataNucleus library version that want to use in your App Engine project under Properties > Google > App Engine > Datastore

Authentication required

You need to be signed in with Google+ to do that.

Signing you in...

Google Developers needs your permission to do that.