Google Apps Script

Supported Style Attributes

Here is a list of style attributes that are currently supported by the Ui Services:

background
backgroundAttachment
backgroundColor
backgroundImage
backgroundImageResolution
backgroundPosition
backgroundRepeat
bleed
bookmarkLabel
bookmarkLevel
bookmarkState
bookmarkTarget
border
borderBottom
borderBottomColor
borderBottomLeftRadius
borderBottomRightRadius
borderBottomStyle
borderBottomWidth
borderCollapse
borderColor
borderLeft
borderLeftColor
borderLeftStyle
borderLeftWidth
borderRadius
borderRight
borderRightColor
borderRightStyle
borderRightWidth
borderSpacing
borderStyle
borderTop
borderTopColor
borderTopLeftRadius
borderTopRightRadius
borderTopStyle
borderTopWidth
borderWidth
bottom
captionPage
captionSide
clear
clip
color
columnBreakAfter
columnBreakBefore
columnCount
columnFill
columnGap
columnRule
columnRuleColor
columnRuleStyle
columnRuleWidth
columnWidth
columns
content
counterIncrement
counterReset
cursor
direction
display
emptyCells
float
flow
font
fontFamily
fontSize
fontStretch
fontStyle
fontVariant
fontWeight
footnoteStylePosition
height
hyphenateAfter
hyphenateBefore
hyphenateLines
hyphenatePatterns
hyphens
imageResolution
left
letterSpacing
lineHeight
lineStackingStrategy
link
listStyle
listStyleImage
listStylePosition
listStyleType
margin
marginBottom
marginInside
marginLeft
marginOutside
marginRight
marginTop
marks
maxHeight
maxWidth
minHeight
minWidth
opacity
orphans
overflow
padding
paddingBottom
paddingLeft
paddingRight
paddingTop
page
pageBreakAfter
pageBreakBefore
pageBreakInside
position
right
size
stringSet
tableColumnSpan
tableLayout
tableRowSpan
textAlign
textAlignLast
textDecoration
textHeight
textIndent
textLineThrough
textLineThroughColor
textLineThroughStyle
textOverline
textOverlineColor
textOverlineStyle
textTransform
textUnderline
textUnderlineColor
textUnderlineStyle
top
verticalAlign
visibility
whiteSpace
widows
width
wordSpacing
zIndex

Authentication required

You need to be signed in with Google+ to do that.

Signing you in...

Google Developers needs your permission to do that.