Installation

This page contains information about installing the Google API Client Library for Ruby.

System requirements

  • Operating systems:
    • Linux
    • Mac OS X
    • Windows

    Note: This library is pure Ruby, so other operating systems with Ruby support may work as well.

  • Ruby: Version 2.0 or higher.
  • RubyGems: Version 1.3.6 or higher.

Getting started: Installing the gem

To install the library and all of its dependencies, open a terminal and install using RubyGems:

$ gem install google-api-client

If you already have the gem installed and would simply like to update to the latest version:

$ gem update -y google-api-client

Depending on your system, you may need to prepend these commands with sudo.

Finding the samples

You can find samples for multiple APIs in a separate GitHub repository.