Safe Browsing API Client Library for Ruby

Safe Browsing API: Enables client applications to check web resources (most commonly URLs) against Google-generated lists of unsafe web resources.

This page contains information about getting started with the Safe Browsing API using the Google API Client Library for Ruby. In addition, you may be interested in the following documentation:

Installing the google-api-client gem

If you haven't installed the Google API Client Library for Ruby before, open a terminal and install using RubyGems:

$ gem install google-api-client

If you already have the gem installed and would simply like to update to the latest version:

$ gem update -y google-api-client

Depending on your system, you may need to prepend these commands with sudo.

Getting started with the Google API Client Library for Ruby

Be sure to check our extensive Getting started guide for a quick overview of how to make your first request.