Note: Version v201902 will be sunset soon. All users of those versions must migrate to a newer one.

enum ProgrammaticEntitiesError.Reason (v201902)

The reasons for the target error.


Namespace
https://www.google.com/apis/ads/publisher/v201902
Enumeration Description
INVALID_RATE_TYPE RateType is not supported.
INVALID_ENVIRONMENT_TYPE EnvironmentType must match AdExchange environment.
INVALID_PRODUCT_TYPE ProductType is not supported.
INVALID_LINE_ITEM_TYPE LineItemType is not supported.
INVALID_ROADBLOCKING_TYPE RoadblockingType is not supported.
INVALID_DELIVERY_RATE_TYPE DeliveryRateType is not supported.
INVALID_COMPANION_DELIVERY_OPTION CompanionDeliveryOption is not supported.
INVALID_CREATIVE_ROTATION_TYPE CreativeRotationType is not supported.
INVALID_COMPANION_CREATIVE_PLACEHOLDER CreativePlaceholder should not have companions.
EMPTY_CREATIVE_PLACEHOLDER Creative placeholders cannot be null or empty.
UNKNOWN The value returned if the actual value is not exposed by the requested API version.