enum InventoryTargetingError.Reason (v201808)

The reasons for the target error.


Namespace
https://www.google.com/apis/ads/publisher/v201808
Enumeration Description
AT_LEAST_ONE_PLACEMENT_OR_INVENTORY_UNIT_REQUIRED At least one placement or inventory unit is required
INVENTORY_CANNOT_BE_TARGETED_AND_EXCLUDED The same inventory unit or placement cannot be targeted and excluded at the same time
INVENTORY_UNIT_CANNOT_BE_TARGETED_IF_ANCESTOR_IS_TARGETED A child inventory unit cannot be targeted if its ancestor inventory unit is also targeted.
INVENTORY_UNIT_CANNOT_BE_TARGETED_IF_ANCESTOR_IS_EXCLUDED A child inventory unit cannot be targeted if its ancestor inventory unit is excluded.
INVENTORY_UNIT_CANNOT_BE_EXCLUDED_IF_ANCESTOR_IS_EXCLUDED A child inventory unit cannot be excluded if its ancestor inventory unit is also excluded.
EXPLICITLY_TARGETED_INVENTORY_UNIT_CANNOT_BE_TARGETED An explicitly targeted inventory unit cannot be targeted.
EXPLICITLY_TARGETED_INVENTORY_UNIT_CANNOT_BE_EXCLUDED An explicitly targeted inventory unit cannot be excluded.
SELF_ONLY_INVENTORY_UNIT_NOT_ALLOWED A landing page-only ad unit cannot be targeted.
SELF_ONLY_INVENTORY_UNIT_WITHOUT_DESCENDANTS A landing page-only ad unit cannot be targeted if it doesn't have any children.
YOUTUBE_AUDIENCE_SEGMENTS_CAN_ONLY_BE_TARGETED_WITH_YOUTUBE_SHARED_INVENTORY Audience segments shared from YouTube can only be targeted with inventory shared from YouTube for cross selling.
UNKNOWN The value returned if the actual value is not exposed by the requested API version.

Send feedback about...

Ad Manager API
Ad Manager API
Need help? Visit our support page.